aboutsummaryrefslogtreecommitdiff
path: root/devel/cgit/Makefile
diff options
context:
space:
mode:
authorAntoine Brodin <antoine@FreeBSD.org>2013-06-16 23:14:41 +0000
committerAntoine Brodin <antoine@FreeBSD.org>2013-06-16 23:14:41 +0000
commite05ce9f2b30830654110c0f5cca055afc850e739 (patch)
treedd5eb230e9497082e4fc7b88a0137ef4a9fdaa31 /devel/cgit/Makefile
parent7505e5bcb8c205e8fe24bed23354de638aa9234b (diff)
downloadports-e05ce9f2b30830654110c0f5cca055afc850e739.tar.gz
ports-e05ce9f2b30830654110c0f5cca055afc850e739.zip
- Fix build WITHOUT_NLS, NO_GETTEXT must be passed to make
- Fix plist with pkg_install - Pass maintainership to reporter PR: ports/179599 Reported by: Kevin Zheng
Notes
Notes: svn path=/head/; revision=321081
Diffstat (limited to 'devel/cgit/Makefile')
-rw-r--r--devel/cgit/Makefile12
1 files changed, 6 insertions, 6 deletions
diff --git a/devel/cgit/Makefile b/devel/cgit/Makefile
index 5448c561f7e1..984d98f528f4 100644
--- a/devel/cgit/Makefile
+++ b/devel/cgit/Makefile
@@ -3,15 +3,15 @@
PORTNAME= cgit
PORTVERSION= 0.9.2
-PORTREVISION= 2
+PORTREVISION= 3
CATEGORIES= devel www
MASTER_SITES= http://git.zx2c4.com/cgit/snapshot/:cgit \
GOOGLE_CODE:git
DISTFILES= cgit-${PORTVERSION}${EXTRACT_SUFX}:cgit \
git-${GIT_VERSION}.tar.gz:git
-MAINTAINER= ports@FreeBSD.org
-COMMENT= Fast webinterface for git
+MAINTAINER= kevinz5000@gmail.com
+COMMENT= Fast web frontend for Git repositories
LICENSE= GPLv2
@@ -23,15 +23,15 @@ USES= iconv shebangfix
SHEBANG_FILES= filters/html-converters/resources/markdown.pl
USE_GMAKE= yes
USE_OPENSSL= yes
-CFLAGS+= -I${LOCALBASE}/include -DNO_GETTEXT=1
+CFLAGS+= -I${LOCALBASE}/include
MAKE_ARGS+= CGIT_SCRIPT_PATH=${WWWDIR} \
- CGIT_CONFIG=${PREFIX}/etc/cgitrc
+ CGIT_CONFIG=${PREFIX}/etc/cgitrc NO_GETTEXT=1
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_JOBS_SAFE= yes
SUB_FILES= pkg-message
SUB_LIST+= PORTNAME=${PORTNAME}
-PLIST_SUB+= PORTNAME=${PORTNAME}
+PLIST_SUB+= PORTNAME=${PORTNAME} WWWOWN=${WWWOWN} WWWGRP=${WWWGRP}
.include <bsd.port.options.mk>