aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-infix/Makefile
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-15 12:14:39 +0000
commit1ac224e5633aab81a4aa7a40d84308751aa6bbe1 (patch)
tree364e168d1c32783717ae24623ca009a9e3afac74 /devel/cl-infix/Makefile
parent0771132bce39427ace1fc0c1a360e09e40965a9d (diff)
downloadports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.tar.gz
ports-1ac224e5633aab81a4aa7a40d84308751aa6bbe1.zip
Remove redundant code and variables from the cl-* ports.
Introduce bsd.cl-asdf.mk to automate the compilation and installation of Common Lisp libraries using the ASDF framework. Currently it supports building FASL files on SBCL and CLISP, to support the ports that already exist in the ports tree. This should help bringing in more cl-* ports from the ASDF repository without excessive code duplication.
Notes
Notes: svn path=/head/; revision=247937
Diffstat (limited to 'devel/cl-infix/Makefile')
-rw-r--r--devel/cl-infix/Makefile26
1 files changed, 11 insertions, 15 deletions
diff --git a/devel/cl-infix/Makefile b/devel/cl-infix/Makefile
index 1fd87d4487b7..ba7856331853 100644
--- a/devel/cl-infix/Makefile
+++ b/devel/cl-infix/Makefile
@@ -5,7 +5,8 @@
# $FreeBSD$
PORTNAME= infix
-DISTVERSION= 19960628
+PORTVERSION= 19960628
+PORTREVISION= 1
CATEGORIES= devel lisp
MASTER_SITES= http://ftp.linux.org.uk/pub/lisp/cclan/ \
ftp://ftp.ntnu.no/pub/lisp/cclan/ \
@@ -17,29 +18,24 @@ DISTNAME= ${PORTNAME}
MAINTAINER= olgeni@FreeBSD.org
COMMENT= A lisp macro for reading math expressions in infix form
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/asdf/asdf.lisp:${PORTSDIR}/devel/cl-asdf
-
WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION}
-DOCSDIR?= ${PREFIX}/share/doc/${PKGNAMEPREFIX}${PORTNAME}
-CL_LIBDIR= ${PREFIX}/lib/common-lisp
-
NO_BUILD= yes
NO_CDROM= No fees or compensation can be charged
-LPORTDOCS= COPYING infix.3lisp
+USE_ASDF= yes
do-install:
- @${MKDIR} ${CL_LIBDIR}/infix
- @${INSTALL_DATA} ${WRKSRC}/infix.asd ${CL_LIBDIR}/infix/
- @${INSTALL_DATA} ${WRKSRC}/*.cl ${CL_LIBDIR}/infix/
- @${INSTALL_DATA} ${WRKSRC}/infix.system ${CL_LIBDIR}/infix/
- @${LN} -sf ${CL_LIBDIR}/infix/infix.asd ${CL_LIBDIR}/system-registry/infix.asd
+ @${MKDIR} ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/*.cl ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/infix.asd ${ASDF_PATHNAME}
+ @${INSTALL_DATA} ${WRKSRC}/infix.system ${ASDF_PATHNAME}
+ @${LN} -sf ${ASDF_PATHNAME}/*.asd ${ASDF_REGISTRY}
.if !defined(NOPORTDOCS)
-.for FILE in ${LPORTDOCS}
@${MKDIR} ${DOCSDIR}
- @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}/
+.for FILE in COPYING infix.3lisp
+ @${INSTALL_DATA} ${WRKSRC}/${FILE} ${DOCSDIR}
.endfor
.endif
+.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>