aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-split-sequence-clisp
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-12 21:32:07 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-12 21:32:07 +0000
commit124bd509d955fd50aab5844a6bd7499f50bd10a2 (patch)
tree582a2e08ecb7ebce4e85f9c2a4acf3c7ee96f5fd /devel/cl-split-sequence-clisp
parent1b469086964a9998aa78737cbd4d6bfadeadf3b6 (diff)
downloadports-124bd509d955fd50aab5844a6bd7499f50bd10a2.tar.gz
ports-124bd509d955fd50aab5844a6bd7499f50bd10a2.zip
Cleanup whitespace, disable command echo and reduce diff between
similar code fragments.
Notes
Notes: svn path=/head/; revision=247737
Diffstat (limited to 'devel/cl-split-sequence-clisp')
-rw-r--r--devel/cl-split-sequence-clisp/Makefile42
1 files changed, 21 insertions, 21 deletions
diff --git a/devel/cl-split-sequence-clisp/Makefile b/devel/cl-split-sequence-clisp/Makefile
index e841c722fb41..980a2d2d7188 100644
--- a/devel/cl-split-sequence-clisp/Makefile
+++ b/devel/cl-split-sequence-clisp/Makefile
@@ -4,36 +4,36 @@
#
# $FreeBSD$
-PORTNAME= split-sequence
-PORTVERSION= 20011114.1
+PORTNAME= split-sequence
+PORTVERSION= 20011114.1
PORTREVISION= 2
-CATEGORIES= devel lisp
-MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
- ftp://ftp.ntnu.no/pub/lisp/cclan/ \
- http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
-PKGNAMEPREFIX= cl-
-PKGNAMESUFFIX= -clisp
-DISTFILES= # use installed sources from CL_LIBDIR
-EXTRACT_ONLY= # use installed sources from CL_LIBDIR
+CATEGORIES= devel lisp
+MASTER_SITES= ftp://ftp.linux.org.uk/pub/lisp/experimental/cclan/ \
+ ftp://ftp.ntnu.no/pub/lisp/cclan/ \
+ http://www-jcsu.jesus.cam.ac.uk/ftp/pub/cclan/
+PKGNAMEPREFIX= cl-
+PKGNAMESUFFIX= -clisp
+DISTFILES= # use installed sources from CL_LIBDIR
+EXTRACT_ONLY= # use installed sources from CL_LIBDIR
-MAINTAINER= olgeni@FreeBSD.org
-COMMENT= Partitioning Common Lisp sequences
+MAINTAINER= olgeni@FreeBSD.org
+COMMENT= Partitioning Common Lisp sequences
-BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
-RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
- ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
- clisp:${PORTSDIR}/lang/clisp
+BUILD_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
+RUN_DEPENDS= ${LOCALBASE}/lib/common-lisp/split-sequence/split-sequence.asd:${PORTSDIR}/devel/cl-split-sequence \
+ ${LOCALBASE}/lib/common-lisp/asdf/clispfasl/asdf.fasl:${PORTSDIR}/devel/cl-asdf-clisp \
+ clisp:${PORTSDIR}/lang/clisp
do-build:
- FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
+ @FBSD_ASDF_COMPILE_PORT=t WRKSRC=${WRKSRC}/ \
clisp -q -ansi -norc \
-i ${LOCALBASE}/etc/asdf-init \
-x "(asdf:oos 'asdf:compile-op :split-sequence)"
do-install:
- ${MKDIR} ${PREFIX}/lib/common-lisp/split-sequence/clispfasl
- ${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/split-sequence/clispfasl/
+ @${MKDIR} ${PREFIX}/lib/common-lisp/split-sequence/clispfasl
+ @${INSTALL_DATA} ${WRKSRC}/*.fasl ${PREFIX}/lib/common-lisp/split-sequence/clispfasl/
.include <bsd.port.mk>