aboutsummaryrefslogtreecommitdiff
path: root/devel/cl-trivial-features-sbcl
diff options
context:
space:
mode:
authorJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 12:40:13 +0000
committerJimmy Olgeni <olgeni@FreeBSD.org>2010-01-20 12:40:13 +0000
commit9d2ef0bb9e6d20a29f9f5c876df5940030f8fc9b (patch)
tree4783b07e65d08851153d1c5e959bd6ae077b1ff2 /devel/cl-trivial-features-sbcl
parentb667cdbd375c6509a88a99061cd9cc5296057119 (diff)
downloadports-9d2ef0bb9e6d20a29f9f5c876df5940030f8fc9b.tar.gz
ports-9d2ef0bb9e6d20a29f9f5c876df5940030f8fc9b.zip
When building ASDF modules with the previous cl-asdf port version,
sometimes the build would fail because of "missing" packages that weren't actually missing (this only happened in ports that aren't committed yet). Rewrite the FASL placement code using the asdf-binary-locations extension, which is already included in the cl-asdf port but needs to be installed from ports when building for SBCL (which has its own ASDF code). The binary-locations code generates paths unsuitable for PLISTs, therefore it has been overridden with lisp-specific-fasl-subdir. Because of the new code, PLIST generation for cl-*-sbcl and cl-*-clisp ports is now entirely automated. All dependent cl-* ports are upgraded (obsolete code removed, PORTREVISION bumped).
Notes
Notes: svn path=/head/; revision=248207
Diffstat (limited to 'devel/cl-trivial-features-sbcl')
-rw-r--r--devel/cl-trivial-features-sbcl/Makefile5
-rw-r--r--devel/cl-trivial-features-sbcl/pkg-plist2
2 files changed, 1 insertions, 6 deletions
diff --git a/devel/cl-trivial-features-sbcl/Makefile b/devel/cl-trivial-features-sbcl/Makefile
index 0563dc783a37..b718ec32c0cc 100644
--- a/devel/cl-trivial-features-sbcl/Makefile
+++ b/devel/cl-trivial-features-sbcl/Makefile
@@ -6,6 +6,7 @@
PORTNAME= trivial-features
PORTVERSION= 2010.01.16
+PORTREVISION= 1
CATEGORIES= devel lisp
PKGNAMEPREFIX= cl-
DISTFILES= # none
@@ -20,9 +21,5 @@ USE_ASDF_FASL= yes
FASL_TARGET= sbcl
FASL_BUILD= yes
-do-install:
- @${MKDIR} ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
- @${INSTALL_DATA} ${WRKSRC}/*.fasl ${ASDF_PATHNAME}/src/${FASL_DIR_REL}
-
.include "${.CURDIR}/../../devel/cl-asdf/bsd.cl-asdf.mk"
.include <bsd.port.mk>
diff --git a/devel/cl-trivial-features-sbcl/pkg-plist b/devel/cl-trivial-features-sbcl/pkg-plist
deleted file mode 100644
index c4acd855a8b5..000000000000
--- a/devel/cl-trivial-features-sbcl/pkg-plist
+++ /dev/null
@@ -1,2 +0,0 @@
-%%LIB32DIR%%/common-lisp/trivial-features/src/sbclfasl/tf-sbcl.fasl
-@dirrm %%LIB32DIR%%/common-lisp/trivial-features/src/sbclfasl