aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake-gui
diff options
context:
space:
mode:
authorRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 21:16:19 +0000
committerRaphael Kubo da Costa <rakuco@FreeBSD.org>2015-12-05 21:16:19 +0000
commitb30000116c4bfde572a1cff85ec04164135f4fd4 (patch)
tree99a6d5a5ed2d9c6e643f0ea313af428fd72b8d54 /devel/cmake-gui
parent32a74b1944b167766d91bcaa32b971d0343b79f5 (diff)
downloadports-b30000116c4bfde572a1cff85ec04164135f4fd4.tar.gz
ports-b30000116c4bfde572a1cff85ec04164135f4fd4.zip
Update CMake to 3.4.1.
Release notes: http://www.kitware.com/blog/home/post/1016 Finally a small, bug-fix release that does not requrie changes to other ports. PR: 205014
Notes
Notes: svn path=/head/; revision=403079
Diffstat (limited to 'devel/cmake-gui')
-rw-r--r--devel/cmake-gui/Makefile3
-rw-r--r--devel/cmake-gui/files/patch-git_16f5d18422
2 files changed, 2 insertions, 23 deletions
diff --git a/devel/cmake-gui/Makefile b/devel/cmake-gui/Makefile
index 4b686d46ba8c..289b6cd77e24 100644
--- a/devel/cmake-gui/Makefile
+++ b/devel/cmake-gui/Makefile
@@ -1,7 +1,7 @@
# $FreeBSD$
PORTNAME= cmake
-PORTVERSION= 3.4.0
+PORTVERSION= 3.4.1
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v3.4/
PKGNAMESUFFIX= -gui
@@ -10,6 +10,7 @@ MAINTAINER= kde@FreeBSD.org
COMMENT= Qt-based GUI for CMake
LICENSE= BSD3CLAUSE
+LICENSE_FILE= ${WRKSRC}/Copyright.txt
BUILD_DEPENDS= sphinx-build:${PORTSDIR}/textproc/py-sphinx
LIB_DEPENDS= libcurl.so:${PORTSDIR}/ftp/curl \
diff --git a/devel/cmake-gui/files/patch-git_16f5d184 b/devel/cmake-gui/files/patch-git_16f5d184
deleted file mode 100644
index c37e37082a24..000000000000
--- a/devel/cmake-gui/files/patch-git_16f5d184
+++ /dev/null
@@ -1,22 +0,0 @@
-Fixes the build with recent GCCs (at least 4.8+).
-
-commit 16f5d1843b3720729f50376f522550fcfa787a3c
-Author: Kylie McClain <somasissounds@gmail.com>
-Date: Wed Nov 25 18:12:06 2015 -0500
-
- Include `sys/types.h` header to get `mode_t`
-
- Do not depend on it being included by other system headers.
- It is not included by others on musl-libc, for example.
-
---- Source/cmStandardIncludes.h
-+++ Source/cmStandardIncludes.h
-@@ -54,6 +54,8 @@
-
- #if defined( _MSC_VER )
- typedef unsigned short mode_t;
-+#else
-+# include <sys/types.h>
- #endif
-
- // use this class to shrink the size of symbols in .o files