aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorKris Moore <kmoore@FreeBSD.org>2009-05-27 16:19:33 +0000
committerKris Moore <kmoore@FreeBSD.org>2009-05-27 16:19:33 +0000
commit05a218b49a000d9fd863949df74a5f286dca2e95 (patch)
treebdc16471007aae9849e8a68e93be73f153e5601e /devel/cmake
parent9c9309117a579a8697a48f8dac045d7fb5ae8027 (diff)
downloadports-05a218b49a000d9fd863949df74a5f286dca2e95.tar.gz
ports-05a218b49a000d9fd863949df74a5f286dca2e95.zip
Updated devel/cmake to respect LOCALBASE when set to locations other than /usr/local
- Not bumping PORTREV since this only effects users running on a non-standard LOCALBASE Approved by: miwi (mentor)
Notes
Notes: svn path=/head/; revision=234662
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile8
1 files changed, 8 insertions, 0 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index e5d9625dc9fb..0cde16628865 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -37,8 +37,16 @@ MAN1= ccmake.1 \
ctest.1
post-patch:
+ @${GREP} -rl '/usr/local' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
+ ${XARGS} ${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g'
@${GREP} -rl '/usr/X11R6' ${WRKSRC}/Modules ${WRKSRC}/Tests | \
${XARGS} ${REINPLACE_CMD} -e 's,/usr/X11R6,${LOCALBASE},g'
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Source/cmLocalGenerator.cxx
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/Source/CPack/cmCPackGenerator.cxx
+ @${REINPLACE_CMD} -e 's,/usr/local,${LOCALBASE},g' \
+ ${WRKSRC}/bootstrap
@${REINPLACE_CMD} -e 's,/opt/kde4,${LOCALBASE}/kde4,g' \
${WRKSRC}/Modules/FindKDE4.cmake