aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorTobias C. Berner <tcberner@FreeBSD.org>2020-10-11 10:55:22 +0000
committerTobias C. Berner <tcberner@FreeBSD.org>2020-10-11 10:55:22 +0000
commit05b1c9a5f4a2aaea3b4a155dcf68921d7d855ba3 (patch)
tree0a3acb99c85d78324bd7720231db7f8c4ce6eef7 /devel/cmake
parent8ffb4356682d6e74b9d8c68975979fa0afaf7c96 (diff)
downloadports-05b1c9a5f4a2aaea3b4a155dcf68921d7d855ba3.tar.gz
ports-05b1c9a5f4a2aaea3b4a155dcf68921d7d855ba3.zip
devel/cmake: update to 3.18.4
Changes in 3.18.4 since 3.18.3: Brad King (3): FindJNI: Add aarch64 support VS: Populate `std:c{11,17}` flag table entries for v142 CMake 3.18.4 Cristian Adam (1): OBJCXX: Fix regression for compiling cpp files as objcxx Kinan Mahdi (1): VS: Fix regression in C# source links Marc Chevrier (1): FindPython: Fix erroneous regex in ABI check Shoaib Meenai (1): Clang: Look for llvm-lib when using MSVC-like front-end zasdfg bnm (1): FindCUDA/select_compute_arch: Add CUDA 11.1 and SM86 support - add additional patch to ensure that wxWidgets can be found with minimal effort PR: 250166 Exp-run by: antoine
Notes
Notes: svn path=/head/; revision=552049
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile2
-rw-r--r--devel/cmake/distinfo6
-rw-r--r--devel/cmake/files/patch-Modules_FindwxWidgets.cmake11
3 files changed, 15 insertions, 4 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index d634b1e2abee..505393e6adc6 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -3,7 +3,7 @@
PORTNAME= cmake
# Remember to update devel/cmake-doc and devel/cmake-gui as well.
-DISTVERSION= 3.18.3
+DISTVERSION= 3.18.4
CATEGORIES= devel
MASTER_SITES= https://github.com/Kitware/CMake/releases/download/v${DISTVERSION}/ \
https://www.cmake.org/files/v${PORTVERSION}/
diff --git a/devel/cmake/distinfo b/devel/cmake/distinfo
index ec3563d471f0..1a15a0dcf10e 100644
--- a/devel/cmake/distinfo
+++ b/devel/cmake/distinfo
@@ -1,3 +1,3 @@
-TIMESTAMP = 1600788630
-SHA256 (cmake-3.18.3.tar.gz) = 2c89f4e30af4914fd6fb5d00f863629812ada848eee4e2d29ec7e456d7fa32e5
-SIZE (cmake-3.18.3.tar.gz) = 8976093
+TIMESTAMP = 1602011548
+SHA256 (cmake-3.18.4.tar.gz) = 597c61358e6a92ecbfad42a9b5321ddd801fc7e7eca08441307c9138382d4f77
+SIZE (cmake-3.18.4.tar.gz) = 8976659
diff --git a/devel/cmake/files/patch-Modules_FindwxWidgets.cmake b/devel/cmake/files/patch-Modules_FindwxWidgets.cmake
new file mode 100644
index 000000000000..10dd780352bf
--- /dev/null
+++ b/devel/cmake/files/patch-Modules_FindwxWidgets.cmake
@@ -0,0 +1,11 @@
+--- Modules/FindwxWidgets.cmake.orig 2020-10-11 10:51:15 UTC
++++ Modules/FindwxWidgets.cmake
+@@ -761,7 +761,7 @@ else()
+ #-----------------------------------------------------------------
+ # Support cross-compiling, only search in the target platform.
+ find_program(wxWidgets_CONFIG_EXECUTABLE
+- NAMES $ENV{WX_CONFIG} wx-config wx-config-3.1 wx-config-3.0 wx-config-2.9 wx-config-2.8
++ NAMES $ENV{WX_CONFIG} wx-config wxgtk3u-3.1-config wxgtk3u-3.0-config wxgtk2u-2.8-config wx-config-3.1 wx-config-3.0 wx-config-2.9 wx-config-2.8
+ DOC "Location of wxWidgets library configuration provider binary (wx-config)."
+ ONLY_CMAKE_FIND_ROOT_PATH
+ )