aboutsummaryrefslogtreecommitdiff
path: root/devel/cmake
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2017-09-21 19:59:35 +0000
committerJan Beich <jbeich@FreeBSD.org>2017-09-21 19:59:35 +0000
commit9f1c615306f495d816ba7b983ec4ead5aee58361 (patch)
tree4ed6b47a484c665168298e90322a49c865a4bb90 /devel/cmake
parent285d61c0a3a4e372030cb232af8bdc2bf21b28f1 (diff)
downloadports-9f1c615306f495d816ba7b983ec4ead5aee58361.tar.gz
ports-9f1c615306f495d816ba7b983ec4ead5aee58361.zip
devel/cmake: backport boost 1.65.1 support
CMake Warning at /usr/local/share/cmake/Modules/FindBoost.cmake:767 (message): Imported targets not available for Boost version 106501 Call Stack (most recent call first): /usr/local/share/cmake/Modules/FindBoost.cmake:871 (_Boost_COMPONENT_DEPENDENCIES) /usr/local/share/cmake/Modules/FindBoost.cmake:1501 (_Boost_MISSING_DEPENDENCIES) CMakeLists.txt:558 (find_package) PR: 222207 Approved by: kde (rakuco) Obtained from: upstream (cmake-3.9.3)
Notes
Notes: svn path=/head/; revision=450301
Diffstat (limited to 'devel/cmake')
-rw-r--r--devel/cmake/Makefile1
-rw-r--r--devel/cmake/files/patch-git_ee1f890372
2 files changed, 73 insertions, 0 deletions
diff --git a/devel/cmake/Makefile b/devel/cmake/Makefile
index e7568fc4265a..694440a0022c 100644
--- a/devel/cmake/Makefile
+++ b/devel/cmake/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cmake
DISTVERSION= 3.9.2
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= https://www.cmake.org/files/v${PORTVERSION:R}/
diff --git a/devel/cmake/files/patch-git_ee1f8903 b/devel/cmake/files/patch-git_ee1f8903
new file mode 100644
index 000000000000..eaedfe95dc91
--- /dev/null
+++ b/devel/cmake/files/patch-git_ee1f8903
@@ -0,0 +1,72 @@
+From ee1f8903322b443b263ec9638ab4851e7e5edf21 Mon Sep 17 00:00:00 2001
+From: Roger Leigh <rleigh@dundee.ac.uk>
+Date: Wed, 6 Sep 2017 21:11:47 +0100
+Subject: [PATCH] FindBoost: Add support for Boost 1.65.0 and 1.65.1 to CMake
+ 3.9
+
+Backport the changes from commit fa114e7d70 (FindBoost: Add Boost 1.65
+dependencies, 2017-08-22) and commit dbba53a5aa (FindBoost: Add version
+1.65.1, 2017-09-06) to CMake 3.9.
+
+Fixes: #17289
+
+--- Modules/FindBoost.cmake.orig 2017-09-07 16:10:58 UTC
++++ Modules/FindBoost.cmake
+@@ -550,7 +550,10 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
+ # The addition of a new release should only require it to be run
+ # against the new release.
+ set(_Boost_IMPORTED_TARGETS TRUE)
+- if(NOT Boost_VERSION VERSION_LESS 103300 AND Boost_VERSION VERSION_LESS 103500)
++ if(Boost_VERSION VERSION_LESS 103300)
++ message(WARNING "Imported targets and dependency information not available for Boost version ${Boost_VERSION} (all versions older than 1.33)")
++ set(_Boost_IMPORTED_TARGETS FALSE)
++ elseif(NOT Boost_VERSION VERSION_LESS 103300 AND Boost_VERSION VERSION_LESS 103500)
+ set(_Boost_IOSTREAMS_DEPENDENCIES regex thread)
+ set(_Boost_REGEX_DEPENDENCIES thread)
+ set(_Boost_WAVE_DEPENDENCIES filesystem thread)
+@@ -764,8 +767,27 @@ function(_Boost_COMPONENT_DEPENDENCIES component _ret)
+ set(_Boost_WAVE_DEPENDENCIES filesystem system serialization thread chrono date_time atomic)
+ set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
+ else()
+- message(WARNING "Imported targets not available for Boost version ${Boost_VERSION}")
+- set(_Boost_IMPORTED_TARGETS FALSE)
++ if(NOT Boost_VERSION VERSION_LESS 106500)
++ set(_Boost_CHRONO_DEPENDENCIES system)
++ set(_Boost_CONTEXT_DEPENDENCIES thread chrono system date_time)
++ set(_Boost_COROUTINE_DEPENDENCIES context system)
++ set(_Boost_FIBER_DEPENDENCIES context thread chrono system date_time)
++ set(_Boost_FILESYSTEM_DEPENDENCIES system)
++ set(_Boost_IOSTREAMS_DEPENDENCIES regex)
++ set(_Boost_LOG_DEPENDENCIES date_time log_setup system filesystem thread regex chrono atomic)
++ set(_Boost_MATH_DEPENDENCIES math_c99 math_c99f math_c99l math_tr1 math_tr1f math_tr1l atomic)
++ set(_Boost_MPI_DEPENDENCIES serialization)
++ set(_Boost_MPI_PYTHON_DEPENDENCIES python mpi serialization)
++ set(_Boost_NUMPY_DEPENDENCIES python)
++ set(_Boost_RANDOM_DEPENDENCIES system)
++ set(_Boost_THREAD_DEPENDENCIES chrono system date_time atomic)
++ set(_Boost_WAVE_DEPENDENCIES filesystem system serialization thread chrono date_time atomic)
++ set(_Boost_WSERIALIZATION_DEPENDENCIES serialization)
++ endif()
++ if(NOT Boost_VERSION VERSION_LESS 106600)
++ message(WARNING "New Boost version may have incorrect or missing dependencies and imported targets")
++ set(_Boost_IMPORTED_TARGETS FALSE)
++ endif()
+ endif()
+
+ string(TOUPPER ${component} uppercomponent)
+@@ -815,6 +837,7 @@ function(_Boost_COMPONENT_HEADERS component _hdrs)
+ set(_Boost_MATH_TR1L_HEADERS "boost/math/tr1.hpp")
+ set(_Boost_MPI_HEADERS "boost/mpi.hpp")
+ set(_Boost_MPI_PYTHON_HEADERS "boost/mpi/python/config.hpp")
++ set(_Boost_NUMPY_HEADERS "boost/python/numpy.hpp")
+ set(_Boost_PRG_EXEC_MONITOR_HEADERS "boost/test/prg_exec_monitor.hpp")
+ set(_Boost_PROGRAM_OPTIONS_HEADERS "boost/program_options.hpp")
+ set(_Boost_PYTHON_HEADERS "boost/python.hpp")
+@@ -998,6 +1021,7 @@ else()
+ # _Boost_COMPONENT_HEADERS. See the instructions at the top of
+ # _Boost_COMPONENT_DEPENDENCIES.
+ set(_Boost_KNOWN_VERSIONS ${Boost_ADDITIONAL_VERSIONS}
++ "1.65.1" "1.65.0" "1.65"
+ "1.64.0" "1.64" "1.63.0" "1.63" "1.62.0" "1.62" "1.61.0" "1.61" "1.60.0" "1.60"
+ "1.59.0" "1.59" "1.58.0" "1.58" "1.57.0" "1.57" "1.56.0" "1.56" "1.55.0" "1.55"
+ "1.54.0" "1.54" "1.53.0" "1.53" "1.52.0" "1.52" "1.51.0" "1.51"