aboutsummaryrefslogtreecommitdiff
path: root/devel/coccinelle/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-28 14:24:43 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-28 14:24:43 +0000
commit11794c602658bf2dc9a4cef62ad6714e6feb0542 (patch)
tree04e565cb0df4db13d8f48c365656856ece5ef113 /devel/coccinelle/Makefile
parent7a4fcd737486dfae7cf8902b01ef6dcabd170ce7 (diff)
downloadports-11794c602658bf2dc9a4cef62ad6714e6feb0542.tar.gz
ports-11794c602658bf2dc9a4cef62ad6714e6feb0542.zip
Update to 1.0.0-rc18
Support stage Strip binaries Approved by: maintainer (avg by IRC) Based on patch by: Alexandre Perrin (kAworu irc)
Notes
Notes: svn path=/head/; revision=335092
Diffstat (limited to 'devel/coccinelle/Makefile')
-rw-r--r--devel/coccinelle/Makefile20
1 files changed, 9 insertions, 11 deletions
diff --git a/devel/coccinelle/Makefile b/devel/coccinelle/Makefile
index fe7768d7ff6f..ea21004b8270 100644
--- a/devel/coccinelle/Makefile
+++ b/devel/coccinelle/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= coccinelle
-DISTVERSION= 0.2.4rc5
+DISTVERSION= 1.0.0-rc18
CATEGORIES= devel
MASTER_SITES= http://coccinelle.lip6.fr/distrib/
EXTRACT_SUFX= .tgz
@@ -13,17 +13,15 @@ COMMENT= Coccinelle is a program matching and transformation engine
USES= shebangfix gmake perl5
GNU_CONFIGURE= yes
USE_PERL5= build
-USE_PYTHON= 2.5+
+USE_PYTHON= 2.6+
USE_OCAML= 3.0+
-SHEBANG_FILES= configure
+bash_CMD= ${SH}
+SHEBANG_FILES= setup/echo.sh
+MAKE_ARGS+= PYTHON_VERSION=${PYTHON_VER}
-MAN1= spatch.1
-
-NO_STAGE= yes
-post-patch:
- @${REINPLACE_CMD} 's|CAMLreturn0|return 0|' \
- ${WRKSRC}/pycaml/pycaml_ml.c
- @${REINPLACE_CMD} 's|shell python|shell ${PYTHON_CMD}|' \
- ${WRKSRC}/pycaml/Makefile
+post-install:
+ ${STRIP_CMD} ${STAGEDIR}${DATADIR}/dllpcre_stubs.so \
+ ${STAGEDIR}${DATADIR}/dllpycaml_stubs.so \
+ ${STAGEDIR}${DATADIR}/spatch
.include <bsd.port.mk>