aboutsummaryrefslogtreecommitdiff
path: root/devel/codeworker
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-11-15 22:10:03 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-11-15 22:10:03 +0000
commit4ca6b3102938c08bd9ae904dbb0944f9260b89b5 (patch)
tree5a9da59575ca9601220db7a7376b54bc3bfe3158 /devel/codeworker
parentd85873b6b8d25f36c24a7c2c7a839fa1c467de5e (diff)
downloadports-4ca6b3102938c08bd9ae904dbb0944f9260b89b5.tar.gz
ports-4ca6b3102938c08bd9ae904dbb0944f9260b89b5.zip
Convert to stage
USE_GMAKE->USES=gmake
Notes
Notes: svn path=/head/; revision=333939
Diffstat (limited to 'devel/codeworker')
-rw-r--r--devel/codeworker/Makefile5
1 files changed, 2 insertions, 3 deletions
diff --git a/devel/codeworker/Makefile b/devel/codeworker/Makefile
index ac72bf19fa05..cbe461992901 100644
--- a/devel/codeworker/Makefile
+++ b/devel/codeworker/Makefile
@@ -14,9 +14,9 @@ LICENSE= LGPL21
WRKSRC= ${WRKDIR}/CodeWorker${PORTVERSION:S/./_/g}
+USES= gmake
USE_ZIP= yes
USE_DOS2UNIX= yes
-USE_GMAKE= yes
MAKE_ARGS= CC="${CXX}" CXX="${CXX}" CXXFLAGS="${CXXFLAGS}" LFLAGS="-lm"
ALL_TARGET= build
@@ -24,7 +24,6 @@ CFLAGS+= -Dstricmp=strcasecmp
PLIST_FILES= bin/codeworker
-NO_STAGE= yes
post-patch:
@${FIND} ${WRKSRC} -name "*.cpp" -or -name "*.h" | ${XARGS} \
${REINPLACE_CMD} -e \
@@ -32,6 +31,6 @@ post-patch:
s|__GNUC_PREREQ |__GNUC_PREREQ__|'
do-install:
- (cd ${WRKSRC} && ${INSTALL_PROGRAM} codeworker ${PREFIX}/bin)
+ (cd ${WRKSRC} && ${INSTALL_PROGRAM} codeworker ${STAGEDIR}${PREFIX}/bin)
.include <bsd.port.mk>