aboutsummaryrefslogtreecommitdiff
path: root/devel/compiler-rt/Makefile
diff options
context:
space:
mode:
authorMark Linimon <linimon@FreeBSD.org>2019-07-04 11:57:27 +0000
committerMark Linimon <linimon@FreeBSD.org>2019-07-04 11:57:27 +0000
commit6cac2841378775e3af01619c8fecf91dd20b5d7c (patch)
treeceea04f0c5b6209ff96f8faad9a2d79a5df466e6 /devel/compiler-rt/Makefile
parentf4a001a5b13e32f0d7094b33341803a2bf3b3417 (diff)
downloadports-6cac2841378775e3af01619c8fecf91dd20b5d7c.tar.gz
ports-6cac2841378775e3af01619c8fecf91dd20b5d7c.zip
Use BROKEN_powerpc instead of old-style test.
While here, pet portlint (BROKEN_* location.)
Notes
Notes: svn path=/head/; revision=505834
Diffstat (limited to 'devel/compiler-rt/Makefile')
-rw-r--r--devel/compiler-rt/Makefile7
1 files changed, 3 insertions, 4 deletions
diff --git a/devel/compiler-rt/Makefile b/devel/compiler-rt/Makefile
index badd64ddbb88..77437b58db04 100644
--- a/devel/compiler-rt/Makefile
+++ b/devel/compiler-rt/Makefile
@@ -13,10 +13,11 @@ LICENSE= BSD3CLAUSE MIT
LICENSE_COMB= dual
LICENSE_FILE= ${WRKSRC}/LICENSE.TXT
-BUILD_DEPENDS= cmake:devel/cmake
-
+BROKEN_powerpc= does not compile
BROKEN_powerpc64= does not build: undefined reference to fmax
+BUILD_DEPENDS= cmake:devel/cmake
+
CONFIGURE_WRKSRC= ${WRKDIR}/build
BUILD_WRKSRC= ${WRKDIR}/build
INSTALL_WRKSRC= ${WRKDIR}/build
@@ -46,8 +47,6 @@ PLIST_FILES= include/Block.h \
.if ${ARCH} == "i386"
CFLAGS+= -march=i486
-.elif ${ARCH} == "powerpc"
-BROKEN= Does not compile on powerpc
.endif
.if defined(BOOTSTRAP)