aboutsummaryrefslogtreecommitdiff
path: root/devel/compiler-rt
diff options
context:
space:
mode:
authorBrooks Davis <brooks@FreeBSD.org>2009-10-09 03:36:54 +0000
committerBrooks Davis <brooks@FreeBSD.org>2009-10-09 03:36:54 +0000
commit81b31973ef59fae47cee4873ce0c77597f925a5c (patch)
tree9935e287e9095aaaeea336a55bc06c4c14f28253 /devel/compiler-rt
parentdf2a6060e16c4ec80c6314dc74d8aef03e613ea0 (diff)
downloadports-81b31973ef59fae47cee4873ce0c77597f925a5c.tar.gz
ports-81b31973ef59fae47cee4873ce0c77597f925a5c.zip
Add a port of compiler-rt, the LLVM project's compiler runtime and
blocks support.
Notes
Notes: svn path=/head/; revision=242595
Diffstat (limited to 'devel/compiler-rt')
-rw-r--r--devel/compiler-rt/Makefile64
-rw-r--r--devel/compiler-rt/Makefile.svn_rev1
-rw-r--r--devel/compiler-rt/distinfo3
-rw-r--r--devel/compiler-rt/foo55
-rw-r--r--devel/compiler-rt/pkg-descr9
5 files changed, 132 insertions, 0 deletions
diff --git a/devel/compiler-rt/Makefile b/devel/compiler-rt/Makefile
new file mode 100644
index 000000000000..26a290fd389e
--- /dev/null
+++ b/devel/compiler-rt/Makefile
@@ -0,0 +1,64 @@
+# New ports collection makefile for: compiler-rt
+# Date created: 8 Oct 2009
+# Whom: Brooks Davis
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiler-rt
+DISTVERSION= 0.r${SVN_REV}
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= Compiler runtime library with Blocks support
+
+BUILD_DEPENDS= cmake:${PORTSDIR}/devel/cmake
+
+CONFIGURE_WRKSRC= ${WRKDIR}/build
+BUILD_WRKSRC= ${WRKDIR}/build
+INSTALL_WRKSRC= ${WRKDIR}/build
+
+#USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+LLVM_SVN= http://llvm.org/svn/llvm-project
+
+PLIST_FILES= include/Block.h \
+ include/Block_private.h \
+ lib/libBlocksRuntime.so
+
+.include <bsd.port.pre.mk>
+
+.if defined(BOOTSTRAP)
+SVN_REV!= svn info ${LLVM_SVN}/ | ${GREP} Revision | cut -d' ' -f2
+.else
+.include "Makefile.svn_rev"
+.endif
+
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} \
+ ${LLVM_SVN}/compiler-rt/trunk ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2
+${DISTNAME}
+ echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
+.if ${USER} == brooks
+ scp ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif
+
+do-configure:
+ ${MKDIR} ${CONFIGURE_WRKSRC}
+ cd ${CONFIGURE_WRKSRC} && \
+ cmake -DCMAKE_INSTALL_PREFIX="${PREFIX}" ${WRKSRC}
+
+.include <bsd.port.post.mk>
diff --git a/devel/compiler-rt/Makefile.svn_rev b/devel/compiler-rt/Makefile.svn_rev
new file mode 100644
index 000000000000..bcba5c897e48
--- /dev/null
+++ b/devel/compiler-rt/Makefile.svn_rev
@@ -0,0 +1 @@
+SVN_REV= 83568
diff --git a/devel/compiler-rt/distinfo b/devel/compiler-rt/distinfo
new file mode 100644
index 000000000000..a15db8290ed9
--- /dev/null
+++ b/devel/compiler-rt/distinfo
@@ -0,0 +1,3 @@
+MD5 (compiler-rt-0.r83568.tar.bz2) = 05a687dc9c07205606c9247f838af91e
+SHA256 (compiler-rt-0.r83568.tar.bz2) = 30faef7f15bce6cc4d20cda718c026570ca843f1d05691612faeaa98c67a5f69
+SIZE (compiler-rt-0.r83568.tar.bz2) = 713438
diff --git a/devel/compiler-rt/foo b/devel/compiler-rt/foo
new file mode 100644
index 000000000000..1b0d88c59f38
--- /dev/null
+++ b/devel/compiler-rt/foo
@@ -0,0 +1,55 @@
+# New ports collection makefile for: compiler-rt
+# Date created: 20 Nov 2005
+#
+# $FreeBSD$
+#
+
+PORTNAME= compiler-rt
+DISTVERSION= 0.r${SVN_REV}
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_LOCAL}
+MASTER_SITE_SUBDIR= brooks
+
+MAINTAINER= brooks@FreeBSD.org
+COMMENT= Low Level Virtual Machine
+
+CONFIGURE_WRKSRC= ${WRKDIR}/build
+BUILD_WRKSRC= ${WRKDIR}/build
+
+USE_GCC= 4.2+
+USE_GMAKE= yes
+USE_BZIP2= yes
+USE_LDCONFIG= yes
+MAKE_JOBS_SAFE= yes
+
+LLVM_SVN= http://llvm.org/svn/llvm-project
+
+MAN1=
+
+.include <bsd.port.pre.mk>
+
+.if defined(BOOTSTRAP)
+SVN_REV!= svn info ${LLVM_SVN}/ | ${GREP} Revision | cut -d' ' -f2
+.else
+.include "Makefile.svn_rev"
+.endif
+
+.if defined(BOOTSTRAP)
+FETCH_DEPENDS+= svn:${PORTSDIR}/devel/subversion
+
+do-fetch:
+ ${MKDIR} ${WRKDIR}
+ svn export -r ${SVN_REV} \
+ ${LLVM_SVN}/compiler-rt/trunk ${WRKSRC}
+ cd ${WRKDIR}; tar cvfy ${DISTDIR}/${DISTNAME}.tar.bz2
+${DISTNAME}
+ echo "SVN_REV= ${SVN_REV}" > ${MASTERDIR}/Makefile.svn_rev
+.if ${USER} == brooks
+ scp ${DISTDIR}/${DISTNAME}.tar.bz2 \
+ freefall.freebsd.org:public_distfiles/
+.endif
+.endif
+
+do-configure:
+ ${MKDIR} ${CONFIGURE_WRKSRC}
+ cd ${CONFIGURE_WRKSRC}/build && cmake ../compiler-rt
diff --git a/devel/compiler-rt/pkg-descr b/devel/compiler-rt/pkg-descr
new file mode 100644
index 000000000000..3287e54ba296
--- /dev/null
+++ b/devel/compiler-rt/pkg-descr
@@ -0,0 +1,9 @@
+The compiler-rt project is a simple library that provides an
+implementation of the low-level target-specific hooks required by code
+generation and other runtime components. For example, when compiling
+for a 32-bit target, converting a double to a 64-bit unsigned integer
+is compiling into a runtime call to the "__fixunsdfdi" function. The
+compiler-rt library provides optimized implementations of this and other
+low-level routines.
+
+WWW: http://compiler-rt.llvm.org/