aboutsummaryrefslogtreecommitdiff
path: root/devel/cook
diff options
context:
space:
mode:
authorJason Evans <jasone@FreeBSD.org>2000-02-01 07:41:59 +0000
committerJason Evans <jasone@FreeBSD.org>2000-02-01 07:41:59 +0000
commit4f8a162df2511234fc8f3b718c322ab4e9887529 (patch)
treeef4bd63b5b0f8f893688c31551179bbee07a0c0f /devel/cook
parentbf00c85054954b2907915bbb4c30f0e6004a378c (diff)
downloadports-4f8a162df2511234fc8f3b718c322ab4e9887529.tar.gz
ports-4f8a162df2511234fc8f3b718c322ab4e9887529.zip
Add port of 'cook', which is similar in nature to make(1).
Notes
Notes: svn path=/head/; revision=25385
Diffstat (limited to 'devel/cook')
-rw-r--r--devel/cook/Makefile64
-rw-r--r--devel/cook/distinfo1
-rw-r--r--devel/cook/pkg-comment1
-rw-r--r--devel/cook/pkg-descr6
-rw-r--r--devel/cook/pkg-message2
-rw-r--r--devel/cook/pkg-plist67
6 files changed, 141 insertions, 0 deletions
diff --git a/devel/cook/Makefile b/devel/cook/Makefile
new file mode 100644
index 000000000000..b2b878789e0c
--- /dev/null
+++ b/devel/cook/Makefile
@@ -0,0 +1,64 @@
+# New ports collection Makefile for: cook
+# Version required: 2.11
+# Date created: 31 January 2000
+# Whom: jasone
+#
+# $FreeBSD$
+#
+
+DISTNAME= cook-2.11
+CATEGORIES= devel
+MASTER_SITES= ${MASTER_SITE_SUNSITE} \
+ http://www.canb.auug.org.au/~millerp/cook/
+MASTER_SITE_SUBDIR= devel/make
+
+MAINTAINER= jasone@freebsd.org
+
+BUILD_DEPENDS= gettext:${PORTSDIR}/devel/gettext
+
+USE_AUTOCONF= yes
+GNU_CONFIGURE= yes
+CONFIGURE_ENV= CPPFLAGS=-I${LOCALBASE}/include LDFLAGS=-L${LOCALBASE}/lib
+
+MAN1= c_incl.1 cook.1 cook_bom.1 cook_lic.1 cookfp.1 cooktime.1 find_libs.1 \
+ make2cook.1 roffpp.1
+MANPREFIX = ${PREFIX}/share/cook
+MANLANG = "" en
+MANCOMPRESSED= no
+
+strip_bins := c_incl cook cook_bom cookfp cooktime find_libs make2cook roffpp
+
+# cook's configure.in is in the etc subdirectory. Move it to the main
+# directory so that USE_AUTOCONF works.
+post-patch:
+ @${MV} ${WRKSRC}/etc/configure.in ${WRKSRC}/
+
+# Make sure that the whole directory tree exists.
+pre-install:
+ ${MKDIR} ${PREFIX}/share/cook/en/man1
+ ${MKDIR} ${PREFIX}/lib/cook/en/LC_MESSAGES
+
+# cook installs extra copies in a directory that MANLANG can't cope with, so
+# shuffle things around a bit.
+post-install:
+ @${MKDIR} ${PREFIX}/share/cook/en/man1
+ @${MKDIR} ${PREFIX}/share/cook/man/en/man1
+.for manpage in ${MAN1}
+ @${MV} ${PREFIX}/share/cook/en/man1/${manpage} \
+ ${PREFIX}/share/cook/man/en/man1/
+.endfor
+ @${TOUCH} ${PREFIX}/share/cook/en/man1/.not_empty
+ @${MKDIR} ${PREFIX}/share/cook/man/man1
+.for manpage in ${MAN1}
+ @${MV} ${PREFIX}/man/man1/${manpage} ${PREFIX}/share/cook/man/man1/
+.endfor
+.for bin in ${strip_bins}
+ @strip ${PREFIX}/bin/${bin}
+.endfor
+ @echo
+ @echo "Add ${PREFIX}/share/cook/man to your MANPATH in order to " \
+ "access the manual"
+ @echo "pages included with this port."
+ @echo
+
+.include <bsd.port.mk>
diff --git a/devel/cook/distinfo b/devel/cook/distinfo
new file mode 100644
index 000000000000..802d71e95db8
--- /dev/null
+++ b/devel/cook/distinfo
@@ -0,0 +1 @@
+MD5 (cook-2.11.tar.gz) = cb0f0958c336a77d80df7ad86f982649
diff --git a/devel/cook/pkg-comment b/devel/cook/pkg-comment
new file mode 100644
index 000000000000..5a505600c40d
--- /dev/null
+++ b/devel/cook/pkg-comment
@@ -0,0 +1 @@
+Like make(1), but more powerful and clean.
diff --git a/devel/cook/pkg-descr b/devel/cook/pkg-descr
new file mode 100644
index 000000000000..d2e7747072dd
--- /dev/null
+++ b/devel/cook/pkg-descr
@@ -0,0 +1,6 @@
+'cook' serves the same purpose as make(1), but uses a much more sane syntax,
+and includes additional features that make it powerful enough to maintain a
+single dependency graph for large projects (as things should be done in an
+ideal world). Don't be put off by 'cook' not being commonly available on
+target machines, since 'cook' can automatically generate shell scripts that
+make installing 'cook' on target machines unnecessary.
diff --git a/devel/cook/pkg-message b/devel/cook/pkg-message
new file mode 100644
index 000000000000..9edc833ded72
--- /dev/null
+++ b/devel/cook/pkg-message
@@ -0,0 +1,2 @@
+Add ${PREFIX}/share/cook/man to your MANPATH in order to access the manual
+pages included with this port.
diff --git a/devel/cook/pkg-plist b/devel/cook/pkg-plist
new file mode 100644
index 000000000000..bf6758ed190e
--- /dev/null
+++ b/devel/cook/pkg-plist
@@ -0,0 +1,67 @@
+bin/c_incl
+bin/cook
+bin/cook_bom
+bin/cookfp
+bin/cooktime
+bin/find_libs
+bin/make2cook
+bin/roffpp
+info/dir
+lib/cook/en/LC_MESSAGES/c_incl.mo
+lib/cook/en/LC_MESSAGES/cook.mo
+lib/cook/en/LC_MESSAGES/cook_bom.mo
+lib/cook/en/LC_MESSAGES/cookfp.mo
+lib/cook/en/LC_MESSAGES/cooktime.mo
+lib/cook/en/LC_MESSAGES/find_libs.mo
+lib/cook/en/LC_MESSAGES/fstrcmp.mo
+lib/cook/en/LC_MESSAGES/make2cook.mo
+lib/cook/en/LC_MESSAGES/roffpp.mo
+share/cook/en/building.ps
+share/cook/en/building.dvi
+share/cook/en/building.txt
+share/cook/en/lsm.ps
+share/cook/en/lsm.dvi
+share/cook/en/lsm.txt
+share/cook/en/man1/.not_empty
+share/cook/en/readme.ps
+share/cook/en/readme.dvi
+share/cook/en/readme.txt
+share/cook/en/refman.ps
+share/cook/en/refman.dvi
+share/cook/en/refman.txt
+share/cook/en/release.ps
+share/cook/en/release.dvi
+share/cook/en/release.txt
+share/cook/en/user-guide.ps
+share/cook/en/user-guide.dvi
+share/cook/en/user-guide.txt
+share/cook/as
+share/cook/bison
+share/cook/c
+share/cook/f77
+share/cook/functions
+share/cook/g77
+share/cook/gcc
+share/cook/home
+share/cook/lex
+share/cook/library
+share/cook/print
+share/cook/program
+share/cook/rcs
+share/cook/recursive
+share/cook/sccs
+share/cook/text
+share/cook/usr
+share/cook/usr.local
+share/cook/yacc
+share/cook/yacc_many
+@dirrm lib/cook/en/LC_MESSAGES
+@dirrm lib/cook/en
+@dirrm lib/cook
+@dirrm share/cook/man/en/man1
+@dirrm share/cook/man/en
+@dirrm share/cook/man/man1
+@dirrm share/cook/man
+@dirrm share/cook/en/man1
+@dirrm share/cook/en
+@dirrm share/cook