aboutsummaryrefslogtreecommitdiff
path: root/devel/cppcheck
diff options
context:
space:
mode:
authorBrendan Fabeny <bf@FreeBSD.org>2013-06-11 15:25:53 +0000
committerBrendan Fabeny <bf@FreeBSD.org>2013-06-11 15:25:53 +0000
commitda5ccc0e43e366445dd86657559c7eea33496b6c (patch)
tree5a3d3fa45febe888d10fdaf9b8f73782dbfc6c99 /devel/cppcheck
parent7c24512abdf8d32b0e15d5ae18fff7e5d8e9c4e2 (diff)
downloadports-da5ccc0e43e366445dd86657559c7eea33496b6c.tar.gz
ports-da5ccc0e43e366445dd86657559c7eea33496b6c.zip
Switch from the bundled tinyxml2 to the new textproc/tinyxml2 port
Notes
Notes: svn path=/head/; revision=320605
Diffstat (limited to 'devel/cppcheck')
-rw-r--r--devel/cppcheck/Makefile11
1 files changed, 6 insertions, 5 deletions
diff --git a/devel/cppcheck/Makefile b/devel/cppcheck/Makefile
index eabf0c9b3723..2884f9b22adf 100644
--- a/devel/cppcheck/Makefile
+++ b/devel/cppcheck/Makefile
@@ -3,6 +3,7 @@
PORTNAME= cppcheck
PORTVERSION= 1.60.1
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= SF/${PORTNAME}/${PORTNAME}/${PORTVERSION}/
@@ -11,14 +12,14 @@ COMMENT= Static analysis of C/C++ code
LICENSE= GPLv3
-#LIB_DEPENDS= tinyxml:${PORTSDIR}/textproc/tinyxml
+LIB_DEPENDS= tinyxml2:${PORTSDIR}/textproc/tinyxml2
USE_BZIP2= yes
USE_GMAKE= yes
ALL_TARGET= cppcheck
LDFLAGS+= -L${LOCALBASE}/lib
-#MAKE_ENV+= TINYXML=-ltinyxml
+MAKE_ENV+= TINYXML=-ltinyxml2
OPTIONS_DEFINE= MATCHCOMPILER RULES
OPTIONS_DEFAULT= MATCHCOMPILER RULES
@@ -53,9 +54,9 @@ MAKE_ENV+= HAVE_RULES=yes
.endif
post-patch:
-# @${REINPLACE_CMD} \
-# -e 's|-Iexternals/tinyxml|-I${LOCALBASE}/include|' \
-# ${WRKSRC}/Makefile
+ @${REINPLACE_CMD} \
+ -e 's|-Iexternals/tinyxml|-I${LOCALBASE}/include|' \
+ ${WRKSRC}/Makefile
.if ${PORT_OPTIONS:MDOCS}
@${REINPLACE_CMD} -e '\|DB2MAN=|d' \
${WRKSRC}/Makefile