aboutsummaryrefslogtreecommitdiff
path: root/devel/cppunit
diff options
context:
space:
mode:
authorBryan Drewery <bdrewery@FreeBSD.org>2013-10-09 13:47:48 +0000
committerBryan Drewery <bdrewery@FreeBSD.org>2013-10-09 13:47:48 +0000
commitdf2625aa3d7a973a054779463821b28955cf1052 (patch)
tree14e657b9ff914be9031ad713a76abe5a4bab767a /devel/cppunit
parent28abdae5df05a815b672fbf05c6d4086246bf03b (diff)
downloadports-df2625aa3d7a973a054779463821b28955cf1052.tar.gz
ports-df2625aa3d7a973a054779463821b28955cf1052.zip
- Convert to staging
- Convert WITH_DOXYGEN to an option
Notes
Notes: svn path=/head/; revision=329899
Diffstat (limited to 'devel/cppunit')
-rw-r--r--devel/cppunit/Makefile41
-rw-r--r--devel/cppunit/pkg-plist1
2 files changed, 17 insertions, 25 deletions
diff --git a/devel/cppunit/Makefile b/devel/cppunit/Makefile
index b23a07933c3b..408c97842858 100644
--- a/devel/cppunit/Makefile
+++ b/devel/cppunit/Makefile
@@ -9,28 +9,21 @@ MASTER_SITES= SF
MAINTAINER= bdrewery@FreeBSD.org
COMMENT= C++ port of the JUnit framework for unit testing
+OPTIONS_DEFINE= DOXYGEN
+
USE_AUTOTOOLS= libtool
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
-NO_STAGE= yes
-.if defined(WITH_DOXYGEN)
-BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
+.include <bsd.port.options.mk>
+
+.if ${PORT_OPTIONS:MDOXYGEN}
+BUILD_DEPENDS+= doxygen:${PORTSDIR}/devel/doxygen
CONFIGURE_ARGS+= --enable-doc --enable-doxygen --enable-html-docs
-PLIST_SUB+= HTMLDOCS="" PORTDOCS=""
+PLIST_SUB+= HTMLDOCS="" PORTDOCS=""
.else
CONFIGURE_ARGS+= --disable-doc --disable-doxygen
-PLIST_SUB+= HTMLDOCS="@comment "
-.endif
-
-MAN1= cppunit-config.1
-#MANCOMPRESSED= no
-
-pre-everything::
-.if !defined(WITH_DOXYGEN)
- @${ECHO_MSG}
- @${ECHO_MSG} "You could define WITH_DOXYGEN if you want HTML documentation"
- @${ECHO_MSG}
+PLIST_SUB+= HTMLDOCS="@comment "
.endif
post-patch:
@@ -38,15 +31,13 @@ post-patch:
${WRKSRC}/Makefile.in
post-install:
- @${FIND} ${PREFIX}/include/cppunit ! -type d | \
- ${SED} 's,^${PREFIX}/,,' >> ${TMPPLIST}
- @${FIND} ${PREFIX}/include/cppunit -type d | ${SORT} -r | \
- ${SED} 's,^${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
-.if !defined(NOPORTDOCS) || defined(WITH_DOXYGEN)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/doc/FAQ ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/NEWS ${DOCSDIR}
- ${INSTALL_MAN} ${WRKSRC}/README ${DOCSDIR}
-.endif
+ @${FIND} ${STAGEDIR}${PREFIX}/include/cppunit ! -type d | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,,' >> ${TMPPLIST}
+ @${FIND} ${STAGEDIR}${PREFIX}/include/cppunit -type d | ${SORT} -r | \
+ ${SED} 's,^${STAGEDIR}${PREFIX}/,@dirrm ,' >> ${TMPPLIST}
+ ${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/doc/FAQ ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/NEWS ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_MAN} ${WRKSRC}/README ${STAGEDIR}${DOCSDIR}
.include <bsd.port.mk>
diff --git a/devel/cppunit/pkg-plist b/devel/cppunit/pkg-plist
index 4cadeb0e75f0..551566e2b3ff 100644
--- a/devel/cppunit/pkg-plist
+++ b/devel/cppunit/pkg-plist
@@ -6,6 +6,7 @@ lib/libcppunit.a
lib/libcppunit.la
lib/libcppunit.so
libdata/pkgconfig/cppunit.pc
+man/man1/cppunit-config.1.gz
share/aclocal/cppunit.m4
%%HTMLDOCS%%%%DOCSDIR%%/index.html
%%HTMLDOCS%%%%DOCSDIR%%/_additional_message_8cpp.html