aboutsummaryrefslogtreecommitdiff
path: root/devel/cram
diff options
context:
space:
mode:
authorConrad Meyer <cem@FreeBSD.org>2016-05-11 14:53:46 +0000
committerConrad Meyer <cem@FreeBSD.org>2016-05-11 14:53:46 +0000
commitbbec90bd0e44c781351eacfaeedad3db22c501b4 (patch)
tree6e3d800d3fbf82d6b49b6abe105503171884d5fa /devel/cram
parente6d67e0c3c612bda5920264264b8e8bd96954eff (diff)
downloadports-bbec90bd0e44c781351eacfaeedad3db22c501b4.tar.gz
ports-bbec90bd0e44c781351eacfaeedad3db22c501b4.zip
New port: devel/cram, a simple command line test framework
Cram is a functional testing framework for command line applications. Cram tests look like snippets of interactive shell sessions. Cram runs each command and compares the command output in the test with the command’s actual output.
Notes
Notes: svn path=/head/; revision=415002
Diffstat (limited to 'devel/cram')
-rw-r--r--devel/cram/Makefile23
-rw-r--r--devel/cram/distinfo2
-rw-r--r--devel/cram/pkg-descr5
3 files changed, 30 insertions, 0 deletions
diff --git a/devel/cram/Makefile b/devel/cram/Makefile
new file mode 100644
index 000000000000..4f6271247f91
--- /dev/null
+++ b/devel/cram/Makefile
@@ -0,0 +1,23 @@
+# Created by: Conrad Meyer <cem@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= cram
+PORTVERSION= 0.7
+CATEGORIES= devel python
+MASTER_SITES= CHEESESHOP
+PKGNAMEPREFIX= ${PYTHON_PKGNAMEPREFIX}
+
+MAINTAINER= cem@FreeBSD.org
+COMMENT= A simple testing framework for command line applications
+
+LICENSE= GPLv2+
+
+BUILD_DEPENDS= ${PYTHON_PKGNAMEPREFIX}check-manifest>=0:devel/py-check-manifest \
+ ${PYTHON_PKGNAMEPREFIX}coverage>=0:devel/py-coverage \
+ ${PYTHON_PKGNAMEPREFIX}pep8>=0:devel/pep8 \
+ ${PYTHON_PKGNAMEPREFIX}pyflakes>=0:devel/py-pyflakes
+
+USES= python
+USE_PYTHON= autoplist distutils
+
+.include <bsd.port.mk>
diff --git a/devel/cram/distinfo b/devel/cram/distinfo
new file mode 100644
index 000000000000..e3fc9dd9687f
--- /dev/null
+++ b/devel/cram/distinfo
@@ -0,0 +1,2 @@
+SHA256 (cram-0.7.tar.gz) = 7da7445af2ce15b90aad5ec4792f857cef5786d71f14377e9eb994d8b8337f2f
+SIZE (cram-0.7.tar.gz) = 33527
diff --git a/devel/cram/pkg-descr b/devel/cram/pkg-descr
new file mode 100644
index 000000000000..233895712d91
--- /dev/null
+++ b/devel/cram/pkg-descr
@@ -0,0 +1,5 @@
+Cram is a functional testing framework for command line applications. Cram
+tests look like snippets of interactive shell sessions. Cram runs each command
+and compares the command output in the test with the command’s actual output.
+
+WWW: https://pypi.python.org/pypi/cram