aboutsummaryrefslogtreecommitdiff
path: root/devel/cscout
diff options
context:
space:
mode:
authorAlexander Leidinger <netchild@FreeBSD.org>2003-07-10 14:47:34 +0000
committerAlexander Leidinger <netchild@FreeBSD.org>2003-07-10 14:47:34 +0000
commit49e34644e4fd57830b6fae3694a46db64d5e0ea8 (patch)
tree75abb2ee19ae38a881780715a242c4f96a771c07 /devel/cscout
parent925a0becd4f204a6530a62153305e65769c7185d (diff)
downloadports-49e34644e4fd57830b6fae3694a46db64d5e0ea8.tar.gz
ports-49e34644e4fd57830b6fae3694a46db64d5e0ea8.zip
This is Diomidis Spinellis' (dds@FreeBSD.org) source code analyzer and
refactoring browser for collections of C programs. I coordinated the creation of the port with him, he will maintain the port himself in the future. I think this is the first binary only program (at least in the ports collection) which supports FreeBSD on alpha, amd64, i386, ia64 and sparc64. Reviewed by: dds
Notes
Notes: svn path=/head/; revision=84602
Diffstat (limited to 'devel/cscout')
-rw-r--r--devel/cscout/Makefile65
-rw-r--r--devel/cscout/distinfo6
-rw-r--r--devel/cscout/pkg-descr19
-rw-r--r--devel/cscout/pkg-plist85
4 files changed, 175 insertions, 0 deletions
diff --git a/devel/cscout/Makefile b/devel/cscout/Makefile
new file mode 100644
index 000000000000..d7a8c210aaee
--- /dev/null
+++ b/devel/cscout/Makefile
@@ -0,0 +1,65 @@
+# New ports collection makefile for: cscout
+# Date created: 07. Jul 2003
+# Whom: netchild@FreeBSD.org
+#
+# $FreeBSD$
+#
+
+PORTNAME= cscout
+PORTVERSION= 1.13
+CATEGORIES= devel
+MASTER_SITES= http://www.spinellis.gr/cscout/ \
+ http://www.dmst.aueb.gr/dds/cscout/
+DISTFILES= ${PORTNAME}-${PORTVERSION}-neutral${EXTRACT_SUFX} \
+ ${PORTNAME}-${PORTVERSION}-freebsd-${ARCH}${EXTRACT_SUFX}
+
+MAINTAINER= dds@FreeBSD.org
+COMMENT= Source code analyzer and refactoring browser for collections of C programs
+
+WRKSRC= ${WRKDIR}/${PORTNAME}
+NO_BUILD= yes
+USE_REINPLACE= yes
+
+MAN1= cscout.1 cswc.1
+
+CPIO= /usr/bin/cpio
+SORT= /usr/bin/sort
+
+post-patch:
+.if exists(/usr/include/g++/)
+ ${REINPLACE_CMD} -i "" -e 's:g++-3:g++:g' \
+ ${WRKSRC}/etc/cscout_incs.FBSD_GCC
+.endif
+ (${SED} -n '1,/Platform defines begin/p' \
+ ${WRKSRC}/etc/cscout_defs.FBSD_GCC && \
+ ${CPP} -O -dM /dev/null | ${SORT} && \
+ ${SED} -n '/Platform defines end/,$$p' \
+ ${WRKSRC}/etc/cscout_defs.FBSD_GCC ) \
+ > ${WRKDIR}/cscout_defs.h
+ ${CP} ${WRKDIR}/cscout_defs.h ${WRKSRC}/etc/cscout_defs.FBSD_GCC
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/bin/cscout ${PREFIX}/bin
+ ${INSTALL_SCRIPT} ${WRKSRC}/bin/cswc ${PREFIX}/bin
+ cd ${WRKSRC}/etc && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${PREFIX}/etc/${PORTNAME}
+# don't overwrite an existing config
+.if !exists(${PREFIX}/etc/${PORTNAME}/cscout_incs.h)
+ ${INSTALL_DATA} ${WRKSRC}/etc/cscout_incs.FBSD_GCC ${PREFIX}/etc/${PORTNAME}/cscout_incs.h
+.endif
+.if !exists(${PREFIX}/etc/${PORTNAME}/cscout_defs.h)
+ ${INSTALL_DATA} ${WRKDIR}/cscout_defs.h ${PREFIX}/etc/${PORTNAME}/cscout_defs.h
+.endif
+.if !defined(NOPORTDOCS)
+ cd ${WRKSRC}/example && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${EXAMPLESDIR}
+ cd ${WRKSRC}/doc && ${FIND} . -print | \
+ ${CPIO} -pdu -R ${BINOWN}:${BINGRP} --quiet ${DOCSDIR}
+.endif
+.if !defined(NO_INSTALL_MANPAGES)
+.for i in ${MAN1}
+ ${INSTALL_MAN} ${WRKSRC}/man/${i} ${PREFIX}/man/man1
+.endfor
+.endif
+
+.include <bsd.port.mk>
diff --git a/devel/cscout/distinfo b/devel/cscout/distinfo
new file mode 100644
index 000000000000..6154392833e5
--- /dev/null
+++ b/devel/cscout/distinfo
@@ -0,0 +1,6 @@
+MD5 (cscout-1.13-neutral.tar.gz) = f0375409ec8ace35275d574a1b9b31de
+MD5 (cscout-1.13-freebsd-alpha.tar.gz) = 4ed279c40ea1a29d556b536525b28b76
+MD5 (cscout-1.13-freebsd-amd64.tar.gz) = 675c901bef6ecd25ff1ac83e96187fb8
+MD5 (cscout-1.13-freebsd-i386.tar.gz) = 7b900b27fc15cc159fce8833e4d98682
+MD5 (cscout-1.13-freebsd-ia64.tar.gz) = a21ea9b417dc775ebe44c7c451da961e
+MD5 (cscout-1.13-freebsd-sparc64.tar.gz) = 0e58ee5f8e0c7cf7145c4f282fca865d
diff --git a/devel/cscout/pkg-descr b/devel/cscout/pkg-descr
new file mode 100644
index 000000000000..87bc0a321552
--- /dev/null
+++ b/devel/cscout/pkg-descr
@@ -0,0 +1,19 @@
+CScout is a source code analyzer and refactoring browser for collections
+of C programs. It can process workspaces of multiple projects (we define
+a project as a collection of C source files that are linked together)
+mapping the complexity introduced by the C preprocessor back into
+the original C source code files. CScout takes advantage of modern
+hardware advances (fast processors and large memory capacities) to
+analyze C source code beyond the level of detail and accuracy provided
+by current compilers and linkers. The analysis CScout performs takes
+into account the identifier scopes introduced by the C preprocessor and
+the C language proper scopes and namespaces. CScout has already been
+applied on projects of tens of thousands of lines, like the apache web
+server (using 320MB of (virtual) memory, taking 40 minutes on a 500MHz
+Celeron processor with 128MB of RAM).
+
+This free unsupported version of CScout is distributed under the terms
+of the CScout Public License, which is available in the accompanying
+documentation.
+
+WWW: http://www.spinellis.gr/cscout/
diff --git a/devel/cscout/pkg-plist b/devel/cscout/pkg-plist
new file mode 100644
index 000000000000..eec620be4a8d
--- /dev/null
+++ b/devel/cscout/pkg-plist
@@ -0,0 +1,85 @@
+bin/cscout
+bin/cswc
+@unexec if cmp -s %D/etc/cscout/cscout_defs.h %D/etc/cscout/cscout_defs.FBSD_GCC; then rm -f %D/etc/cscout/cscout_defs.h; fi
+@unexec if cmp -s %D/etc/cscout/cscout_incs.h %D/etc/cscout/cscout_incs.FBSD_GCC; then rm -f %D/etc/cscout/cscout_incs.h; fi
+etc/cscout/cscout_defs.BORLAND
+etc/cscout/cscout_defs.FBSD_GCC
+etc/cscout/cscout_defs.GENERIC
+etc/cscout/cscout_defs.LINUX_GCC
+etc/cscout/cscout_defs.WIN32_MINGW
+etc/cscout/cscout_defs.WIN32_MSC
+etc/cscout/cscout_incs.FBSD_GCC
+etc/cscout/cscout_incs.GENERIC
+etc/cscout/cscout_incs.LINUX_GCC
+etc/cscout/cscout_incs.WIN32_MINGW
+etc/cscout/cscout_incs.WIN32_MSC
+@unexec rmdir %D/etc/cscout || true
+%%PORTDOCS%%%%DOCSDIR%%/access.html
+%%PORTDOCS%%%%DOCSDIR%%/contents.html
+%%PORTDOCS%%%%DOCSDIR%%/cvs.html
+%%PORTDOCS%%%%DOCSDIR%%/egglos.html
+%%PORTDOCS%%%%DOCSDIR%%/error.html
+%%PORTDOCS%%%%DOCSDIR%%/ext.html
+%%PORTDOCS%%%%DOCSDIR%%/faq.html
+%%PORTDOCS%%%%DOCSDIR%%/file.html
+%%PORTDOCS%%%%DOCSDIR%%/fq.html
+%%PORTDOCS%%%%DOCSDIR%%/geglos.html
+%%PORTDOCS%%%%DOCSDIR%%/id.html
+%%PORTDOCS%%%%DOCSDIR%%/idq.html
+%%PORTDOCS%%%%DOCSDIR%%/idxprint.html
+%%PORTDOCS%%%%DOCSDIR%%/index.html
+%%PORTDOCS%%%%DOCSDIR%%/indexw.html
+%%PORTDOCS%%%%DOCSDIR%%/intro.html
+%%PORTDOCS%%%%DOCSDIR%%/license.html
+%%PORTDOCS%%%%DOCSDIR%%/mancscout.html
+%%PORTDOCS%%%%DOCSDIR%%/mancswc.html
+%%PORTDOCS%%%%DOCSDIR%%/name.html
+%%PORTDOCS%%%%DOCSDIR%%/op.html
+%%PORTDOCS%%%%DOCSDIR%%/opt.html
+%%PORTDOCS%%%%DOCSDIR%%/pragma.html
+%%PORTDOCS%%%%DOCSDIR%%/re.html
+%%PORTDOCS%%%%DOCSDIR%%/run.html
+%%PORTDOCS%%%%DOCSDIR%%/setup.html
+%%PORTDOCS%%%%DOCSDIR%%/short.html
+%%PORTDOCS%%%%DOCSDIR%%/simul.html
+%%PORTDOCS%%%%DOCSDIR%%/walk.html
+%%PORTDOCS%%%%DOCSDIR%%/web.html
+%%PORTDOCS%%%%DOCSDIR%%/wsp.html
+%%PORTDOCS%%%%DOCSDIR%%/yacc.html
+%%PORTDOCS%%@dirrm %%DOCSDIR%%
+%%PORTDOCS%%%%EXAMPLESDIR%%/.cscout/cscout_defs.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/.cscout/cscout_incs.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk.prj
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/FIXES
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/README
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/awk.1
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/awk.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/awkgram.y
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/b.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/buildwin.bat
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/lex.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/lib.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/mac.code
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/main.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/makefile
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/makefile.win
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/maketab.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/missing95.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/parse.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/proctab.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/proto.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/run.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/tran.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/vcvars32.bat
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/ytab.c
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/ytab.h
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/ytabc.bak
+%%PORTDOCS%%%%EXAMPLESDIR%%/awk/ytabh.bak
+%%PORTDOCS%%%%EXAMPLESDIR%%/bin.prj
+%%PORTDOCS%%%%EXAMPLESDIR%%/mkproj
+%%PORTDOCS%%%%EXAMPLESDIR%%/sh.prj
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/.cscout
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%/awk
+%%PORTDOCS%%@dirrm %%EXAMPLESDIR%%