aboutsummaryrefslogtreecommitdiff
path: root/devel/darts/Makefile
diff options
context:
space:
mode:
authorAkinori MUSHA <knu@FreeBSD.org>2003-04-02 12:03:44 +0000
committerAkinori MUSHA <knu@FreeBSD.org>2003-04-02 12:03:44 +0000
commit60209edaa67605cb2c21046dc067413967264302 (patch)
tree56175baf616b1c49afd520ca0435862cd9f72efb /devel/darts/Makefile
parentdc6364288742e3cc15bdca0e5cc8ab0f09dcba34 (diff)
downloadports-60209edaa67605cb2c21046dc067413967264302.tar.gz
ports-60209edaa67605cb2c21046dc067413967264302.zip
Add darts, a C++ template library that implements Double-Array.
Notes
Notes: svn path=/head/; revision=77973
Diffstat (limited to 'devel/darts/Makefile')
-rw-r--r--devel/darts/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/darts/Makefile b/devel/darts/Makefile
new file mode 100644
index 000000000000..1f3fef7b2cf8
--- /dev/null
+++ b/devel/darts/Makefile
@@ -0,0 +1,33 @@
+# New ports collection makefile for: darts
+# Date created: 2 April 2003
+# Whom: Akinori MUSHA aka knu <knu@idaemons.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= darts
+PORTVERSION= 0.1
+CATEGORIES= devel
+MASTER_SITES= http://cl.aist-nara.ac.jp/~taku-ku/software/darts/src/
+
+MAINTAINER= knu@FreeBSD.org
+COMMENT= A C++ template library that implements Double-Array
+
+GNU_CONFIGURE= yes
+
+EXAMPLES= darts.cpp mkdarts.cpp
+DOCS= AUTHORS ChangeLog README doc
+
+post-install:
+.if !defined(NOPORTDOCS)
+ ${MKDIR} ${EXAMPLESDIR}
+.for f in ${EXAMPLES}
+ ${CP} -R ${WRKSRC}/${f} ${EXAMPLESDIR}/
+.endfor
+ ${MKDIR} ${DOCSDIR}
+.for f in ${DOCS}
+ ${CP} -R ${WRKSRC}/${f} ${DOCSDIR}/
+.endfor
+.endif
+
+.include <bsd.port.mk>