aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus-tcl
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2016-04-19 14:20:01 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2016-04-19 14:20:01 +0000
commit4e23c21fc178f53926a6fdce031c92cf22ece907 (patch)
tree14fe99943d56267ca815906c549d8a671245db05 /devel/dbus-tcl
parentc1364a4b63589dc9afcb8aed2258c90b1fe957d6 (diff)
downloadports-4e23c21fc178f53926a6fdce031c92cf22ece907.tar.gz
ports-4e23c21fc178f53926a6fdce031c92cf22ece907.zip
Add "tea" argument to USES=tcl to facilitate porting of TEA-based extensions.
Quoting https://tcl.tk/doc/tea: "The Tcl Extension Architecture, or TEA, by John Ousterhout and others, is a set of guidelines and techniques for the distribution, configuration, compilation, and installation of Tcl extensions. TEA also provides a set of utilities that operate accordingly. Many Tcl extensions leverage the TEA utilities, which are designed to be easily customizable." To facilitate the porting of TEA-based extensions, I have added the new "tea" argument to USES=tcl. This argument prepares the autoconf environment by setting GNU_CONFIGURE and sets some commonly used CONFIGURE_ARGS. Also, it tries to figure out the correct extension name, sets TCL_PKG accordingly, and adds it to PLIST_SUB. I have modified a few ports to take advantage of this. More will come.
Notes
Notes: svn path=/head/; revision=413646
Diffstat (limited to 'devel/dbus-tcl')
-rw-r--r--devel/dbus-tcl/Makefile9
1 files changed, 3 insertions, 6 deletions
diff --git a/devel/dbus-tcl/Makefile b/devel/dbus-tcl/Makefile
index 5c5505fdcc25..df51d4108b77 100644
--- a/devel/dbus-tcl/Makefile
+++ b/devel/dbus-tcl/Makefile
@@ -21,10 +21,7 @@ PORTDOCS= *
TEST_TARGET= do-test
-USES= pkgconfig tcl:85+
-GNU_CONFIGURE= yes
-CONFIGURE_ARGS+=--with-tcl=${TCL_LIBDIR} \
- --exec-prefix=${PREFIX}
+USES= pkgconfig tcl:85+,tea
PLIST_FILES= lib/dbus/libdbus21.so.1 \
lib/dbus/pkgIndex.tcl \
@@ -36,8 +33,8 @@ post-patch:
do-test:
DBUS=$$(${LOCALBASE}/bin/dbus-daemon --session --print-address --fork --print-pid); \
- DBUS_ADDR=$$(echo $$DBUS | awk '{print $$1}'); \
- DBUS_PID=$$(echo $$DBUS | awk '{print $$2}'); \
+ DBUS_ADDR=$$(echo $$DBUS | ${AWK} '{print $$1}'); \
+ DBUS_PID=$$(echo $$DBUS | ${AWK} '{print $$2}'); \
DBUS_ENV=DBUS_SESSION_BUS_ADDRESS=$$DBUS_ADDR; \
${SETENV} ${MAKE_ENV} $$DBUS_ENV ${MAKE} -C ${WRKSRC} test; \
kill $$DBUS_PID