aboutsummaryrefslogtreecommitdiff
path: root/devel/dbus
diff options
context:
space:
mode:
authorJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-27 02:05:30 +0000
committerJoe Marcus Clarke <marcus@FreeBSD.org>2006-10-27 02:05:30 +0000
commit7b1e0fc98007f16cd31f7a64a3e8f5d4d54b5fae (patch)
tree6983c5fb0056146944d91771edaf0f5b1103d0a0 /devel/dbus
parent4713aa09b68765331b0d061b41dc3c9a7f75a120 (diff)
downloadports-7b1e0fc98007f16cd31f7a64a3e8f5d4d54b5fae.tar.gz
ports-7b1e0fc98007f16cd31f7a64a3e8f5d4d54b5fae.zip
Add a missing #include to correct a problem where dbus would refuse to
launch if /usr/local or /usr/X11R6 were NFS mounts. The error seen would be: Failed to start message bus: Can't calculate buffer size when reading directory Approved by: portmgr (implicit)
Notes
Notes: svn path=/head/; revision=175538
Diffstat (limited to 'devel/dbus')
-rw-r--r--devel/dbus/Makefile2
-rw-r--r--devel/dbus/files/patch-dbus_dbus-sysdeps-util-unix.c14
2 files changed, 12 insertions, 4 deletions
diff --git a/devel/dbus/Makefile b/devel/dbus/Makefile
index 590c3fea87a4..c4b9b5b04ecc 100644
--- a/devel/dbus/Makefile
+++ b/devel/dbus/Makefile
@@ -7,7 +7,7 @@
PORTNAME= dbus
PORTVERSION?= 0.93
-PORTREVISION?= 2
+PORTREVISION?= 3
CATEGORIES= devel gnome
MASTER_SITES= http://dbus.freedesktop.org/releases/
diff --git a/devel/dbus/files/patch-dbus_dbus-sysdeps-util-unix.c b/devel/dbus/files/patch-dbus_dbus-sysdeps-util-unix.c
index 28701094bd8b..2372578ee8b9 100644
--- a/devel/dbus/files/patch-dbus_dbus-sysdeps-util-unix.c
+++ b/devel/dbus/files/patch-dbus_dbus-sysdeps-util-unix.c
@@ -1,6 +1,14 @@
---- dbus/dbus-sysdeps-util-unix.c.orig Sat Oct 7 12:33:47 2006
-+++ dbus/dbus-sysdeps-util-unix.c Sat Oct 7 12:34:13 2006
-@@ -502,7 +502,7 @@ static dbus_bool_t
+--- dbus/dbus-sysdeps-util-unix.c.orig Thu Oct 26 22:02:29 2006
++++ dbus/dbus-sysdeps-util-unix.c Thu Oct 26 22:02:52 2006
+@@ -42,6 +42,7 @@
+ #include <sys/socket.h>
+ #include <dirent.h>
+ #include <sys/un.h>
++#include <limits.h>
+
+ #ifndef O_BINARY
+ #define O_BINARY 0
+@@ -502,7 +503,7 @@ static dbus_bool_t
dirent_buf_size(DIR * dirp, size_t *size)
{
long name_max;