aboutsummaryrefslogtreecommitdiff
path: root/devel/dcmtk
diff options
context:
space:
mode:
authorPietro Cerutti <gahr@FreeBSD.org>2010-07-28 09:45:02 +0000
committerPietro Cerutti <gahr@FreeBSD.org>2010-07-28 09:45:02 +0000
commitd302b29d5169e02197be908a31e395a347e88550 (patch)
tree1f979a4f255dd93a6f5e140497983dd47157fd9a /devel/dcmtk
parent29e4fbb3a58e146a88832c05a5cca65ed488d41e (diff)
downloadports-d302b29d5169e02197be908a31e395a347e88550.tar.gz
ports-d302b29d5169e02197be908a31e395a347e88550.zip
- New port: devel/dcmtk
DCMTK - DICOM Toolkit DCMTK is a collection of libraries and applications implementing large parts of the DICOM standard. It includes software for examining, constructing and converting DICOM image files, handling offline media, sending and receiving images over a network connection, as well as demonstrative image storage and worklist servers. DCMTK is is written in a mixture of ANSI C and C++.
Notes
Notes: svn path=/head/; revision=258365
Diffstat (limited to 'devel/dcmtk')
-rw-r--r--devel/dcmtk/Makefile52
-rw-r--r--devel/dcmtk/Makefile.man8
-rw-r--r--devel/dcmtk/distinfo3
-rw-r--r--devel/dcmtk/files/patch-config_Makefile.def.in25
-rw-r--r--devel/dcmtk/files/patch-config_configure15
-rw-r--r--devel/dcmtk/pkg-descr8
-rw-r--r--devel/dcmtk/pkg-plist497
7 files changed, 608 insertions, 0 deletions
diff --git a/devel/dcmtk/Makefile b/devel/dcmtk/Makefile
new file mode 100644
index 000000000000..b5148702b477
--- /dev/null
+++ b/devel/dcmtk/Makefile
@@ -0,0 +1,52 @@
+# New ports collection Makefile for: dcmtk
+# Date created: 26 July 2010
+# Whom: gahr
+#
+# $FreeBSD$
+#
+
+PORTNAME= dcmtk
+PORTVERSION= 3.5.4
+CATEGORIES= devel
+MASTER_SITES= ftp://dicom.offis.de/pub/dicom/offis/software/${PORTNAME}/${PORTNAME}${PORTVERSION:S/.//g}/
+
+MAINTAINER= gahr@FreeBSD.org
+COMMENT= A toolkit to work with DICOM files
+
+LIB_DEPENDS= tiff.4:${PORTSDIR}/graphics/tiff \
+ png.6:${PORTSDIR}/graphics/png \
+ jpeg.11:${PORTSDIR}/graphics/jpeg
+
+USE_GMAKE= yes
+USE_GNOME= libxml2
+USE_LDCONFIG= yes
+
+CFLAGS= -D__BSD_VISIBLE
+CPPFLAGS= ${CFLAGS}
+GNU_CONFIGURE= yes
+CONFIGURE_ARGS+=--with-libpnginc=${LOCALBASE}/include \
+ --with-libtiffinc=${LOCALBASE}/include \
+ --with-libxmlinc=${LOCALBASE}/include \
+ --bindir=${PREFIX}/bin/${PORTNAME} \
+ --sysconfdir=${PREFIX}/etc/${PORTNAME} \
+ --datadir=${DATADIR}
+CONFIGURE_ENV+= CPPFLAGS="${CPPFLAGS}" AR="${CXX}" \
+ ARFLAGS="-shared -o" LIBEXT="so" RANLIB=":"
+
+INSTALL_TARGET= install install-lib
+
+SHLIBS= dcmdata dcmdsig dcmimage dcmimgle dcmjpeg dcmnet \
+ dcmpstat dcmqrdb dcmsr dcmtls dcmwlm ijg12 ijg16 \
+ ijg8 ofstd
+SHLIBVER= ${PORTVERSION:R:R}
+PLIST_SUB= SHLIBVER=${SHLIBVER}
+
+post-install:
+.for shlib in ${SHLIBS}
+ @${MV} ${PREFIX}/lib/lib${shlib}.so ${PREFIX}/lib/lib${shlib}.so.${SHLIBVER}
+ @${LN} -sf ${PREFIX}/lib/lib${shlib}.so.${SHLIBVER} ${PREFIX}/lib/lib${shlib}.so
+.endfor
+
+.include "Makefile.man"
+.include <bsd.port.mk>
+
diff --git a/devel/dcmtk/Makefile.man b/devel/dcmtk/Makefile.man
new file mode 100644
index 000000000000..f7b8dc91a3cf
--- /dev/null
+++ b/devel/dcmtk/Makefile.man
@@ -0,0 +1,8 @@
+MAN1= dcm2pnm.1 dcmcrle.1 dcmdump.1 dcmmkcrv.1 dcmp2pgm.1 dcmpsmk.1 \
+ dcmqridx.1 dcmscale.1 dsr2html.1 echoscu.1 storescp.1 xml2dcm.1 \
+ dcm2xml.1 dcmdjpeg.1 dcmftest.1 dcmmkdir.1 dcmprscp.1 dcmpsprt.1 \
+ dcmqrscp.1 dcmsign.1 dsr2xml.1 findscu.1 storescu.1 xml2dsr.1 \
+ dcmcjpeg.1 dcmdrle.1 dcmgpdir.1 dcmmklut.1 dcmprscu.1 dcmpsrcv.1 \
+ dcmqrti.1 dcod2lum.1 dsrdump.1 movescu.1 termscu.1 dcmconv.1 \
+ dcmdspfn.1 dcmj2pnm.1 dcmodify.1 dcmpschk.1 dcmpssnd.1 dcmquant.1 \
+ dconvlum.1 dump2dcm.1 pdf2dcm.1 wlmscpfs.1
diff --git a/devel/dcmtk/distinfo b/devel/dcmtk/distinfo
new file mode 100644
index 000000000000..2dc1f709b906
--- /dev/null
+++ b/devel/dcmtk/distinfo
@@ -0,0 +1,3 @@
+MD5 (dcmtk-3.5.4.tar.gz) = 0afd971cdf976a5b336722ef2f68e6d7
+SHA256 (dcmtk-3.5.4.tar.gz) = 7b8575ba609516d76b681c0de8c1328cf23e57deb2c7085a6aa37d4292354d76
+SIZE (dcmtk-3.5.4.tar.gz) = 3756374
diff --git a/devel/dcmtk/files/patch-config_Makefile.def.in b/devel/dcmtk/files/patch-config_Makefile.def.in
new file mode 100644
index 000000000000..cfdd18d06a2a
--- /dev/null
+++ b/devel/dcmtk/files/patch-config_Makefile.def.in
@@ -0,0 +1,25 @@
+--- config/Makefile.def.in.orig 2004-11-12 13:43:35.000000000 +0000
++++ config/Makefile.def.in 2010-07-27 19:23:16.000000000 +0000
+@@ -11,8 +11,8 @@
+
+ bindir = $(DESTDIR)@bindir@
+ etcdir = $(DESTDIR)@sysconfdir@
+-datadir = $(DESTDIR)@datadir@/data
+-docdir = $(DESTDIR)@datadir@/doc
++datadir = $(DESTDIR)@datadir@
++docdir = $(DESTDIR)/@datadir@
+ mandir = $(DESTDIR)@mandir@
+ libdir = $(DESTDIR)@libdir@
+ includedir = $(DESTDIR)@includedir@
+@@ -86,9 +86,9 @@
+ .SUFFIXES: .o .cc .c .h
+
+ .cc.o:
+- $(CXX) $(defines) -c $(includes) $(ARCH) \
++ $(CXX) $(defines) -c $(includes) \
+ $(CPPFLAGS) $(CXXFLAGS) $<
+
+ .c.o:
+- $(CC) $(defines) -c $(includes) $(ARCH) \
++ $(CC) $(defines) -c $(includes) \
+ $(CPPFLAGS) $(CFLAGS) $<
diff --git a/devel/dcmtk/files/patch-config_configure b/devel/dcmtk/files/patch-config_configure
new file mode 100644
index 000000000000..6b436ee1c9ae
--- /dev/null
+++ b/devel/dcmtk/files/patch-config_configure
@@ -0,0 +1,15 @@
+--- config/configure.orig 2010-07-28 07:44:25.000000000 +0000
++++ config/configure 2010-07-28 07:47:33.000000000 +0000
+@@ -15824,9 +15824,9 @@
+ CXXFLAGS="-D_POSIX_C_SOURCE=199506L $CXXFLAGS"
+ CFLAGS="-D_POSIX_C_SOURCE=199506L $CFLAGS"
+ ;;
+- *-*-freebsd5*)
+- ;;
+- *-*-freebsd6*)
++ *-*-freebsd*)
++ CXXFLAGS="-D_XOPEN_SOURCE_EXTENDED -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_BSD_COMPAT -D_OSF_SOURCE -D_POSIX_C_SOURCE=199506L $CXXFLAGS"
++ CFLAGS="-D_XOPEN_SOURCE_EXTENDED -D_XOPEN_SOURCE=600 -D_BSD_SOURCE -D_BSD_COMPAT -D_OSF_SOURCE -D_POSIX_C_SOURCE=199506L $CFLAGS"
+ ;;
+ *-*-netbsdelf2*)
+ ;;
diff --git a/devel/dcmtk/pkg-descr b/devel/dcmtk/pkg-descr
new file mode 100644
index 000000000000..d14093e38a5c
--- /dev/null
+++ b/devel/dcmtk/pkg-descr
@@ -0,0 +1,8 @@
+DCMTK is a collection of libraries and applications implementing large parts
+of the DICOM standard. DCMTK includes software for examining, constructing and
+converting DICOM image files, handling offline media, sending and receiving
+images over a network connection, as well as demonstrative image storage and
+worklist servers. DCMTK comes in complete source code and is written in a
+mixture of ANSI C and C++.
+
+WWW: http://dicom.offis.de/dcmtk.php.en
diff --git a/devel/dcmtk/pkg-plist b/devel/dcmtk/pkg-plist
new file mode 100644
index 000000000000..f515c0c344ae
--- /dev/null
+++ b/devel/dcmtk/pkg-plist
@@ -0,0 +1,497 @@
+bin/dcmtk/dcm2pnm
+bin/dcmtk/dcm2xml
+bin/dcmtk/dcmcjpeg
+bin/dcmtk/dcmconv
+bin/dcmtk/dcmcrle
+bin/dcmtk/dcmdjpeg
+bin/dcmtk/dcmdrle
+bin/dcmtk/dcmdspfn
+bin/dcmtk/dcmdump
+bin/dcmtk/dcmftest
+bin/dcmtk/dcmgpdir
+bin/dcmtk/dcmj2pnm
+bin/dcmtk/dcmmkcrv
+bin/dcmtk/dcmmkdir
+bin/dcmtk/dcmmklut
+bin/dcmtk/dcmodify
+bin/dcmtk/dcmp2pgm
+bin/dcmtk/dcmprscp
+bin/dcmtk/dcmprscu
+bin/dcmtk/dcmpschk
+bin/dcmtk/dcmpsmk
+bin/dcmtk/dcmpsprt
+bin/dcmtk/dcmpsrcv
+bin/dcmtk/dcmpssnd
+bin/dcmtk/dcmqridx
+bin/dcmtk/dcmqrscp
+bin/dcmtk/dcmqrti
+bin/dcmtk/dcmquant
+bin/dcmtk/dcmscale
+bin/dcmtk/dcmsign
+bin/dcmtk/dcod2lum
+bin/dcmtk/dconvlum
+bin/dcmtk/dsr2html
+bin/dcmtk/dsr2xml
+bin/dcmtk/dsrdump
+bin/dcmtk/dump2dcm
+bin/dcmtk/echoscu
+bin/dcmtk/findscu
+bin/dcmtk/movescu
+bin/dcmtk/pdf2dcm
+bin/dcmtk/storescp
+bin/dcmtk/storescu
+bin/dcmtk/termscu
+bin/dcmtk/wlmscpfs
+bin/dcmtk/xml2dcm
+bin/dcmtk/xml2dsr
+etc/dcmtk/dcmpstat.cfg
+etc/dcmtk/dcmqrscp.cfg
+etc/dcmtk/printers.cfg
+etc/dcmtk/storescp.cfg
+etc/dcmtk/storescu.cfg
+include/dcmtk/config/cfunix.h
+include/dcmtk/config/osconfig.h
+include/dcmtk/dcmdata/cmdlnarg.h
+include/dcmtk/dcmdata/dcbytstr.h
+include/dcmtk/dcmdata/dcchrstr.h
+include/dcmtk/dcmdata/dccodec.h
+include/dcmtk/dcmdata/dcdatset.h
+include/dcmtk/dcmdata/dcddirif.h
+include/dcmtk/dcmdata/dcdebug.h
+include/dcmtk/dcmdata/dcdefine.h
+include/dcmtk/dcmdata/dcdeftag.h
+include/dcmtk/dcmdata/dcdicdir.h
+include/dcmtk/dcmdata/dcdicent.h
+include/dcmtk/dcmdata/dcdict.h
+include/dcmtk/dcmdata/dcdirrec.h
+include/dcmtk/dcmdata/dcelem.h
+include/dcmtk/dcmdata/dcerror.h
+include/dcmtk/dcmdata/dcfilefo.h
+include/dcmtk/dcmdata/dchashdi.h
+include/dcmtk/dcmdata/dcistrma.h
+include/dcmtk/dcmdata/dcistrmb.h
+include/dcmtk/dcmdata/dcistrmf.h
+include/dcmtk/dcmdata/dcistrmz.h
+include/dcmtk/dcmdata/dcitem.h
+include/dcmtk/dcmdata/dclist.h
+include/dcmtk/dcmdata/dcmetinf.h
+include/dcmtk/dcmdata/dcobject.h
+include/dcmtk/dcmdata/dcofsetl.h
+include/dcmtk/dcmdata/dcostrma.h
+include/dcmtk/dcmdata/dcostrmb.h
+include/dcmtk/dcmdata/dcostrmf.h
+include/dcmtk/dcmdata/dcostrmz.h
+include/dcmtk/dcmdata/dcovlay.h
+include/dcmtk/dcmdata/dcpcache.h
+include/dcmtk/dcmdata/dcpixel.h
+include/dcmtk/dcmdata/dcpixseq.h
+include/dcmtk/dcmdata/dcpxitem.h
+include/dcmtk/dcmdata/dcrleccd.h
+include/dcmtk/dcmdata/dcrlecce.h
+include/dcmtk/dcmdata/dcrlecp.h
+include/dcmtk/dcmdata/dcrledec.h
+include/dcmtk/dcmdata/dcrledrg.h
+include/dcmtk/dcmdata/dcrleenc.h
+include/dcmtk/dcmdata/dcrleerg.h
+include/dcmtk/dcmdata/dcrlerp.h
+include/dcmtk/dcmdata/dcsequen.h
+include/dcmtk/dcmdata/dcstack.h
+include/dcmtk/dcmdata/dcswap.h
+include/dcmtk/dcmdata/dctag.h
+include/dcmtk/dcmdata/dctagkey.h
+include/dcmtk/dcmdata/dctk.h
+include/dcmtk/dcmdata/dctypes.h
+include/dcmtk/dcmdata/dcuid.h
+include/dcmtk/dcmdata/dcvm.h
+include/dcmtk/dcmdata/dcvr.h
+include/dcmtk/dcmdata/dcvrae.h
+include/dcmtk/dcmdata/dcvras.h
+include/dcmtk/dcmdata/dcvrat.h
+include/dcmtk/dcmdata/dcvrcs.h
+include/dcmtk/dcmdata/dcvrda.h
+include/dcmtk/dcmdata/dcvrds.h
+include/dcmtk/dcmdata/dcvrdt.h
+include/dcmtk/dcmdata/dcvrfd.h
+include/dcmtk/dcmdata/dcvrfl.h
+include/dcmtk/dcmdata/dcvris.h
+include/dcmtk/dcmdata/dcvrlo.h
+include/dcmtk/dcmdata/dcvrlt.h
+include/dcmtk/dcmdata/dcvrobow.h
+include/dcmtk/dcmdata/dcvrof.h
+include/dcmtk/dcmdata/dcvrpn.h
+include/dcmtk/dcmdata/dcvrpobw.h
+include/dcmtk/dcmdata/dcvrsh.h
+include/dcmtk/dcmdata/dcvrsl.h
+include/dcmtk/dcmdata/dcvrss.h
+include/dcmtk/dcmdata/dcvrst.h
+include/dcmtk/dcmdata/dcvrtm.h
+include/dcmtk/dcmdata/dcvrui.h
+include/dcmtk/dcmdata/dcvrul.h
+include/dcmtk/dcmdata/dcvrulup.h
+include/dcmtk/dcmdata/dcvrus.h
+include/dcmtk/dcmdata/dcvrut.h
+include/dcmtk/dcmdata/dcxfer.h
+include/dcmtk/dcmimage/diargimg.h
+include/dcmtk/dcmimage/diargpxt.h
+include/dcmtk/dcmimage/dicmyimg.h
+include/dcmtk/dcmimage/dicmypxt.h
+include/dcmtk/dcmimage/dicocpt.h
+include/dcmtk/dcmimage/dicoflt.h
+include/dcmtk/dcmimage/dicoimg.h
+include/dcmtk/dcmimage/dicomot.h
+include/dcmtk/dcmimage/dicoopx.h
+include/dcmtk/dcmimage/dicoopxt.h
+include/dcmtk/dcmimage/dicopx.h
+include/dcmtk/dcmimage/dicopxt.h
+include/dcmtk/dcmimage/dicorot.h
+include/dcmtk/dcmimage/dicosct.h
+include/dcmtk/dcmimage/dihsvimg.h
+include/dcmtk/dcmimage/dihsvpxt.h
+include/dcmtk/dcmimage/dipalimg.h
+include/dcmtk/dcmimage/dipalpxt.h
+include/dcmtk/dcmimage/dipipng.h
+include/dcmtk/dcmimage/dipitiff.h
+include/dcmtk/dcmimage/diqtcmap.h
+include/dcmtk/dcmimage/diqtctab.h
+include/dcmtk/dcmimage/diqtfs.h
+include/dcmtk/dcmimage/diqthash.h
+include/dcmtk/dcmimage/diqthitl.h
+include/dcmtk/dcmimage/diqthitm.h
+include/dcmtk/dcmimage/diqtid.h
+include/dcmtk/dcmimage/diqtpbox.h
+include/dcmtk/dcmimage/diqtpix.h
+include/dcmtk/dcmimage/diqtstab.h
+include/dcmtk/dcmimage/diqttype.h
+include/dcmtk/dcmimage/diquant.h
+include/dcmtk/dcmimage/diregist.h
+include/dcmtk/dcmimage/dirgbimg.h
+include/dcmtk/dcmimage/dirgbpxt.h
+include/dcmtk/dcmimage/diybrimg.h
+include/dcmtk/dcmimage/diybrpxt.h
+include/dcmtk/dcmimage/diyf2img.h
+include/dcmtk/dcmimage/diyf2pxt.h
+include/dcmtk/dcmimage/diyp2img.h
+include/dcmtk/dcmimage/diyp2pxt.h
+include/dcmtk/dcmimgle/dcmimage.h
+include/dcmtk/dcmimgle/dibaslut.h
+include/dcmtk/dcmimgle/diciefn.h
+include/dcmtk/dcmimgle/dicielut.h
+include/dcmtk/dcmimgle/dicrvfit.h
+include/dcmtk/dcmimgle/didislut.h
+include/dcmtk/dcmimgle/didispfn.h
+include/dcmtk/dcmimgle/didocu.h
+include/dcmtk/dcmimgle/diflipt.h
+include/dcmtk/dcmimgle/digsdfn.h
+include/dcmtk/dcmimgle/digsdlut.h
+include/dcmtk/dcmimgle/diimage.h
+include/dcmtk/dcmimgle/diinpx.h
+include/dcmtk/dcmimgle/diinpxt.h
+include/dcmtk/dcmimgle/diluptab.h
+include/dcmtk/dcmimgle/dimo1img.h
+include/dcmtk/dcmimgle/dimo2img.h
+include/dcmtk/dcmimgle/dimocpt.h
+include/dcmtk/dcmimgle/dimoflt.h
+include/dcmtk/dcmimgle/dimoimg.h
+include/dcmtk/dcmimgle/dimoipxt.h
+include/dcmtk/dcmimgle/dimomod.h
+include/dcmtk/dcmimgle/dimoopx.h
+include/dcmtk/dcmimgle/dimoopxt.h
+include/dcmtk/dcmimgle/dimopx.h
+include/dcmtk/dcmimgle/dimopxt.h
+include/dcmtk/dcmimgle/dimorot.h
+include/dcmtk/dcmimgle/dimosct.h
+include/dcmtk/dcmimgle/diobjcou.h
+include/dcmtk/dcmimgle/diovdat.h
+include/dcmtk/dcmimgle/diovlay.h
+include/dcmtk/dcmimgle/diovlimg.h
+include/dcmtk/dcmimgle/diovpln.h
+include/dcmtk/dcmimgle/dipixel.h
+include/dcmtk/dcmimgle/diplugin.h
+include/dcmtk/dcmimgle/dipxrept.h
+include/dcmtk/dcmimgle/diregbas.h
+include/dcmtk/dcmimgle/dirotat.h
+include/dcmtk/dcmimgle/discalet.h
+include/dcmtk/dcmimgle/displint.h
+include/dcmtk/dcmimgle/ditranst.h
+include/dcmtk/dcmimgle/diutils.h
+include/dcmtk/dcmjpeg/ddpiimpl.h
+include/dcmtk/dcmjpeg/dipijpeg.h
+include/dcmtk/dcmjpeg/djcodecd.h
+include/dcmtk/dcmjpeg/djcodece.h
+include/dcmtk/dcmjpeg/djcparam.h
+include/dcmtk/dcmjpeg/djdecabs.h
+include/dcmtk/dcmjpeg/djdecbas.h
+include/dcmtk/dcmjpeg/djdecext.h
+include/dcmtk/dcmjpeg/djdeclol.h
+include/dcmtk/dcmjpeg/djdecode.h
+include/dcmtk/dcmjpeg/djdecpro.h
+include/dcmtk/dcmjpeg/djdecsps.h
+include/dcmtk/dcmjpeg/djdecsv1.h
+include/dcmtk/dcmjpeg/djdijg12.h
+include/dcmtk/dcmjpeg/djdijg16.h
+include/dcmtk/dcmjpeg/djdijg8.h
+include/dcmtk/dcmjpeg/djeijg12.h
+include/dcmtk/dcmjpeg/djeijg16.h
+include/dcmtk/dcmjpeg/djeijg8.h
+include/dcmtk/dcmjpeg/djencabs.h
+include/dcmtk/dcmjpeg/djencbas.h
+include/dcmtk/dcmjpeg/djencext.h
+include/dcmtk/dcmjpeg/djenclol.h
+include/dcmtk/dcmjpeg/djencode.h
+include/dcmtk/dcmjpeg/djencpro.h
+include/dcmtk/dcmjpeg/djencsps.h
+include/dcmtk/dcmjpeg/djencsv1.h
+include/dcmtk/dcmjpeg/djrplol.h
+include/dcmtk/dcmjpeg/djrploss.h
+include/dcmtk/dcmjpeg/djutils.h
+include/dcmtk/dcmnet/assoc.h
+include/dcmtk/dcmnet/cond.h
+include/dcmtk/dcmnet/dcasccff.h
+include/dcmtk/dcmnet/dcasccfg.h
+include/dcmtk/dcmnet/dccfenmp.h
+include/dcmtk/dcmnet/dccfpcmp.h
+include/dcmtk/dcmnet/dccfprmp.h
+include/dcmtk/dcmnet/dccfrsmp.h
+include/dcmtk/dcmnet/dccftsmp.h
+include/dcmtk/dcmnet/dccfuidh.h
+include/dcmtk/dcmnet/dcmlayer.h
+include/dcmtk/dcmnet/dcmsmap.h
+include/dcmtk/dcmnet/dcmtrans.h
+include/dcmtk/dcmnet/dcompat.h
+include/dcmtk/dcmnet/dicom.h
+include/dcmtk/dcmnet/dimse.h
+include/dcmtk/dcmnet/diutil.h
+include/dcmtk/dcmnet/dul.h
+include/dcmtk/dcmnet/extneg.h
+include/dcmtk/dcmnet/lst.h
+include/dcmtk/dcmpstat/dcmpstat.h
+include/dcmtk/dcmpstat/dvcache.h
+include/dcmtk/dcmpstat/dviface.h
+include/dcmtk/dcmpstat/dvpsab.h
+include/dcmtk/dcmpstat/dvpsabl.h
+include/dcmtk/dcmpstat/dvpsal.h
+include/dcmtk/dcmpstat/dvpsall.h
+include/dcmtk/dcmpstat/dvpscf.h
+include/dcmtk/dcmpstat/dvpscu.h
+include/dcmtk/dcmpstat/dvpscul.h
+include/dcmtk/dcmpstat/dvpsda.h
+include/dcmtk/dcmpstat/dvpsdal.h
+include/dcmtk/dcmpstat/dvpsdef.h
+include/dcmtk/dcmpstat/dvpsfs.h
+include/dcmtk/dcmpstat/dvpsga.h
+include/dcmtk/dcmpstat/dvpsgal.h
+include/dcmtk/dcmpstat/dvpsgl.h
+include/dcmtk/dcmpstat/dvpsgll.h
+include/dcmtk/dcmpstat/dvpsgr.h
+include/dcmtk/dcmpstat/dvpsgrl.h
+include/dcmtk/dcmpstat/dvpshlp.h
+include/dcmtk/dcmpstat/dvpsib.h
+include/dcmtk/dcmpstat/dvpsibl.h
+include/dcmtk/dcmpstat/dvpsmsg.h
+include/dcmtk/dcmpstat/dvpsov.h
+include/dcmtk/dcmpstat/dvpsovl.h
+include/dcmtk/dcmpstat/dvpspl.h
+include/dcmtk/dcmpstat/dvpspll.h
+include/dcmtk/dcmpstat/dvpspr.h
+include/dcmtk/dcmpstat/dvpsprt.h
+include/dcmtk/dcmpstat/dvpsri.h
+include/dcmtk/dcmpstat/dvpsril.h
+include/dcmtk/dcmpstat/dvpsrs.h
+include/dcmtk/dcmpstat/dvpsrsl.h
+include/dcmtk/dcmpstat/dvpssp.h
+include/dcmtk/dcmpstat/dvpsspl.h
+include/dcmtk/dcmpstat/dvpssv.h
+include/dcmtk/dcmpstat/dvpssvl.h
+include/dcmtk/dcmpstat/dvpstat.h
+include/dcmtk/dcmpstat/dvpstx.h
+include/dcmtk/dcmpstat/dvpstxl.h
+include/dcmtk/dcmpstat/dvpstyp.h
+include/dcmtk/dcmpstat/dvpsvl.h
+include/dcmtk/dcmpstat/dvpsvll.h
+include/dcmtk/dcmpstat/dvpsvw.h
+include/dcmtk/dcmpstat/dvpsvwl.h
+include/dcmtk/dcmpstat/dvsighdl.h
+include/dcmtk/dcmqrdb/dcmqrcbf.h
+include/dcmtk/dcmqrdb/dcmqrcbg.h
+include/dcmtk/dcmqrdb/dcmqrcbm.h
+include/dcmtk/dcmqrdb/dcmqrcbs.h
+include/dcmtk/dcmqrdb/dcmqrcnf.h
+include/dcmtk/dcmqrdb/dcmqrdba.h
+include/dcmtk/dcmqrdb/dcmqrdbi.h
+include/dcmtk/dcmqrdb/dcmqrdbs.h
+include/dcmtk/dcmqrdb/dcmqridx.h
+include/dcmtk/dcmqrdb/dcmqropt.h
+include/dcmtk/dcmqrdb/dcmqrptb.h
+include/dcmtk/dcmqrdb/dcmqrsrv.h
+include/dcmtk/dcmqrdb/dcmqrtis.h
+include/dcmtk/dcmsign/dcsignat.h
+include/dcmtk/dcmsign/sialgo.h
+include/dcmtk/dcmsign/siautopr.h
+include/dcmtk/dcmsign/sibrsapr.h
+include/dcmtk/dcmsign/sicert.h
+include/dcmtk/dcmsign/sicertvf.h
+include/dcmtk/dcmsign/sicreapr.h
+include/dcmtk/dcmsign/sidsa.h
+include/dcmtk/dcmsign/simac.h
+include/dcmtk/dcmsign/simaccon.h
+include/dcmtk/dcmsign/simd5.h
+include/dcmtk/dcmsign/sinullpr.h
+include/dcmtk/dcmsign/siprivat.h
+include/dcmtk/dcmsign/siripemd.h
+include/dcmtk/dcmsign/sirsa.h
+include/dcmtk/dcmsign/sisha1.h
+include/dcmtk/dcmsign/sisprof.h
+include/dcmtk/dcmsign/sitstamp.h
+include/dcmtk/dcmsign/sitypes.h
+include/dcmtk/dcmsr/dsrbascc.h
+include/dcmtk/dcmsr/dsrchecc.h
+include/dcmtk/dcmsr/dsrcitem.h
+include/dcmtk/dcmsr/dsrcodtn.h
+include/dcmtk/dcmsr/dsrcodvl.h
+include/dcmtk/dcmsr/dsrcomcc.h
+include/dcmtk/dcmsr/dsrcomtn.h
+include/dcmtk/dcmsr/dsrcomvl.h
+include/dcmtk/dcmsr/dsrcontn.h
+include/dcmtk/dcmsr/dsrcsidl.h
+include/dcmtk/dcmsr/dsrdattn.h
+include/dcmtk/dcmsr/dsrdoc.h
+include/dcmtk/dcmsr/dsrdoctn.h
+include/dcmtk/dcmsr/dsrdoctr.h
+include/dcmtk/dcmsr/dsrdtitn.h
+include/dcmtk/dcmsr/dsrenhcc.h
+include/dcmtk/dcmsr/dsrimgfr.h
+include/dcmtk/dcmsr/dsrimgtn.h
+include/dcmtk/dcmsr/dsrimgvl.h
+include/dcmtk/dcmsr/dsriodcc.h
+include/dcmtk/dcmsr/dsrkeycc.h
+include/dcmtk/dcmsr/dsrmamcc.h
+include/dcmtk/dcmsr/dsrnumtn.h
+include/dcmtk/dcmsr/dsrnumvl.h
+include/dcmtk/dcmsr/dsrpnmtn.h
+include/dcmtk/dcmsr/dsrprocc.h
+include/dcmtk/dcmsr/dsrreftn.h
+include/dcmtk/dcmsr/dsrscogr.h
+include/dcmtk/dcmsr/dsrscotn.h
+include/dcmtk/dcmsr/dsrscovl.h
+include/dcmtk/dcmsr/dsrsoprf.h
+include/dcmtk/dcmsr/dsrstrvl.h
+include/dcmtk/dcmsr/dsrtcodt.h
+include/dcmtk/dcmsr/dsrtcosp.h
+include/dcmtk/dcmsr/dsrtcotn.h
+include/dcmtk/dcmsr/dsrtcoto.h
+include/dcmtk/dcmsr/dsrtcovl.h
+include/dcmtk/dcmsr/dsrtextn.h
+include/dcmtk/dcmsr/dsrtimtn.h
+include/dcmtk/dcmsr/dsrtlist.h
+include/dcmtk/dcmsr/dsrtncsr.h
+include/dcmtk/dcmsr/dsrtree.h
+include/dcmtk/dcmsr/dsrtypes.h
+include/dcmtk/dcmsr/dsruidtn.h
+include/dcmtk/dcmsr/dsrwavch.h
+include/dcmtk/dcmsr/dsrwavtn.h
+include/dcmtk/dcmsr/dsrwavvl.h
+include/dcmtk/dcmsr/dsrxmlc.h
+include/dcmtk/dcmsr/dsrxmld.h
+include/dcmtk/dcmsr/dsrxrdcc.h
+include/dcmtk/dcmtls/tlslayer.h
+include/dcmtk/dcmtls/tlstrans.h
+include/dcmtk/dcmwlm/wlds.h
+include/dcmtk/dcmwlm/wldsfs.h
+include/dcmtk/dcmwlm/wlfsim.h
+include/dcmtk/dcmwlm/wlmactmg.h
+include/dcmtk/dcmwlm/wltypdef.h
+include/dcmtk/ofstd/ofalgo.h
+include/dcmtk/ofstd/ofbmanip.h
+include/dcmtk/ofstd/ofcast.h
+include/dcmtk/ofstd/ofcmdln.h
+include/dcmtk/ofstd/ofconapp.h
+include/dcmtk/ofstd/ofcond.h
+include/dcmtk/ofstd/ofconfig.h
+include/dcmtk/ofstd/ofconsol.h
+include/dcmtk/ofstd/ofcrc32.h
+include/dcmtk/ofstd/ofdate.h
+include/dcmtk/ofstd/ofdatime.h
+include/dcmtk/ofstd/offname.h
+include/dcmtk/ofstd/ofglobal.h
+include/dcmtk/ofstd/oflist.h
+include/dcmtk/ofstd/oflogfil.h
+include/dcmtk/ofstd/ofoset.h
+include/dcmtk/ofstd/ofset.h
+include/dcmtk/ofstd/ofsetit.h
+include/dcmtk/ofstd/ofstack.h
+include/dcmtk/ofstd/ofstd.h
+include/dcmtk/ofstd/ofstdinc.h
+include/dcmtk/ofstd/ofstream.h
+include/dcmtk/ofstd/ofstring.h
+include/dcmtk/ofstd/ofthread.h
+include/dcmtk/ofstd/oftime.h
+include/dcmtk/ofstd/oftimer.h
+include/dcmtk/ofstd/oftypes.h
+include/dcmtk/ofstd/ofuoset.h
+lib/dcm2xml.dtd
+lib/dicom.dic
+lib/dsr2xml.xsd
+lib/libdcmdata.so.%%SHLIBVER%%
+lib/libdcmdata.so
+lib/libdcmdsig.so.%%SHLIBVER%%
+lib/libdcmdsig.so
+lib/libdcmimage.so.%%SHLIBVER%%
+lib/libdcmimage.so
+lib/libdcmimgle.so.%%SHLIBVER%%
+lib/libdcmimgle.so
+lib/libdcmjpeg.so.%%SHLIBVER%%
+lib/libdcmjpeg.so
+lib/libdcmnet.so.%%SHLIBVER%%
+lib/libdcmnet.so
+lib/libdcmpstat.so.%%SHLIBVER%%
+lib/libdcmpstat.so
+lib/libdcmqrdb.so.%%SHLIBVER%%
+lib/libdcmqrdb.so
+lib/libdcmsr.so.%%SHLIBVER%%
+lib/libdcmsr.so
+lib/libdcmtls.so.%%SHLIBVER%%
+lib/libdcmtls.so
+lib/libdcmwlm.so.%%SHLIBVER%%
+lib/libdcmwlm.so
+lib/libijg12.so.%%SHLIBVER%%
+lib/libijg12.so
+lib/libijg16.so.%%SHLIBVER%%
+lib/libijg16.so
+lib/libijg8.so.%%SHLIBVER%%
+lib/libijg8.so
+lib/libofstd.so.%%SHLIBVER%%
+lib/libofstd.so
+%%DATADIR%%/camera.lut
+%%DATADIR%%/dumppat.txt
+%%DATADIR%%/monitor.lut
+%%DATADIR%%/philips.lut
+%%DATADIR%%/printer.lut
+%%DATADIR%%/scanner.lut
+%%DATADIR%%/COPYRIGHT
+%%DATADIR%%/FAQ
+%%DATADIR%%/HISTORY
+%%DATADIR%%/asconfig.txt
+%%DATADIR%%/ciphers.txt
+%%DATADIR%%/datadict.txt
+%%DATADIR%%/dcmqrcnf.txt
+%%DATADIR%%/dcmqrset.txt
+%%DATADIR%%/randseed.txt
+%%DATADIR%%/testing.txt
+%%DATADIR%%/wwwapp.txt
+@dirrm %%DATADIR%%
+@dirrm include/dcmtk/ofstd
+@dirrm include/dcmtk/dcmwlm
+@dirrm include/dcmtk/dcmtls
+@dirrm include/dcmtk/dcmsr
+@dirrm include/dcmtk/dcmsign
+@dirrm include/dcmtk/dcmqrdb
+@dirrm include/dcmtk/dcmpstat
+@dirrm include/dcmtk/dcmnet
+@dirrm include/dcmtk/dcmjpeg
+@dirrm include/dcmtk/dcmimgle
+@dirrm include/dcmtk/dcmimage
+@dirrm include/dcmtk/dcmdata
+@dirrm include/dcmtk/config
+@dirrm include/dcmtk
+@dirrm etc/dcmtk
+@dirrm bin/dcmtk