aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf/Makefile
diff options
context:
space:
mode:
authorKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
committerKoop Mast <kwm@FreeBSD.org>2013-03-08 10:51:34 +0000
commit7887c684adab042fed1bfcba2e91589ecd17c4a8 (patch)
tree961839899dce7f75292a08c079f548973bdbd40d /devel/dconf/Makefile
parent85544f2c01be814e0af1ebee1076012e7ed60bb0 (diff)
downloadports-7887c684adab042fed1bfcba2e91589ecd17c4a8.tar.gz
ports-7887c684adab042fed1bfcba2e91589ecd17c4a8.zip
* Update the glib to 2.34.3 and gtk20 to 2.24.17 and gtk30 to 3.6.4 which
are the latest stable releases. * Update vala to the newest stable release 0.18.1, also update a few ports in the gtk/gnome stack. * The c++ bindings ports for glib, atk, gconf, etc, have now USE_GNOME toggles. * Remove pkg-config run depends from glib20 and freetype2. This doesn't eliminate pkg-config run dependency completely, a second phase is needed and is planned. * Support for .:run. and .:build. for USE_GNOME components was added. Currently only libxml2 and libxslt support this mechanism. * Updates of the telepathy stack and empathy. * Trim makefile headers, convert ports to new options, trim off library versions for some ports. * Fix other ports so they build with the new glib version. Thanks to miwi and crees for helping out with some exp-runs. Approved by: portmgr (miwi & bapt) Obtained from: gnome team repo
Notes
Notes: svn path=/head/; revision=313633
Diffstat (limited to 'devel/dconf/Makefile')
-rw-r--r--devel/dconf/Makefile58
1 files changed, 39 insertions, 19 deletions
diff --git a/devel/dconf/Makefile b/devel/dconf/Makefile
index 21df21c88cc6..d392d7ac9acc 100644
--- a/devel/dconf/Makefile
+++ b/devel/dconf/Makefile
@@ -1,41 +1,61 @@
-# New ports collection makefile for: dconf
-# Date created: 28 May 2010
-# Whom: Koop Mast <kwm@FreeBSD.org>
-#
+# Created by: Koop Mast <kwm@FreeBSD.org>
# $FreeBSD$
-# $MCom: ports/devel/dconf/Makefile,v 1.9 2010/11/04 16:41:01 kwm Exp $
-#
+# $MCom: ports/devel/dconf/Makefile,v 1.30 2012/10/03 17:57:17 kwm Exp $
-PORTNAME= dconf
-PORTVERSION= 0.5.1
-PORTREVISION= 4
+PORTNAME?= dconf
+PORTVERSION= 0.12.1
+PORTREVISION= 1
CATEGORIES= devel gnome
MASTER_SITES= GNOME
+DISTNAME= dconf-${PORTVERSION}
DIST_SUBDIR= gnome3
MAINTAINER= gnome@FreeBSD.org
COMMENT= A configuration database system for GNOME
-BUILD_DEPENDS= g-ir-scanner:${PORTSDIR}/devel/gobject-introspection \
- valac:${PORTSDIR}/lang/vala
-LIB_DEPENDS= gee.2:${PORTSDIR}/devel/libgee
+BUILD_DEPENDS= vala>=0.11.7:${PORTSDIR}/lang/vala
+LIB_DEPENDS= dbus-1:${PORTSDIR}/devel/dbus
-USE_BZIP2= yes
+USE_XZ= yes
USE_GMAKE= yes
-#USE_GETTEXT= yes
-USE_GNOME= gnomehack gtk20
+USE_GNOME= gnomehack glib20 gnomehier
USE_LDCONFIG= yes
GNU_CONFIGURE= yes
-
-MAKE_JOBS_SAFE= yes
-
+MAKE_JOBS_UNSAFE= yes
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+DCONF_SLAVE?= no
+
+.if ${DCONF_SLAVE} == "editor"
+USE_GNOME+= gtk30
+INSTALLS_ICONS= yes
+GLIB_SCHEMAS= ca.desrt.dconf-editor.gschema.xml
+LIB_DEPENDS+= dconf:${PORTSDIR}/devel/dconf
+.else
+CONFIGURE_ARGS+=--disable-editor
+.endif
+
+post-patch:
+ @${REINPLACE_CMD} -e 's|/etc/|${PREFIX}/etc/|g' \
+ ${WRKSRC}/engine/dconf-engine.c \
+ ${WRKSRC}/bin/dconf-update.c
+ @${REINPLACE_CMD} -e 's|/usr/local/|${LOCALBASE}/|g' \
+ ${WRKSRC}/editor/dconf-model.c
+ @${REINPLACE_CMD} -e 's|/usr/share|${LOCALBASE}/share|g' \
+ ${WRKSRC}/editor/dconf-model.vala
+ @${REINPLACE_CMD} -e 's|-Wno-unused-but-set-variable||g' \
+ ${WRKSRC}/bin/Makefile.in \
+ ${WRKSRC}/client/Makefile.in \
+ ${WRKSRC}/editor/Makefile.in
+
pre-build:
- ${GMAKE} -C ${WRKSRC}/client dconf-client.c libdconf.so.0
+# ${GMAKE} -C ${WRKSRC}/client dconf-client.c libdconf.so.0
+# ${GMAKE} -C ${WRKSRC}/dbus-1 dconf-dbus-1.c libdconf-dbus-1.so.0
post-install:
-${LOCALBASE}/bin/gio-querymodules ${PREFIX}/lib/gio/modules
+ @${MKDIR} ${PREFIX}/etc/dconf/db
+ @${MKDIR} ${PREFIX}/etc/dconf/profile
.include <bsd.port.mk>