aboutsummaryrefslogtreecommitdiff
path: root/devel/dconf/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2020-06-16 08:39:18 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2020-06-16 08:39:18 +0000
commitbcc17ec7c0beaab5f8743ca71b58f45b5c39e2b3 (patch)
tree0f681fbbc137b38a95c0d18a39d2205fb5cbbe90 /devel/dconf/Makefile
parent67dd5e8c3cc444e252615008701f04aed5fd4d84 (diff)
downloadports-bcc17ec7c0beaab5f8743ca71b58f45b5c39e2b3.tar.gz
ports-bcc17ec7c0beaab5f8743ca71b58f45b5c39e2b3.zip
Fix build on FreeBSD 11
The builds fails with base binutils when it is used. While it builds perfectly fine with lld let's always enforce binutils from ports because the combinaison to catch all systems default on the old GNU ld non trivial to make. Reported by: antoine, kib
Notes
Notes: svn path=/head/; revision=539334
Diffstat (limited to 'devel/dconf/Makefile')
-rw-r--r--devel/dconf/Makefile2
1 files changed, 2 insertions, 0 deletions
diff --git a/devel/dconf/Makefile b/devel/dconf/Makefile
index d11304ec6712..02ddfd76d18b 100644
--- a/devel/dconf/Makefile
+++ b/devel/dconf/Makefile
@@ -24,6 +24,8 @@ PORTSCOUT= limitw:1,even
USES= gettext gnome localbase meson pkgconfig python:3.6+,build tar:xz
USE_GNOME= glib20 libxslt:build
USE_LDCONFIG= yes
+USE_BINUTILS= yes
+LDFLAGS+= -B${LOCALBASE}/bin
BINARY_ALIAS= python3=${PYTHON_VERSION}
MESON_ARGS= -Dman=true \