aboutsummaryrefslogtreecommitdiff
path: root/devel/dfmt/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-07-23 05:14:10 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2017-07-23 05:14:10 +0000
commit35537a31e95e59742ff650755ff79c118e83c995 (patch)
tree946f6a3edd6673292e445170a0df23b70cfda556 /devel/dfmt/Makefile
parentc044c1fca430c37c3a87ad94bc9917182990fb01 (diff)
downloadports-35537a31e95e59742ff650755ff79c118e83c995.tar.gz
ports-35537a31e95e59742ff650755ff79c118e83c995.zip
- New port: devel/dfmt
dfmt is a formatter for D source code. dfmt is beta quality. Make backups of your files or use source control when using the --inplace option. WWW: https://github.com/dlang-community/dfmt
Notes
Notes: svn path=/head/; revision=446448
Diffstat (limited to 'devel/dfmt/Makefile')
-rw-r--r--devel/dfmt/Makefile33
1 files changed, 33 insertions, 0 deletions
diff --git a/devel/dfmt/Makefile b/devel/dfmt/Makefile
new file mode 100644
index 000000000000..1ae609ce9d0c
--- /dev/null
+++ b/devel/dfmt/Makefile
@@ -0,0 +1,33 @@
+# Created by: Alonso Cardenas Marquez <acm@FreeBSD.org>
+# $FreeBSD$
+
+PORTNAME= dfmt
+DISTVERSION= 0.5.0beta5
+CATEGORIES= devel
+MASTER_SITES= https://github.com/dlang-community/dfmt/archive/
+DISTNAME= ${DISTVERSION:S/^/v/:S/beta5/-beta.5/}
+DIST_SUBDIR= ${PORTNAME}
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Formatter for D source code
+
+LICENSE= BSL
+
+BUILD_DEPENDS= ldmd2:lang/ldc \
+ dub:devel/dub \
+ ${LOCALBASE}/lib/d/libdparse.a:devel/libdparse
+
+PLIST_FILES= bin/${PORTNAME}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${DISTVERSION:S/beta5/-beta.5/}
+DUB_CMD= ${LOCALBASE}/bin/dub build --build=release
+
+post-patch:
+ ${REINPLACE_CMD} -e "s|%%LOCALBASE%%|${LOCALBASE}|g" ${WRKSRC}/dub.json
+
+do-build:
+ @cd ${WRKSRC} && ${DUB_CMD}
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/${PORTNAME} ${STAGEDIR}${PREFIX}/bin/
+
+.include <bsd.port.mk>