aboutsummaryrefslogtreecommitdiff
path: root/devel/directfb
diff options
context:
space:
mode:
authorSam Lawrance <lawrance@FreeBSD.org>2006-01-30 23:59:11 +0000
committerSam Lawrance <lawrance@FreeBSD.org>2006-01-30 23:59:11 +0000
commit04c27222d2993b5a92895d2f3819767c2df86a44 (patch)
tree0278d68453a88f4444e42f62d20abb4f4a40060c /devel/directfb
parentc7aa5d4b627f0d5d350bb1fcd9aca44095e76e5c (diff)
downloadports-04c27222d2993b5a92895d2f3819767c2df86a44.tar.gz
ports-04c27222d2993b5a92895d2f3819767c2df86a44.zip
Unbreak. Replace hard-coded -lc_r with ${PTHREAD_LIBS}.
Notes
Notes: svn path=/head/; revision=154861
Diffstat (limited to 'devel/directfb')
-rw-r--r--devel/directfb/Makefile8
1 files changed, 1 insertions, 7 deletions
diff --git a/devel/directfb/Makefile b/devel/directfb/Makefile
index 3509826fee54..cb7f97f4685a 100644
--- a/devel/directfb/Makefile
+++ b/devel/directfb/Makefile
@@ -18,8 +18,6 @@ COMMENT= Graphic development lightweight API
LIB_DEPENDS= jpeg.9:${PORTSDIR}/graphics/jpeg \
png.5:${PORTSDIR}/graphics/png
-BROKEN= Hard-wires libc_r thread library
-
CONFIGURE_ENV= CPPFLAGS="${PTHREAD_CFLAGS}" \
LDFLAGS="${PTHREAD_LIBS}"
USE_SDL= sdl
@@ -27,7 +25,6 @@ USE_AUTOTOOLS= libtool:15
USE_GMAKE= yes
INSTALLS_SHLIB= yes
USE_PERL5= yes
-USE_REINPLACE= yes
PLIST_SUB+= DIRECTFB_VERSION=${PORTVERSION}
.if exists(${LOCALBASE}/lib/libfreetype.so.9)
@@ -52,12 +49,9 @@ MAN5= directfbrc.5
BROKEN= "Does not compile on alpha 5.x"
.endif
-.if ${ARCH} == "ia64"
-BROKEN= "Hard-codes references to libc_r"
-.endif
-
post-patch:
@${FIND} ${WRKSRC} -name Makefile.in | ${XARGS} ${REINPLACE_CMD} -e \
's|[(]libdir[)]/pkgconfig|(prefix)/libdata/pkgconfig|g'
+ ${REINPLACE_CMD} -e 's/-lc_r/${PTHREAD_LIBS}/g' ${WRKSRC}/configure
.include <bsd.port.post.mk>