aboutsummaryrefslogtreecommitdiff
path: root/devel/dispy
diff options
context:
space:
mode:
authorMikhail Teterin <mi@FreeBSD.org>2018-08-13 18:45:25 +0000
committerMikhail Teterin <mi@FreeBSD.org>2018-08-13 18:45:25 +0000
commit0dbb8a9c215f5b60500502dd236e9b23043e2de6 (patch)
tree9f527cb242dee850286cb21a1d39ff9f2bbe5c3c /devel/dispy
parent28882acb2e06cdc469316b20202859ed0e3f9858 (diff)
downloadports-0dbb8a9c215f5b60500502dd236e9b23043e2de6.tar.gz
ports-0dbb8a9c215f5b60500502dd236e9b23043e2de6.zip
Add port of Distributed Python (dispy) and the pycos, which it requires
Notes
Notes: svn path=/head/; revision=477104
Diffstat (limited to 'devel/dispy')
-rw-r--r--devel/dispy/Makefile20
-rw-r--r--devel/dispy/distinfo3
-rw-r--r--devel/dispy/pkg-descr13
3 files changed, 36 insertions, 0 deletions
diff --git a/devel/dispy/Makefile b/devel/dispy/Makefile
new file mode 100644
index 000000000000..ecb1c2bedab0
--- /dev/null
+++ b/devel/dispy/Makefile
@@ -0,0 +1,20 @@
+# Created by: Mikhail Teterin
+# $FreeBSD$
+
+PORTNAME= dispy
+PORTVERSION= 4.9.1
+CATEGORIES= devel net
+MASTER_SITES= SF
+MASTER_SITE_SUBDIR=${PORTNAME}
+
+MAINTAINER= mi@aldan.algebra.com
+COMMENT= Distributed and Parallel Computing with/for Python
+
+LICENSE= APACHE20
+LICENSE_FILE= ${WRKSRC}/LICENSE.txt
+
+USES= python
+USE_PYTHON= autoplist concurrent distutils
+NO_ARCH= yes
+
+.include <bsd.port.mk>
diff --git a/devel/dispy/distinfo b/devel/dispy/distinfo
new file mode 100644
index 000000000000..5ddf67f4a724
--- /dev/null
+++ b/devel/dispy/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1533922025
+SHA256 (dispy-4.9.1.tar.gz) = c52ee9cfff94803b11a2ac9bad7e73783b04abf6ffe839e09add6e71e281698e
+SIZE (dispy-4.9.1.tar.gz) = 282489
diff --git a/devel/dispy/pkg-descr b/devel/dispy/pkg-descr
new file mode 100644
index 000000000000..ea4e52e5db29
--- /dev/null
+++ b/devel/dispy/pkg-descr
@@ -0,0 +1,13 @@
+dispy is a comprehensive, yet easy to use framework for creating
+and using compute clusters to execute computations in parallel
+across multiple processors in a single machine (SMP), among many
+machines in a cluster, grid or cloud. dispy is well suited for data
+parallel (SIMD) paradigm where a computation (Python function or
+standalone program) is evaluated with different (large) datasets
+independently with no communication among computation tasks (except
+for computation tasks sending Provisional/Intermediate Results or
+Transferring Files to the client). If communication/cooperation
+among tasks is needed, Distributed Communicating Processes module
+of pycos framework could be used.
+
+WWW: http://dispy.sourceforge.net/