aboutsummaryrefslogtreecommitdiff
path: root/devel/djgpp-gcc
diff options
context:
space:
mode:
authorRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
committerRong-En Fan <rafan@FreeBSD.org>2007-07-23 09:36:51 +0000
commitf935a609c53c5c6031e6848db95c7debed127e27 (patch)
tree4c3cf6af6588247c0dd3f92f9601357c33c56217 /devel/djgpp-gcc
parent703b5eb18b542fec0e78704ada72142cd2b33175 (diff)
downloadports-f935a609c53c5c6031e6848db95c7debed127e27.tar.gz
ports-f935a609c53c5c6031e6848db95c7debed127e27.zip
- Set --mandir and --infodir in CONFIGURE_ARGS if the configure script
supports them. This is determined by running ``configure --help'' in do-configure target and set the shell variable _LATE_CONFIGURE_ARGS which is then passed to CONFIGURE_ARGS. - Remove --mandir and --infodir in ports' Makefile where applicable Few ports use REINPLACE_CMD to achieve the same effect, remove them too. - Correct some manual pages location from PREFIX/man to MANPREFIX/man - Define INFO_PATH where necessary - Document that .info files are installed in a subdirectory relative to PREFIX/INFO_PATH and slightly change add-plist-info to use INFO_PATH and subdirectory detection. PR: ports/111470 Approved by: portmgr Discussed with: stas (Mk/*), gerald (info related stuffs) Tested by: pointyhat exp run
Notes
Notes: svn path=/head/; revision=196111
Diffstat (limited to 'devel/djgpp-gcc')
-rw-r--r--devel/djgpp-gcc/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/djgpp-gcc/Makefile b/devel/djgpp-gcc/Makefile
index dbd0b9ba8e19..e58bc2b93211 100644
--- a/devel/djgpp-gcc/Makefile
+++ b/devel/djgpp-gcc/Makefile
@@ -56,7 +56,6 @@ CONFIGURE_ARGS= --target=${TARGET} \
--with-gcc --with-gnu-ld --with-gnu-as \
--disable-nls --disable-shared \
--with-gxx-include-dir=${PREFIX}/${TARGET}/include/c++/ \
- --infodir=${PREFIX}/${TARGET}/info \
--includedir=${PREFIX}/${TARGET}/include \
--datadir=${PREFIX}/${TARGET}/share
.if defined(WITH_FORTRAN)
@@ -64,6 +63,7 @@ CONFIGURE_ARGS+=--enable-languages=c,c++,fortran,objc,obj-c++
.else
CONFIGURE_ARGS+=--enable-languages=c,c++,objc,obj-c++
.endif
+INFO_PATH= ${TARGET}/info
MAKE_ENV= PATH=${PREFIX}/bin:${PATH}
LIBTOOLFILES= configure gcc/configure