aboutsummaryrefslogtreecommitdiff
path: root/devel/dotconf/Makefile
diff options
context:
space:
mode:
authorBaptiste Daroussin <bapt@FreeBSD.org>2013-12-10 23:06:45 +0000
committerBaptiste Daroussin <bapt@FreeBSD.org>2013-12-10 23:06:45 +0000
commit3138ce89c5e45ff490074afe280b870d1ed7dac3 (patch)
tree3fb99738a5d80847741054bd82dc3892d1d074f1 /devel/dotconf/Makefile
parent37782f7eada4ffce155d560242c33f56aad5c836 (diff)
downloadports-3138ce89c5e45ff490074afe280b870d1ed7dac3.tar.gz
ports-3138ce89c5e45ff490074afe280b870d1ed7dac3.zip
Support stage
Notes
Notes: svn path=/head/; revision=336128
Diffstat (limited to 'devel/dotconf/Makefile')
-rw-r--r--devel/dotconf/Makefile17
1 files changed, 7 insertions, 10 deletions
diff --git a/devel/dotconf/Makefile b/devel/dotconf/Makefile
index b8183d807386..4f12cdc4e72e 100644
--- a/devel/dotconf/Makefile
+++ b/devel/dotconf/Makefile
@@ -7,30 +7,27 @@ CATEGORIES= devel
MASTER_SITES= GENTOO/distfiles
MAINTAINER= ports@FreeBSD.org
-COMMENT= A simple, powerful configuration-file parser
+COMMENT= Simple, powerful configuration-file parser
LICENSE= LGPL21
+OPTIONS_DEFINE= DOCS EXAMPLES
+
USES= pathfix pkgconfig
USE_AUTOTOOLS= libtool
USE_LDCONFIG= yes
-NO_STAGE= yes
post-patch:
@${REINPLACE_CMD} -e \
'/^SUBDIR/s|=.*|= src|' ${WRKSRC}/Makefile.in
post-install:
-.if !defined(NOPORTDOCS)
- @${MKDIR} ${DOCSDIR}
- ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
-.endif
-.if !defined(NOPORTEXAMPLES)
- @${MKDIR} ${EXAMPLESDIR}
+ @${MKDIR} ${STAGEDIR}${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${STAGEDIR}${DOCSDIR}
+ @${MKDIR} ${STAGEDIR}${EXAMPLESDIR}
.for ex in README argdouble caseinsensitive context duplicates errorhandler \
fallback libpool maketest.sh modules noinline simple
- @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${ex} ${EXAMPLESDIR})
+ @(cd ${WRKSRC}/examples && ${COPYTREE_SHARE} ${ex} ${STAGEDIR}${EXAMPLESDIR})
.endfor
-.endif
.include <bsd.port.mk>