aboutsummaryrefslogtreecommitdiff
path: root/devel/dotconf/Makefile
diff options
context:
space:
mode:
authorKevin Lo <kevlo@FreeBSD.org>2001-09-05 16:02:09 +0000
committerKevin Lo <kevlo@FreeBSD.org>2001-09-05 16:02:09 +0000
commit48292acf617c5ff8ce2242c3b38fed3376b0ab26 (patch)
tree171a400c06938e6af851db3d16688d1ed70bc9ec /devel/dotconf/Makefile
parent3159e96380f44d3c3d08501a1fa6282317f57096 (diff)
downloadports-48292acf617c5ff8ce2242c3b38fed3376b0ab26.tar.gz
ports-48292acf617c5ff8ce2242c3b38fed3376b0ab26.zip
Update to version 1.0.6
PR: 30322 Submitted by: Ports Fury
Notes
Notes: svn path=/head/; revision=47459
Diffstat (limited to 'devel/dotconf/Makefile')
-rw-r--r--devel/dotconf/Makefile24
1 files changed, 17 insertions, 7 deletions
diff --git a/devel/dotconf/Makefile b/devel/dotconf/Makefile
index 9264be612d0a..47703a95bcf2 100644
--- a/devel/dotconf/Makefile
+++ b/devel/dotconf/Makefile
@@ -7,23 +7,33 @@
#
PORTNAME= dotconf
-PORTVERSION= 1.0.4
+PORTVERSION= 1.0.6
CATEGORIES= devel
MASTER_SITES= http://www.azzit.de/dotconf/download/
MAINTAINER= ports@FreeBSD.org
-USE_LIBTOOL= yes
USE_GMAKE= yes
+USE_LIBTOOL= yes
INSTALLS_SHLIB= yes
+EXAMPLESDIR= ${PREFIX}/share/examples/${PORTNAME}
+
+pre-patch:
+ @${PERL} -pi -e 's|-Wall -g||' ${WRKSRC}/configure
+ @${PERL} -pi -e 's|-release $(LT_RELEASE)||' ${WRKSRC}/src/Makefile.in
+
+pre-build:
+ @${LN} -sf ${LOCALBASE}/bin/libtool ${WRKSRC}/libtool
+
post-install:
- ${MKDIR} ${DATADIR}
.if !defined(NOPORTDOCS)
-.for f in dotconf-api.txt dotconf-features.txt
- @${INSTALL_DATA} ${WRKSRC}/doc/$f ${DATADIR}
-.endfor
+ @${MKDIR} ${DOCSDIR}
+ ${INSTALL_DATA} ${WRKSRC}/doc/*.txt ${DOCSDIR}
+ @${MKDIR} ${EXAMPLESDIR}
+ ${TAR} -C ${WRKSRC}/examples -cf - . | \
+ ${TAR} -C ${EXAMPLESDIR} --unlink -xf -
+ @${CHOWN} -R ${SHAREOWN}:${SHAREGRP} ${EXAMPLESDIR}
.endif
- ${CP} -R ${WRKSRC}/examples ${DATADIR}
.include <bsd.port.mk>