aboutsummaryrefslogtreecommitdiff
path: root/devel/doxygen
diff options
context:
space:
mode:
authorAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-16 04:24:10 +0000
committerAlexey Dokuchaev <danfe@FreeBSD.org>2022-05-16 04:24:10 +0000
commitb4da23e0057f353d9682433c8074186f5c8b1fa6 (patch)
tree65fbc6a9056ca292b817c65ab15e5b8e8c8c24d6 /devel/doxygen
parentcc058705d67cfc0461c56de8c5a5659fb07591e8 (diff)
downloadports-b4da23e0057f353d9682433c8074186f5c8b1fa6.tar.gz
ports-b4da23e0057f353d9682433c8074186f5c8b1fa6.zip
devel/doxygen: conditionalize MAKE_JOBS_UNSAFE per what comment says.
This allows to utilize all CPU cores when doing docless builds, which comes handy as C++ code typically takes considerable time to compile. Approved by: fluffy
Diffstat (limited to 'devel/doxygen')
-rw-r--r--devel/doxygen/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/doxygen/Makefile b/devel/doxygen/Makefile
index 731e4018d5b7..6d513ff9fa76 100644
--- a/devel/doxygen/Makefile
+++ b/devel/doxygen/Makefile
@@ -19,8 +19,6 @@ USES= bison cmake:noninja compiler:c++17-lang cpe dos2unix \
ALL_TARGET= all
CMAKE_ARGS+= -DDOC_INSTALL_DIR:PATH=${DOCSDIR_REL}
-# Parallel jobs breaks when the DOCS option is on
-MAKE_JOBS_UNSAFE= yes
EXTRACT_AFTER_ARGS= --exclude '*/libmd5'
@@ -41,6 +39,9 @@ DOCS_PLIST_FILES= man/man1/doxygen.1.gz \
man/man1/doxyindexer.1.gz \
man/man1/doxysearch.1.gz \
man/man1/doxywizard.1.gz
+# Parallel jobs break when the DOCS option is on
+DOCS_VARS= MAKE_JOBS_UNSAFE=yes
+
PORTDOCS= *
GRAPHVIZ_RUN_DEPENDS= dot:graphics/graphviz