aboutsummaryrefslogtreecommitdiff
path: root/devel/dupl/Makefile
diff options
context:
space:
mode:
authorYuri Victorovich <yuri@FreeBSD.org>2019-05-19 01:25:32 +0000
committerYuri Victorovich <yuri@FreeBSD.org>2019-05-19 01:25:32 +0000
commit7763bd7af0bef83d0589ce1ea013dcf7cb302f98 (patch)
treed6a11918207ed31724327ca59d9d1262acc406a1 /devel/dupl/Makefile
parent98d9c2ac5670d4075ff76aaec9d5b3cb554ac306 (diff)
downloadports-7763bd7af0bef83d0589ce1ea013dcf7cb302f98.tar.gz
ports-7763bd7af0bef83d0589ce1ea013dcf7cb302f98.zip
New port: devel/dupl: Tool for code clone detection
Notes
Notes: svn path=/head/; revision=502002
Diffstat (limited to 'devel/dupl/Makefile')
-rw-r--r--devel/dupl/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/dupl/Makefile b/devel/dupl/Makefile
new file mode 100644
index 000000000000..d7cac8eb259a
--- /dev/null
+++ b/devel/dupl/Makefile
@@ -0,0 +1,23 @@
+# $FreeBSD$
+
+PORTNAME= dupl
+DISTVERSIONPREFIX= v
+DISTVERSION= 1.0.0-11
+DISTVERSIONSUFFIX= -g28d787e
+CATEGORIES= devel
+
+MAINTAINER= yuri@FreeBSD.org
+COMMENT= Tool for code clone detection
+
+LICENSE= MIT
+LICENSE_FILE= ${WRKSRC}/LICENSE
+
+USES= go
+USE_GITHUB= yes
+GH_ACCOUNT= mibk
+
+GO_PKGNAME= github.com/${GH_ACCOUNT}/${PORTNAME}
+
+PLIST_FILES= bin/${PORTNAME}
+
+.include <bsd.port.mk>