aboutsummaryrefslogtreecommitdiff
path: root/devel/electron12/Makefile
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2021-09-18 17:23:51 +0000
committerJan Beich <jbeich@FreeBSD.org>2021-09-18 22:04:57 +0000
commit3e693f24a78f51cbb7daf258bd727961b3bec046 (patch)
tree0386cfbd2e3c6956d326a4142d8c50023ad90e26 /devel/electron12/Makefile
parentd65611acb322df914ab6bade00f10f03a5d3587f (diff)
downloadports-3e693f24a78f51cbb7daf258bd727961b3bec046.tar.gz
ports-3e693f24a78f51cbb7daf258bd727961b3bec046.zip
devel/electron12: unbreak after dbc5f433f858
../../third_party/skia/src/pdf/SkPDFSubsetFont.cpp:74:5: error: use of undeclared identifier 'hb_subset_input_set_retain_gids'; did you mean 'hb_subset_input_set_flags'? hb_subset_input_set_retain_gids(input.get(), true); ^~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~ hb_subset_input_set_flags /usr/local/include/harfbuzz/hb-subset.h:142:1: note: 'hb_subset_input_set_flags' declared here hb_subset_input_set_flags (hb_subset_input_t *input, ^ ../../third_party/skia/src/pdf/SkPDFSubsetFont.cpp:77:5: error: use of undeclared identifier 'hb_subset_input_set_drop_hints' hb_subset_input_set_drop_hints(input.get(), false); ^ ../../third_party/skia/src/pdf/SkPDFSubsetFont.cpp:78:19: error: use of undeclared identifier 'hb_subset'; did you mean 'hb_set_set'? HBFace subset(hb_subset(face.get(), input.get())); ^~~~~~~~~ hb_set_set /usr/local/include/harfbuzz/hb-set.h:131:1: note: 'hb_set_set' declared here hb_set_set (hb_set_t *set, ^ ../../third_party/skia/src/pdf/SkPDFSubsetFont.cpp:78:29: error: cannot initialize a parameter of type 'hb_set_t *' with an rvalue of type 'std::__1::unique_ptr<hb_face_t, SkFunctionWrapper<void (hb_face_t *), &hb_face_destroy>>::pointer' (aka 'hb_face_t *') HBFace subset(hb_subset(face.get(), input.get())); ^~~~~~~~~~ /usr/local/include/harfbuzz/hb-set.h:131:29: note: passing argument to parameter 'set' here hb_set_set (hb_set_t *set, ^ PR: 258576 Reported by: pkg-fallout Obtained from: Arch Linux
Diffstat (limited to 'devel/electron12/Makefile')
-rw-r--r--devel/electron12/Makefile2
1 files changed, 1 insertions, 1 deletions
diff --git a/devel/electron12/Makefile b/devel/electron12/Makefile
index c78a7e038e3c..68c14d7abd54 100644
--- a/devel/electron12/Makefile
+++ b/devel/electron12/Makefile
@@ -1,7 +1,7 @@
PORTNAME= electron
DISTVERSIONPREFIX= v
DISTVERSION= ${ELECTRON_VER:S/-beta./.b/}
-PORTREVISION= 1
+PORTREVISION= 2
CATEGORIES= devel java
MASTER_SITES= https://commondatastorage.googleapis.com/chromium-browser-official/:chromium \
https://commondatastorage.googleapis.com/chromium-fonts/:chromium_testfonts