aboutsummaryrefslogtreecommitdiff
path: root/devel/electron12/Makefile
diff options
context:
space:
mode:
authorTomoaki AOKI <junchoon@dec.sakura.ne.jp>2021-10-06 08:52:26 +0000
committerKoichiro Iwao <meta@FreeBSD.org>2021-10-06 12:11:29 +0000
commit9cdeb88eac13fab9aed2f3972cef30d229890bde (patch)
tree9618ba975aee8845c9caa8cfbd1dc7488146e7a6 /devel/electron12/Makefile
parent15d61162f70282cc075f10e81cbd54eedbd3369a (diff)
downloadports-9cdeb88eac13fab9aed2f3972cef30d229890bde.tar.gz
ports-9cdeb88eac13fab9aed2f3972cef30d229890bde.zip
devel/electron12: fix build
In file included from ../../third_party/nasm/asm/assemble.c:178: ../../third_party/nasm/include/compiler.h:249:21: error: static declaration of 'mempcpy' follows non-static declaration static inline void *mempcpy(void *dst, const void *src, size_t n) ^ /usr/include/string.h:70:7: note: previous declaration is here void *mempcpy(void * __restrict, const void * __restrict, size_t); ^ PR: 257378 Reported by: Robert Cina <transitive@gmail.com> Tested by: meta Approved by: maintainer timeout (> 2 weeks) MFH: 2021Q4
Diffstat (limited to 'devel/electron12/Makefile')
-rw-r--r--devel/electron12/Makefile6
1 files changed, 6 insertions, 0 deletions
diff --git a/devel/electron12/Makefile b/devel/electron12/Makefile
index 68c14d7abd54..05431df0af4f 100644
--- a/devel/electron12/Makefile
+++ b/devel/electron12/Makefile
@@ -152,6 +152,12 @@ GN_BOOTSTRAP_FLAGS= --no-clean --no-rebuild --skip-generate-buildfiles
.include "Makefile.version"
.include <bsd.port.pre.mk>
+# Add extra-patch-no-mempcpy-nasm only when there's no mempcpy() in base.
+# Nested variable expansion avoids executing the test when not needed for
+# expanding EXTRA_PATCHES.
+EXTRA_PATCHES+= ${"${:!${GREP} mempcpy ${CROSS_SYSROOT}/usr/include/string.h \
+ || ${TRUE}!}" == "":?${PATCHDIR}/extra-patch-no-mempcpy-nasm:}
+
.if ${ARCH} == "amd64"
PLIST_SUB+= AMD64=""
.else