aboutsummaryrefslogtreecommitdiff
path: root/devel/epydoc
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2012-06-07 18:19:23 +0000
committerRene Ladan <rene@FreeBSD.org>2012-06-07 18:19:23 +0000
commitae995ee226284d91d50e2ce187805d72080b8f16 (patch)
treea2ffa54720dca856a357467f597e76c40348d404 /devel/epydoc
parent9de183786dbf8c599cbb9d7c518734348e0ff809 (diff)
downloadports-ae995ee226284d91d50e2ce187805d72080b8f16.tar.gz
ports-ae995ee226284d91d50e2ce187805d72080b8f16.zip
- convert to optionsNG
- include bsd.port.mk instead of bsd.port.{pre|post}.mk
Notes
Notes: svn path=/head/; revision=298704
Diffstat (limited to 'devel/epydoc')
-rw-r--r--devel/epydoc/Makefile16
1 files changed, 10 insertions, 6 deletions
diff --git a/devel/epydoc/Makefile b/devel/epydoc/Makefile
index ecbcf0af01e2..d70b07d371fb 100644
--- a/devel/epydoc/Makefile
+++ b/devel/epydoc/Makefile
@@ -16,16 +16,20 @@ COMMENT= Python API documentation generation tool
LICENSE= MIT
-OPTIONS= UTF8 "Use UTF-8 instead of iso-8859-1 in HTMLs" off
+OPTIONS_DEFINE= UTF8
+
+UTF8_DESC= Use UTF-8 instead of iso-8859-1 in HTMLs
+
+OPTIONS_DEFAULT=
+
+.include <bsd.port.options.mk>
USE_PYTHON= yes
USE_PYDISTUTILS= yes
MAN1= epydoc.1 epydocgui.1
-.include <bsd.port.pre.mk>
-
-.if defined(WITH_UTF8)
+.if ${PORT_OPTIONS:MUTF8}
HTMLENCODING?= utf-8
.endif
@@ -37,9 +41,9 @@ post-patch:
post-install:
cd ${WRKSRC}/man && ${INSTALL_MAN} ${MAN1} ${MAN1PREFIX}/man/man1
-.if !defined(NOPORTDOCS)
+.if ${PORT_OPTIONS:MDOCS}
@${MKDIR} ${DOCSDIR}
@(cd ${WRKSRC}/doc && ${COPYTREE_SHARE} . ${DOCSDIR})
.endif
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>