aboutsummaryrefslogtreecommitdiff
path: root/devel/eric6
diff options
context:
space:
mode:
authorRene Ladan <rene@FreeBSD.org>2022-01-01 13:04:44 +0000
committerRene Ladan <rene@FreeBSD.org>2022-01-01 13:48:55 +0000
commite2b444d89aa72f2d914995363aece00012b470ed (patch)
tree440da3d84e1f45c7b8bfcf24fb4cabafab4c50a0 /devel/eric6
parent3ce791914c525c3027d24fa7ba6ed7c7b948e95d (diff)
downloadports-e2b444d89aa72f2d914995363aece00012b470ed.tar.gz
ports-e2b444d89aa72f2d914995363aece00012b470ed.zip
eric6: Revert removal.
This reverts commits * e6fa82f13214be6efb40b6cca698607fe15adfc0 * fb41f4077d321912b1e1c1c586cc90e9df5ce9d8 * 75b955057c8e0c7cf9f47d4070802312e8427d34 (eric6 part) Requested by: fluffy, tcberner
Diffstat (limited to 'devel/eric6')
-rw-r--r--devel/eric6/Makefile80
-rw-r--r--devel/eric6/Makefile.inc22
-rw-r--r--devel/eric6/bsd.eric6.mk22
-rw-r--r--devel/eric6/distinfo3
-rw-r--r--devel/eric6/files/config22
-rw-r--r--devel/eric6/files/eric6.desktop.in10
-rw-r--r--devel/eric6/pkg-descr11
-rw-r--r--devel/eric6/pkg-message10
-rw-r--r--devel/eric6/pkg-plist44
9 files changed, 224 insertions, 0 deletions
diff --git a/devel/eric6/Makefile b/devel/eric6/Makefile
new file mode 100644
index 000000000000..7f975775b5c1
--- /dev/null
+++ b/devel/eric6/Makefile
@@ -0,0 +1,80 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+
+.include "${.CURDIR}/../../devel/eric6/bsd.eric6.mk"
+
+PKGNAMESUFFIX= -qt5-${FLAVOR:U:S/_/-/}
+DISTNAME= ${PORTNAME}-nolang-${DISTVERSION}
+PORTREVISION= 0
+CATEGORIES= devel python
+
+DEPRECATED= Uses EOL Python 2.7 via www/py-qt5-webengine
+EXPIRATION_DATE=2021-12-31
+
+BUILD_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}pip>0:devel/py-pip@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv>=15.2:devel/py-virtualenv@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.14:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}editorconfig>=0.12.0:editors/py-editorconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}send2trash>=1.5:deskutils/py-send2trash@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asttokens>=1.1:devel/py-asttokens@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}markdown>=2.3.1:textproc/py-markdown@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}enchant>=0:textproc/py-enchant@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+RUN_DEPENDS+= ${PYTHON_PKGNAMEPREFIX}sqlite3>0:databases/py-sqlite3@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}toml>=0:textproc/py-toml@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}virtualenv>=15.2:devel/py-virtualenv@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}docutils>=0.14:textproc/py-docutils@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}editorconfig>=0.12.0:editors/py-editorconfig@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}send2trash>=1.5:deskutils/py-send2trash@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}asttokens>=1.1:devel/py-asttokens@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}markdown>=2.3.1:textproc/py-markdown@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}enchant>=0:textproc/py-enchant@${PY_FLAVOR} \
+ ${PYTHON_PKGNAMEPREFIX}yaml>0:devel/py-yaml@${PY_FLAVOR}
+
+CONFLICTS_INSTALL= ${FLAVORS:N${FLAVOR}:C/^/${PORTNAME}-qt5-/}
+
+USES+= desktop-file-utils python:3.5+ pyqt:5 shebangfix
+USE_PYTHON= flavors
+USE_PYQT= chart core gui qscintilla2 webengine \
+ help_run network_run svg_run sql_run
+INSTALL_PY= install.py -c -f eric6config.freebsd -i ${STAGEDIR}
+SHEBANG_FILES= *.py eric/eric6/*.py eric/scripts/*.py
+SUB_FILES= eric6.desktop
+MASTERPORT= yes
+
+PORTDATA= *
+PORTDOCS= *
+PORTEXAMPLES= *
+
+OPTIONS_DEFINE= DOCS EXAMPLES
+
+.include <bsd.port.options.mk>
+
+post-patch:
+ ${RM} ${WRKSRC}/eric/i18n/*.qm ${WRKSRC}/eric/i18n/*.ts
+
+do-configure:
+ ${SED} -e 's,PYTHON_SITELIBDIR,${PYTHON_SITELIBDIR},' \
+ -e 's,PREFIX,${PREFIX},' \
+ -e 's,DATADIR,${DATADIR},' \
+ -e 's,LOCALBASE,${LOCALBASE},' \
+ -e 's,DOCSDIR,${DOCSDIR},' \
+ -e 's,EXAMPLESDIR,${EXAMPLESDIR},' \
+ < ${FILESDIR}/config > ${WRKSRC}/eric6config.freebsd
+
+do-install:
+ @(cd ${WRKSRC}; \
+ ${SETENV} ${MAKE_ENV} ${PYTHON_CMD} ${INSTALL_PY})
+
+post-install:
+ ${INSTALL_DATA} ${WRKDIR}/eric6.desktop ${STAGEDIR}${PREFIX}/share/applications/
+ ${LN} -sf ${DATADIR:C|${PREFIX}(/share(/pixmaps)?)?||:C|/[^/]+|../|g}eric6/icons/default/eric.png \
+ ${STAGEDIR}${PREFIX}/share/pixmaps/eric6.png
+ @${MKDIR} ${STAGEDIR}${DATADIR}/i18n
+ ${REINPLACE_CMD} -e 's|${STAGEDIR}|${DATADIR}|g' \
+ -e 's|${WRKSRC}|${DATADIR}|g' \
+ ${STAGEDIR}/${DATADIR}/eric6install.json
+ @${RM} ${STAGEDIR}/${DATADIR}/eric6install.json.bak
+
+.include <bsd.port.mk>
diff --git a/devel/eric6/Makefile.inc b/devel/eric6/Makefile.inc
new file mode 100644
index 000000000000..3c6ab023316d
--- /dev/null
+++ b/devel/eric6/Makefile.inc
@@ -0,0 +1,22 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+#
+# This is a set of Makefile macros which allow to build the
+# localized language packages for devel/eric6:
+# german/eric6, russian/eric6, devel/es-eric6
+
+.include "${.CURDIR}/../../devel/eric6/bsd.eric6.mk"
+
+PKGNAMEPREFIX= ${I18N_LANG}-
+DISTNAME= ${PORTNAME}-i18n-${I18N_LANG}-${PORTVERSION}
+
+COMMENT= ${I18N_LANG} i18n package for Eric6 IDE
+
+NO_ARCH= yes
+NO_BUILD= yes
+PLIST_FILES= ${DATADIR}/i18n/${PORTNAME}_${I18N_LANG}.qm
+
+do-install:
+ ${MKDIR} ${STAGEDIR}${DATADIR}/i18n
+ ${INSTALL_DATA} ${WRKSRC}/eric/eric6/i18n/${PORTNAME}_${I18N_LANG}.qm ${STAGEDIR}${DATADIR}/i18n/
+
+.include <bsd.port.mk>
diff --git a/devel/eric6/bsd.eric6.mk b/devel/eric6/bsd.eric6.mk
new file mode 100644
index 000000000000..6f6afc6b8257
--- /dev/null
+++ b/devel/eric6/bsd.eric6.mk
@@ -0,0 +1,22 @@
+# Created by: Boris Samorodov <bsam@FreeBSD.org>
+#
+# This is a set of Makefile macros that are common between devel/eric6 and
+# localized language packages for devel/eric6:
+# german/eric6, russian/eric6, devel/es-eric6
+
+PORTNAME= eric6
+PORTVERSION= 21.11
+PORTREVISION?= 0
+MASTER_SITES= SF/eric-ide/${PORTNAME}/stable/${PORTVERSION}
+WRKSRC= ${WRKDIR}/${PORTNAME}-${PORTVERSION}
+
+MAINTAINER= fluffy@FreeBSD.org
+COMMENT= Full featured Python and Ruby editor and IDE based on Qt
+
+LICENSE= GPLv3
+
+DESCR= ${.CURDIR}/../../devel/eric6/pkg-descr
+MAKE_ENV+= "HOME=${WRKDIR}"
+
+NO_ARCH= yes
+NO_BUILD= yes
diff --git a/devel/eric6/distinfo b/devel/eric6/distinfo
new file mode 100644
index 000000000000..68d4504b0814
--- /dev/null
+++ b/devel/eric6/distinfo
@@ -0,0 +1,3 @@
+TIMESTAMP = 1636374251
+SHA256 (eric6-nolang-21.11.tar.gz) = 769e85fbf06650069e41b7587b13ae5c07c68ef49ea1cf9d38f19ea8655bb0e1
+SIZE (eric6-nolang-21.11.tar.gz) = 12945495
diff --git a/devel/eric6/files/config b/devel/eric6/files/config
new file mode 100644
index 000000000000..e93b28228f01
--- /dev/null
+++ b/devel/eric6/files/config
@@ -0,0 +1,22 @@
+# -*- coding: utf-8 -*-
+#
+# This module contains the configuration of the individual eric6 installation
+#
+
+cfg = {
+ 'ericDir' : 'DATADIR',
+ 'ericPixDir' : 'DATADIR/pixmaps',
+ 'ericIconDir' : 'DATADIR/icons',
+ 'ericDTDDir' : 'DATADIR/DTDs',
+ 'ericCSSDir' : 'DATADIR/CSSs',
+ 'ericStylesDir' : 'DATADIR/Styles',
+ 'ericDocDir' : 'DOCSDIR',
+ 'ericExamplesDir' : 'EXAMPLESDIR',
+ 'ericTranslationsDir' : 'DATADIR/i18n',
+ 'ericTemplatesDir' : 'DATADIR/DesignerTemplates',
+ 'ericCodeTemplatesDir' : 'DATADIR/CodeTemplates',
+ 'ericOthersDir' : 'DATADIR/Others',
+ 'bindir' : 'PREFIX/bin',
+ 'mdir' : 'PYTHON_SITELIBDIR',
+ 'apidir' : 'LOCALBASE/share/qt5/qsci/api',
+}
diff --git a/devel/eric6/files/eric6.desktop.in b/devel/eric6/files/eric6.desktop.in
new file mode 100644
index 000000000000..bdcfcabfaea2
--- /dev/null
+++ b/devel/eric6/files/eric6.desktop.in
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Name=Eric IDE
+GenericName=Python and Ruby IDE
+Comment=Full featured Python and Ruby editor and IDE based on Qt4
+Type=Application
+Exec=eric6
+Icon=eric6
+MimeType=application/x-python;application/x-eric;
+Categories=Development;TextEditor;Qt;Application;
+Terminal=false
diff --git a/devel/eric6/pkg-descr b/devel/eric6/pkg-descr
new file mode 100644
index 000000000000..f5830555dd10
--- /dev/null
+++ b/devel/eric6/pkg-descr
@@ -0,0 +1,11 @@
+Eric is a full featured Python and Ruby editor and IDE, written in python.
+
+It is based on the cross platform Qt gui toolkit, integrating the highly
+flexible Scintilla editor control. It is designed to be usable as everyday's
+quick and dirty editor as well as being usable as a professional project
+management tool integrating many advanced features Python offers
+the professional coder.
+
+This is a port of eric6 (based on Qt5).
+
+WWW: https://eric-ide.python-projects.org/index.html
diff --git a/devel/eric6/pkg-message b/devel/eric6/pkg-message
new file mode 100644
index 000000000000..9cf10be76e1d
--- /dev/null
+++ b/devel/eric6/pkg-message
@@ -0,0 +1,10 @@
+[
+{ type: install
+ message: <<EOM
+eric6 has the following localized language packages:
+ de-eric6
+ es-eric6
+ ru-eric6
+EOM
+}
+]
diff --git a/devel/eric6/pkg-plist b/devel/eric6/pkg-plist
new file mode 100644
index 000000000000..13b42758fe2e
--- /dev/null
+++ b/devel/eric6/pkg-plist
@@ -0,0 +1,44 @@
+bin/eric6
+bin/eric6_api
+bin/eric6_browser
+bin/eric6_compare
+bin/eric6_configure
+bin/eric6_diff
+bin/eric6_doc
+bin/eric6_editor
+bin/eric6_hexeditor
+bin/eric6_iconeditor
+bin/eric6_plugininstall
+bin/eric6_pluginrepository
+bin/eric6_pluginuninstall
+bin/eric6_qregularexpression
+bin/eric6_re
+bin/eric6_shell
+bin/eric6_snap
+bin/eric6_sqlbrowser
+bin/eric6_tray
+bin/eric6_trpreviewer
+bin/eric6_uipreviewer
+bin/eric6_unittest
+%%PYTHON_SITELIBDIR%%/eric6config.py
+%%PYTHON_SITELIBDIR%%/eric6plugins/__init__.py
+share/applications/eric6.desktop
+share/pixmaps/eric6.png
+share/qt5/qsci/api/python/eric6.api
+share/qt5/qsci/api/python/eric6.bas
+share/qt5/qsci/api/python/zope-2.10.7.api
+share/qt5/qsci/api/python/zope-2.11.2.api
+share/qt5/qsci/api/python/zope-3.3.1.api
+share/qt5/qsci/api/qss/qss.api
+share/qt5/qsci/api/ruby/Ruby-1.8.7.api
+share/qt5/qsci/api/ruby/Ruby-1.8.7.bas
+share/qt5/qsci/api/ruby/Ruby-1.9.1.api
+share/qt5/qsci/api/ruby/Ruby-1.9.1.bas
+share/qt5/qsci/api/python/calliope.api
+share/qt5/qsci/api/python/circuitpython.api
+share/qt5/qsci/api/python/microbit.api
+share/qt5/qsci/api/python/micropython.api
+share/qt5/qsci/api/python/micropython.bas
+@dir %%DATADIR%%/DTDs
+@dir %%DATADIR%%/i18n
+%%PORTEXAMPLES%%@dir %%EXAMPLESDIR%%