aboutsummaryrefslogtreecommitdiff
path: root/devel/fb-adb
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2016-10-04 19:49:56 +0000
committerJan Beich <jbeich@FreeBSD.org>2016-10-04 19:49:56 +0000
commit3768bf21d567f1c8f2e41c8e2901721a6716fc7f (patch)
treea0b37cb06c54ecb975a05b325c6e483e10ea5543 /devel/fb-adb
parent3e8c61e077325e82aa952733df4df2ed75a87bf5 (diff)
downloadports-3768bf21d567f1c8f2e41c8e2901721a6716fc7f.tar.gz
ports-3768bf21d567f1c8f2e41c8e2901721a6716fc7f.zip
devel/fb-adb: unbreak fetch for 64bit NDK
fetch: https://dl.google.com/android/ndk/android-ndk-r11c-linux-x86_64.zip: Not Found Note, :7z versus :zip sizes are $ du -Ah android-ndk-* 376M android-ndk-r10e-linux-x86.bin 1.0G android-ndk-r10e-linux-x86.zip 383M android-ndk-r10e-linux-x86_64.bin 1.0G android-ndk-r10e-linux-x86_64.zip 757M android-ndk-r11c-linux-x86_64.zip 721M android-ndk-r12b-linux-x86_64.zip
Notes
Notes: svn path=/head/; revision=423295
Diffstat (limited to 'devel/fb-adb')
-rw-r--r--devel/fb-adb/Makefile7
1 files changed, 4 insertions, 3 deletions
diff --git a/devel/fb-adb/Makefile b/devel/fb-adb/Makefile
index a61eeb27b586..1157c488038a 100644
--- a/devel/fb-adb/Makefile
+++ b/devel/fb-adb/Makefile
@@ -49,14 +49,15 @@ DEBUG_CONFIGURE_ENABLE= debuggable-stubs
# XXX Convert into USES=android once more things depend on it
NDK_DESC= Build target stubs using Android NDK
-NDK_MASTER_SITES= https://dl.google.com/android/ndk/:ndk,p7zip
+NDK_MASTER_SITES= https://dl.google.com/android/ndk/:7z \
+ https://dl.google.com/android/repository/:zip
.if defined(ANDROID_NDK)
# Prefer NDK from environment
WRKSRC_ndk= ${ANDROID_NDK}
.else
NDK_DISTFILES= ${NDK_DISTFILES_${LINUX_ARCH}}
-NDK_DISTFILES_i386= android-ndk-r10e-linux-x86.bin:ndk,p7zip
-NDK_DISTFILES_x86_64= android-ndk-r11c-linux-x86_64.zip:ndk
+NDK_DISTFILES_i386= android-ndk-r10e-linux-x86.bin:7z
+NDK_DISTFILES_x86_64= android-ndk-r11c-linux-x86_64.zip:zip
WRKSRC_ndk= ${WRKDIR}/${NDK_DISTFILES:R:C/(-[^-]+){2}$//}
.endif
NDK_USES= 7z:partial linux