aboutsummaryrefslogtreecommitdiff
path: root/devel/fbthrift
diff options
context:
space:
mode:
authorMichael Forney <mforney@mforney.org>2021-04-10 07:14:59 +0000
committerTobias Kortkamp <tobik@FreeBSD.org>2021-04-10 07:14:59 +0000
commitfd4b97fafcd55dee6346f8698c98cd7d8277a7f7 (patch)
tree0e9b6f48aa1fc8ba906ebfc02c1701f4e7b51c4d /devel/fbthrift
parent1d4cfc12c8fa8c58010c2468a2181bcc96302e36 (diff)
downloadports-fd4b97fafcd55dee6346f8698c98cd7d8277a7f7.tar.gz
ports-fd4b97fafcd55dee6346f8698c98cd7d8277a7f7.zip
devel/fbthrift: Add missing dependency on RocketUpgrade headers to thriftcpp2 target (D29353)
One source file in this target, async/HeaderClientChannel.cpp, depends on the generated header RocketUpgradeAsyncClient.h, so it needs to depend on the target that generates this header. This causes a build error with samurai due to an incorrect build order, and can be reproduced with ninja as well by building thrift/lib/cpp2/CMakeFiles/thriftcpp2.dir/async/HeaderClientChannel.cpp.o directly with an empty .ninja_deps. https://github.com/michaelforney/samurai/issues/70 PR: 254678
Diffstat (limited to 'devel/fbthrift')
-rw-r--r--devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt b/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt
new file mode 100644
index 000000000000..bd74a9c7f7ab
--- /dev/null
+++ b/devel/fbthrift/files/patch-thrift_lib_cpp2_CMakeLists.txt
@@ -0,0 +1,27 @@
+From 70a25a6f6d24fa8e9d8e7d4421a9e5cacf05a904 Mon Sep 17 00:00:00 2001
+From: Michael Forney <mforney@mforney.org>
+Date: Fri, 9 Apr 2021 18:19:10 -0700
+Subject: [PATCH] Add missing dependency on RocketUpgrade headers to thriftcpp2
+ target
+
+One source file in this target, async/HeaderClientChannel.cpp,
+depends on the generated header RocketUpgradeAsyncClient.h, so it
+needs to depend on the target that generates this header.
+
+This causes a build error with samurai due to an incorrect build
+order, and can be reproduced with ninja as well by building
+thrift/lib/cpp2/CMakeFiles/thriftcpp2.dir/async/HeaderClientChannel.cpp.o
+directly with an empty .ninja_deps.
+
+https://github.com/facebook/fbthrift/pull/422
+
+--- thrift/lib/cpp2/CMakeLists.txt.orig 2021-04-04 11:22:06 UTC
++++ thrift/lib/cpp2/CMakeLists.txt
+@@ -208,6 +208,7 @@ add_dependencies(
+ thriftcpp2
+ rpcmetadata
+ thriftmetadata
++ RocketUpgrade-cpp2-target
+ )
+ target_link_libraries(
+ thriftcpp2