aboutsummaryrefslogtreecommitdiff
path: root/devel/flex-sdk
diff options
context:
space:
mode:
authorDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-05 21:30:42 +0000
committerDmitry Marakasov <amdmi3@FreeBSD.org>2015-10-05 21:30:42 +0000
commit4b6fc4064479cb9a4461faec6402cc3b861242d5 (patch)
tree481f26ad7a5cd7f390a646082078b20b65bc799d /devel/flex-sdk
parentca8b6794ce040947aa574d63fd1133f3a183a3c9 (diff)
downloadports-4b6fc4064479cb9a4461faec6402cc3b861242d5.tar.gz
ports-4b6fc4064479cb9a4461faec6402cc3b861242d5.zip
- Don't install garbage files
- Add NO_ARCH - Add empty directories to plist PR: 203194 Submitted by: amdmi3 Approved by: maintainer timeout (kuriyama, 2 weeks)
Notes
Notes: svn path=/head/; revision=398668
Diffstat (limited to 'devel/flex-sdk')
-rw-r--r--devel/flex-sdk/Makefile8
-rw-r--r--devel/flex-sdk/pkg-plist16
2 files changed, 11 insertions, 13 deletions
diff --git a/devel/flex-sdk/Makefile b/devel/flex-sdk/Makefile
index 0279f5fbbe93..9c85ff57f538 100644
--- a/devel/flex-sdk/Makefile
+++ b/devel/flex-sdk/Makefile
@@ -11,23 +11,23 @@ COMMENT= Adobe Flex SDK
CONFLICTS= ja-flex-sdk-2.* flex-sdk2-2.* flex-sdk3-3.*
USES= zip
-USE_JAVA= YES
+USE_JAVA= yes
JAVA_VERSION= 1.6+
WRKSRC= ${WRKDIR}
SUB_FILES= ${SCRIPTS:C/\$/.sh/g}
NO_BUILD= YES
+NO_ARCH= yes
PLIST_SUB= PORTNAME=${PORTNAME}
SUB_LIST= PORTNAME=${PORTNAME}
SCRIPTS= aasdoc acompc amxmlc asdoc compc copylocale digest \
fcsh fdb mxmlc optimizer
-.include <bsd.port.pre.mk>
-
post-extract:
${RM} ${WRKSRC}/bin/*.bat ${WRKSRC}/bin/*.exe
${FIND} ${WRKSRC} -print0 -type f | ${XARGS} -0 ${CHMOD} og+r
${FIND} ${WRKSRC} -print0 -type f -perm +0111 | ${XARGS} -0 ${CHMOD} og+rx
${FIND} ${WRKSRC} -print0 -type d | ${XARGS} -0 ${CHMOD} og+rx
+ ${FIND} ${WRKSRC} -name "._*" -delete
do-install:
.for i in ${SCRIPTS}
@@ -47,4 +47,4 @@ do-install:
${MKDIR} ${STAGEDIR}${DOCSDIR}
${CP} -r ${WRKSRC}/*.htm ${STAGEDIR}${DOCSDIR}/
-.include <bsd.port.post.mk>
+.include <bsd.port.mk>
diff --git a/devel/flex-sdk/pkg-plist b/devel/flex-sdk/pkg-plist
index 8176c2d3bba8..68d17c793065 100644
--- a/devel/flex-sdk/pkg-plist
+++ b/devel/flex-sdk/pkg-plist
@@ -655,19 +655,10 @@ bin/optimizer
%%DATADIR%%/frameworks/projects/air/Core/src/air/net/ServiceMonitor.as
%%DATADIR%%/frameworks/projects/air/Core/src/air/net/SocketMonitor.as
%%DATADIR%%/frameworks/projects/air/Core/src/air/net/URLMonitor.as
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/._AndroidLicenseCheckerCallback.java
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/._AndroidLicensing.java
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/._AndroidLicensingExtension.java
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/._AndroidLicensingExtensionContext.java
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/AndroidLicenseCheckerCallback.java
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/AndroidLicensing.java
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/AndroidLicensingExtension.java
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingJavaProject/src/com/adobe/air/sampleextensions/android/licensing/AndroidLicensingExtensionContext.java
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/._extension.xml
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/._LicenseChecker.as
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/._LicenseStatus.as
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/._LicenseStatusEvent.as
-%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/._LicenseStatusReason.as
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/LicenseChecker.as
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/LicenseStatus.as
%%DATADIR%%/frameworks/projects/air/Licensing/Android/AndroidLicensingLib/src/com/adobe/air/sampleextensions/android/licensing/LicenseStatusEvent.as
@@ -4078,3 +4069,10 @@ bin/optimizer
%%DOCSDIR%%/license-adobesdk-fr.htm
%%DOCSDIR%%/license-mpl.htm
%%DOCSDIR%%/readme.htm
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/src/spark/transitions/supportClasses
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/zh_CN
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/ru_RU
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/ja_JP
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/fr_FR
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/en_US
+@dir %%DATADIR%%/frameworks/projects/mobilecomponents/bundles/de_DE