aboutsummaryrefslogtreecommitdiff
path: root/devel/fossil/Makefile
diff options
context:
space:
mode:
authorWen Heping <wen@FreeBSD.org>2010-06-28 02:22:18 +0000
committerWen Heping <wen@FreeBSD.org>2010-06-28 02:22:18 +0000
commit58817be4fb779002ee9fcc9073260a1f3844770c (patch)
treefc370fd73b6617427dbee805511c0b634c166473 /devel/fossil/Makefile
parent5c92a7b09a1b9cb51108ebfba4aed008911c8fcb (diff)
downloadports-58817be4fb779002ee9fcc9073260a1f3844770c.tar.gz
ports-58817be4fb779002ee9fcc9073260a1f3844770c.zip
Fossil is an easy-to-use Distributed Source Control Management system (DSCM)
which supports access and administration over HTTP CGI or via a built-in HTTP server, has a built-in wiki, built-in file browsing, a built-in tickets system, etc WWW: http://fossil-scm.org/ PR: ports/147867 Submitted by: Bapt <baptiste.daroussin@gmail.com> Feature safe: yes
Notes
Notes: svn path=/head/; revision=257089
Diffstat (limited to 'devel/fossil/Makefile')
-rw-r--r--devel/fossil/Makefile27
1 files changed, 27 insertions, 0 deletions
diff --git a/devel/fossil/Makefile b/devel/fossil/Makefile
new file mode 100644
index 000000000000..f0b2731c1049
--- /dev/null
+++ b/devel/fossil/Makefile
@@ -0,0 +1,27 @@
+# New ports collection makefile for: fossil
+# Date created: 2010-06-15
+# Whom: Bapt <baptiste.daroussin@gmail.com>
+#
+# $FreeBSD$
+#
+
+PORTNAME= fossil
+PORTVERSION= 20100611120259
+CATEGORIES= devel www
+MASTER_SITES= http://www.fossil-scm.org/download/
+DISTNAME= ${PORTNAME}-src-${PORTVERSION}
+
+MAINTAINER= baptiste.daroussin@gmail.com
+COMMENT= DSCM with built-in wiki, http interface and server, tickets database
+
+MAKE_JOBS_SAFE= yes
+
+PLIST_FILES= bin/fossil
+
+LICENSE= BSD
+LICENSE_FILE= ${WRKSRC}/COPYRIGHT-BSD2.txt
+
+do-install:
+ ${INSTALL_PROGRAM} ${WRKSRC}/fossil ${PREFIX}/bin/fossil
+
+.include <bsd.port.mk>