aboutsummaryrefslogtreecommitdiff
path: root/devel/fpc-newt/Makefile
diff options
context:
space:
mode:
authorJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:24:16 +0000
committerJose Alonso Cardenas Marquez <acm@FreeBSD.org>2010-08-16 18:24:16 +0000
commitf42f5be9f74fba7ac2f471e4d6e86bf2fbaf531d (patch)
treebfea8e066f40ce319f5e81f6cd4d40d9420bc497 /devel/fpc-newt/Makefile
parent204087889ae59ae3baece849f2db57d117307199 (diff)
downloadports-f42f5be9f74fba7ac2f471e4d6e86bf2fbaf531d.tar.gz
ports-f42f5be9f74fba7ac2f471e4d6e86bf2fbaf531d.zip
- New port: devel/fpc-newt
Free Pascal interface to newt library PR: 146001 Submitted by: Christopher Key <cjk32 _ at cam.ac.uk>
Notes
Notes: svn path=/head/; revision=259378
Diffstat (limited to 'devel/fpc-newt/Makefile')
-rw-r--r--devel/fpc-newt/Makefile23
1 files changed, 23 insertions, 0 deletions
diff --git a/devel/fpc-newt/Makefile b/devel/fpc-newt/Makefile
new file mode 100644
index 000000000000..e079701429cf
--- /dev/null
+++ b/devel/fpc-newt/Makefile
@@ -0,0 +1,23 @@
+# New ports collection makefile for: fpc-newt
+# Date created: 2010-04-22
+# Whom: Christopher Key <cjk32@cam.ac.uk>
+#
+# $FreeBSD$
+#
+
+PORTREVISION= 0
+CATEGORIES= devel lang
+PKGNAMESUFFIX= -newt
+
+MAINTAINER= acm@FreeBSD.org
+COMMENT= Free Pascal interface to newt library
+
+USE_FPC= yes
+
+MASTERDIR= ${.CURDIR}/../../lang/fpc
+WRKUNITDIR= ${FPCSRCDIR}/packages/${PKGNAMESUFFIX:S/-//}
+EXTRACTUNITDIR+= ${WRKUNITDIR}
+
+OPTIONS= NEWT "Install newt library" on
+
+.include "${MASTERDIR}/Makefile"