aboutsummaryrefslogtreecommitdiff
path: root/devel/gdb6
diff options
context:
space:
mode:
authorDavid E. O'Brien <obrien@FreeBSD.org>2004-10-27 18:37:40 +0000
committerDavid E. O'Brien <obrien@FreeBSD.org>2004-10-27 18:37:40 +0000
commiteb0476c2dd920cb9e45ed14201647e3ae12be92c (patch)
tree35ae90a39e36d9cf0ee5e91c9d93e277e83844ce /devel/gdb6
parentce795f59a778adc5b00d5dc93a551c32240fad65 (diff)
downloadports-eb0476c2dd920cb9e45ed14201647e3ae12be92c.tar.gz
ports-eb0476c2dd920cb9e45ed14201647e3ae12be92c.zip
Really allow building on 4.x. Rev 1.40 was a NOP as the base readline lib
(libreadline.so.4) was the same name as the ports's library. So Rev 1.40 only worked if you manually installed the readline port. This fix allows gdb6 to build with the base stock readline.
Notes
Notes: svn path=/head/; revision=120333
Diffstat (limited to 'devel/gdb6')
-rw-r--r--devel/gdb6/Makefile4
-rw-r--r--devel/gdb6/files/fbsd4.h15
2 files changed, 16 insertions, 3 deletions
diff --git a/devel/gdb6/Makefile b/devel/gdb6/Makefile
index c9e834ca5305..ffa14b8b6573 100644
--- a/devel/gdb6/Makefile
+++ b/devel/gdb6/Makefile
@@ -35,9 +35,7 @@ CFLAGS+= -DRL_NO_COMPAT -DKGDB
.include <bsd.port.pre.mk>
.if ${OSVERSION} < 500000
-USE_GCC?= 3.4
-LIB_DEPENDS= readline.4:${PORTSDIR}/devel/readline
-CFLAGS+= -Wl,--rpath -Wl,${PREFIX}/lib
+CFLAGS+= -include ${FILESDIR}/fbsd4.h
.endif
.if ${ARCH} == "amd64"
diff --git a/devel/gdb6/files/fbsd4.h b/devel/gdb6/files/fbsd4.h
new file mode 100644
index 000000000000..28afb1ba4ca1
--- /dev/null
+++ b/devel/gdb6/files/fbsd4.h
@@ -0,0 +1,15 @@
+// $FreeBSD$
+
+extern void _rl_set_screen_size (int, int);
+
+#define rl_set_screen_size _rl_set_screen_size
+#define rl_filename_completion_function filename_completion_function
+
+extern int screenwidth, screenheight;
+
+static inline void
+rl_get_screen_size (int *rows, int *cols)
+{
+ if (rows) *rows = screenheight;
+ if (cols) *cols = screenwidth;
+}