aboutsummaryrefslogtreecommitdiff
path: root/devel/geany-plugins
diff options
context:
space:
mode:
authorMax Brazhnikov <makc@FreeBSD.org>2015-08-31 08:57:38 +0000
committerMax Brazhnikov <makc@FreeBSD.org>2015-08-31 08:57:38 +0000
commit47f4599d9e5365b06efdefc463ca3e961c91a122 (patch)
treef5cb3cb488ad75ed913b630971a2895b8b6ee9f4 /devel/geany-plugins
parent5c99eefb87f511afa6a17131f604e6a4df73cab0 (diff)
downloadports-47f4599d9e5365b06efdefc463ca3e961c91a122.tar.gz
ports-47f4599d9e5365b06efdefc463ca3e961c91a122.zip
devel/geany:
- Update to 1.25 - Use install-strip target to strip binaries devel/geany-plugin*: - Update to 1.25. geany-plugin-gproject was renamed to geany-plugin-projectorganizer New plugins added: geany-plugin-automark geany-plugin-ctags geany-plugin-git-changebar geany-plugin-markdown geany-plugin-overview - Drop obsolete patches - Use install-strip target to strip binaries - Enable verbose build on package cluster
Notes
Notes: svn path=/head/; revision=395656
Diffstat (limited to 'devel/geany-plugins')
-rw-r--r--devel/geany-plugins/Makefile15
-rw-r--r--devel/geany-plugins/distinfo4
-rw-r--r--devel/geany-plugins/files/Makefile.common22
-rw-r--r--devel/geany-plugins/files/bsd.geany-plugins.mk25
-rw-r--r--devel/geany-plugins/files/extrapatch-configure72
5 files changed, 30 insertions, 108 deletions
diff --git a/devel/geany-plugins/Makefile b/devel/geany-plugins/Makefile
index b08604b7b83a..5d097c05056f 100644
--- a/devel/geany-plugins/Makefile
+++ b/devel/geany-plugins/Makefile
@@ -9,20 +9,15 @@ DISTFILES= # none
MAINTAINER= makc@FreeBSD.org
COMMENT= Geany plugins (meta port)
-NO_BUILD= yes
-NO_INSTALL= yes
-NO_MTREE= yes
+USES= metaport
-.include "${.CURDIR}/files/bsd.geany-plugins.mk"
-
-OPTIONS_DEFINE= NLS
-
-# NLS option first, then plugins sorted in GEANY_PLUGINS_ALL
+OPTIONS_DEFINE= NLS ${GEANY_PLUGINS_ALL:tu}
+OPTIONS_DEFAULT= ${GEANY_PLUGINS_ALL:tu}
NO_OPTIONS_SORT= yes
+.include "${.CURDIR}/files/bsd.geany-plugins.mk"
+
.for plugin in ${GEANY_PLUGINS_ALL}
-OPTIONS_DEFINE+= ${plugin:tu}
-OPTIONS_DEFAULT+= ${plugin:tu}
${plugin:tu}_DESC= ${${plugin}_DESC}
${plugin:tu}_RUN_DEPENDS= geany-plugin-${plugin}>=0:${PORTSDIR}/devel/geany-plugin-${plugin}
.endfor
diff --git a/devel/geany-plugins/distinfo b/devel/geany-plugins/distinfo
index 7ec3012d5775..f44bddc9d88f 100644
--- a/devel/geany-plugins/distinfo
+++ b/devel/geany-plugins/distinfo
@@ -1,2 +1,2 @@
-SHA256 (geany-plugins-1.24.tar.bz2) = dcc0414b29ae0160fc3a7adb0a1d6cbd5bd6bfb1900dab03e8774b3cebf6f2ec
-SIZE (geany-plugins-1.24.tar.bz2) = 3039764
+SHA256 (geany-plugins-1.25.tar.bz2) = 5c13ac1e173284462248ed2faae389a72364c5aa1538de628d2aaa7d286e244b
+SIZE (geany-plugins-1.25.tar.bz2) = 3230888
diff --git a/devel/geany-plugins/files/Makefile.common b/devel/geany-plugins/files/Makefile.common
index 70d89f007e79..c2b043d11028 100644
--- a/devel/geany-plugins/files/Makefile.common
+++ b/devel/geany-plugins/files/Makefile.common
@@ -9,8 +9,6 @@ DISTINFO_FILE= ${.CURDIR}/../../devel/geany-plugins/distinfo
BUILD_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany
RUN_DEPENDS+= ${LOCALBASE}/bin/geany:${PORTSDIR}/devel/geany
-EXTRA_PATCHES= ${.CURDIR}/../../devel/geany-plugins/files/extrapatch-configure
-
GNU_CONFIGURE= yes
USES+= gettext-tools gmake libtool pkgconfig tar:bzip2
USE_GNOME+= gtk20 intltool
@@ -21,6 +19,8 @@ GEANY_PLUGIN= po
po_SWITCH= --enable-nls
CPPFLAGS+= -I${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
+.else
+INSTALL_TARGET= install-strip
.endif
GEANY_PLUGIN?= ${PORTNAME:S,geany-plugin-,,}
@@ -29,26 +29,16 @@ ${GEANY_PLUGIN}_SWITCH?= --enable-${${GEANY_PLUGIN}_DIR}
CONFIGURE_ARGS+= ${${GEANY_PLUGIN}_SWITCH}
+.if defined(VERBOSE_BUILD) || defined(PACKAGE_BUILDING)
+CONFIGURE_ARGS+= --disable-silent-rules
+.endif
+
BUILD_WRKSRC= ${WRKSRC}/${${GEANY_PLUGIN}_DIR}
INSTALL_WRKSRC= ${BUILD_WRKSRC}
DATADIR= share/geany-plugins
DOCSDIR= share/doc/geany-plugins
-.include <bsd.port.options.mk>
-
-.if ${PORTNAME} != "geany-plugins-l10n"
-. if ${PORT_OPTIONS:MNLS}
-USES+= gettext-runtime
-. else
-CONFIGURE_ARGS+= --disable-nls
-. endif
-.endif
-
-pre-configure:
- ${REINPLACE_CMD} -e 's,zlib,,g' \
- ${WRKSRC}/configure
-
post-configure:
${FIND} ${BUILD_WRKSRC} -name Makefile | ${XARGS} \
${REINPLACE_CMD} -e '/^geanypluginsdir/s,${LOCALBASE},${PREFIX},'
diff --git a/devel/geany-plugins/files/bsd.geany-plugins.mk b/devel/geany-plugins/files/bsd.geany-plugins.mk
index a1d857581c70..18647a86265a 100644
--- a/devel/geany-plugins/files/bsd.geany-plugins.mk
+++ b/devel/geany-plugins/files/bsd.geany-plugins.mk
@@ -1,10 +1,12 @@
# $FreeBSD$
-GEANY_VER= 1.24
+GEANY_VER= 1.25
GEANY_PLUGINS_ALL= addons \
autoclose \
+ automark \
codenav \
commander \
+ ctags \
debugger \
defineformat \
devhelp \
@@ -13,19 +15,22 @@ GEANY_PLUGINS_ALL= addons \
geanypy \
gendoc \
geniuspaste \
- gproject \
+ git-changebar \
insertnum \
latex \
lipsum \
lua \
macro \
+ markdown \
miniscript \
multiterm \
numberedbookmarks \
+ overview \
pairtaghighlighter \
pg \
pohelper \
pretty-printer \
+ projectorganizer \
prj \
scope \
sendmail \
@@ -38,12 +43,12 @@ GEANY_PLUGINS_ALL= addons \
webhelper \
xmlsnippets
-# markdown plugin is excluded, requires peg-markdown
-
addons_DESC= various small addons
autoclose_DESC= brackets autocompletion
+automark_DESC= highlights all words that match selected word
codenav_DESC= some facilities for navigating in the code
commander_DESC= command panel for rapid access to any action
+ctags_DESC= generate and query ctags files
debugger_DESC= debugging support (via GDB currently)
defineformat_DESC= on-the-fly \#define formatter
devhelp_DESC= API documentation browser
@@ -52,20 +57,22 @@ geanypy_DESC= support for Python plugins
extrasel_DESC= additional selection tools
gendoc_DESC= generate documentation from the sources comments
geniuspaste_DESC= pastebins support
-gproject_DESC= extension of Geany's project management
-insertnum_DESC= replaces selection with integer numbers
+git-changebar_DESC= highlight changed files tracked with Git
+insertnum_DESC= replace selection with integer numbers
latex_DESC= LaTeX support
lipsum_DESC= Lorem Ipsum generator
lua_DESC= Lua scripting
macro_DESC= user defined macros
-# markdown_DESC= real-time preview of rendered Markdown
+markdown_DESC= real-time preview of rendered Markdown
miniscript_DESC= pipe text/documents via script (shell, perl, awk, etc.)
multiterm_DESC= multi-tabbed virtual terminals emulator
numberedbookmarks_DESC= additional numbered bookmarks
-pairtaghighlighter_DESC= highlights matching opening/closing HTML tags
+overview_DESC= zoomed-out view of open files
+pairtaghighlighter_DESC= highlight matching opening/closing HTML tags
pg_DESC= encrypt, decrypt and verify signatures with GnuPG
pohelper_DESC= support for gettext translation files
pretty-printer_DESC= formats XML and make it human-readable
+projectorganizer_DESC= extension of Geany's project management
prj_DESC= alternative project manager
scope_DESC= graphical GDB front-end
sendmail_DESC= send a document as attachment
@@ -79,6 +86,7 @@ webhelper_DESC= web development facilities
xmlsnippets_DESC= XML/HTML tag autocompletion
doc_DIR= geanydoc
+ctags_DIR= geanyctags
extrasel_DIR= geanyextrasel
gendoc_DIR= geanygendoc
insertnum_DIR= geanyinsertnum
@@ -93,4 +101,5 @@ prj_DIR= geanyprj
sendmail_DIR= geanysendmail
vc_DIR= geanyvc
+git-changebar_SWITCH= --enable-gitchangebar
pretty-printer_SWITCH= --enable-pretty_printer
diff --git a/devel/geany-plugins/files/extrapatch-configure b/devel/geany-plugins/files/extrapatch-configure
deleted file mode 100644
index 4877444b2289..000000000000
--- a/devel/geany-plugins/files/extrapatch-configure
+++ /dev/null
@@ -1,72 +0,0 @@
---- configure.orig 2014-04-13 17:12:39 UTC
-+++ configure
-@@ -23223,69 +23223,3 @@ fi
- expanded_docdir=$(eval echo $expanded_docdir)
-
-
-- cat <<GPEOF
--
--${PACKAGE}-${VERSION}
--
-- Build Environment:
-- Geany version: ${GEANY_VERSION} (GTK${GP_GTK_VERSION_MAJOR})
-- Install prefix: ${prefix}
-- Datadir: ${expanded_datadir}/${PACKAGE_TARNAME}
-- Libdir: ${expanded_libdir}/${PACKAGE_TARNAME}
-- Docdir: ${expanded_docdir}
-- Plugins path: ${geanypluginsdir}
--
-- Build Features:
--GPEOF
--
--
-- while read line; do
-- test -z "$line" && break;
-- plugin=" ${line%:*}:"
-- status=${line#*:}
-- let extracols=34-${#plugin}
-- echo -n "$plugin"
-- for (( i=0; $i<$extracols; i++ )); do
-- echo -n ' '
-- done
-- echo $status
-- done << GPEOF
--$build_feature_statusmsg
--GPEOF
--
-- echo
-- echo " Plugins:"
--
-- while read line; do
-- test -z "$line" && break;
-- plugin=" ${line%:*}:"
-- status=${line#*:}
-- let extracols=34-${#plugin}
-- echo -n "$plugin"
-- for (( i=0; $i<$extracols; i++ )); do
-- echo -n ' '
-- done
-- echo $status
-- done << GPEOF
--$plugins_statusmsg
--GPEOF
--
-- echo
-- echo " Features:"
--
-- while read line; do
-- test -z "$line" && break;
-- plugin=" ${line%:*}:"
-- status=${line#*:}
-- let extracols=34-${#plugin}
-- echo -n "$plugin"
-- for (( i=0; $i<$extracols; i++ )); do
-- echo -n ' '
-- done
-- echo $status
-- done << GPEOF
--$feature_statusmsg
--GPEOF
--
-- echo
--