aboutsummaryrefslogtreecommitdiff
path: root/devel/git-cinnabar
diff options
context:
space:
mode:
authorJan Beich <jbeich@FreeBSD.org>2020-03-23 11:18:12 +0000
committerJan Beich <jbeich@FreeBSD.org>2020-03-23 11:18:12 +0000
commit4271acd20bc0e1ecbc3b40330007bca45460c278 (patch)
tree1e36f207cee8a787876e02935641c5371822b01b /devel/git-cinnabar
parentb6a140bda2ec916d887438bf4786a9e062031a1d (diff)
downloadports-4271acd20bc0e1ecbc3b40330007bca45460c278.tar.gz
ports-4271acd20bc0e1ecbc3b40330007bca45460c278.zip
devel/git-cinnabar: rebuild and unbreak after r528780
|diff --git a/notes.c b/notes.c |index 75c028b300..24089afa8a 100644 |--- a/notes.c |+++ b/notes.c -------------------------- Patching file /wrkdirs/usr/ports/devel/git-cinnabar/work/git-cinnabar-0.5.4/git-core/notes.c using Plan A... Hunk #1 succeeded at 419 (offset 2 lines). Hunk #2 failed at 721. Hunk #3 succeeded at 752 (offset 3 lines). Hunk #4 succeeded at 1159 (offset 35 lines). Hunk #5 failed at 1177. Hunk #6 succeeded at 1159 (offset 4 lines). 2 out of 6 hunks failed--saving rejects to helper/notes.patched.c.rej done gmake[2]: *** [Makefile:157: ../helper/notes.patched.c] Error 1 Reported by: pkg-fallout
Notes
Notes: svn path=/head/; revision=528968
Diffstat (limited to 'devel/git-cinnabar')
-rw-r--r--devel/git-cinnabar/Makefile1
-rw-r--r--devel/git-cinnabar/files/patch-git-2.25.230
2 files changed, 31 insertions, 0 deletions
diff --git a/devel/git-cinnabar/Makefile b/devel/git-cinnabar/Makefile
index 8a458587522b..a81af0d484ac 100644
--- a/devel/git-cinnabar/Makefile
+++ b/devel/git-cinnabar/Makefile
@@ -2,6 +2,7 @@
PORTNAME= git-cinnabar
DISTVERSION= 0.5.4
+PORTREVISION= 1
CATEGORIES= devel
MAINTAINER= jbeich@FreeBSD.org
diff --git a/devel/git-cinnabar/files/patch-git-2.25.2 b/devel/git-cinnabar/files/patch-git-2.25.2
new file mode 100644
index 000000000000..cb1dd04c30d8
--- /dev/null
+++ b/devel/git-cinnabar/files/patch-git-2.25.2
@@ -0,0 +1,30 @@
+--- helper/notes.c.patch.orig 2020-02-05 23:41:37 UTC
++++ helper/notes.c.patch
+@@ -14,10 +14,10 @@ index 75c028b300..24089afa8a 100644
+ if (hex_to_bytes(object_oid.hash + prefix_len, entry.path,
+ hashsz - prefix_len))
+ goto handle_non_note; /* entry.path is not a SHA1 */
+-@@ -722,6 +719,7 @@ static int write_each_note_helper(struct tree_write_stack *tws,
+- struct write_each_note_data {
++@@ -720,6 +720,7 @@ struct write_each_note_data {
+ struct tree_write_stack *root;
+- struct non_note *next_non_note;
++ struct non_note **nn_list;
++ struct non_note *nn_prev;
+ + unsigned int note_mode;
+ };
+
+@@ -41,10 +41,10 @@ index 75c028b300..24089afa8a 100644
+ {
+ struct tree_write_stack root;
+ struct write_each_note_data cb_data;
+-@@ -1143,6 +1142,7 @@ int write_notes_tree(struct notes_tree *t, struct object_id *result)
+- root.path[0] = root.path[1] = '\0';
++@@ -1178,6 +1179,7 @@ int write_notes_tree_mode(struct notes_tree *t, struct
+ cb_data.root = &root;
+- cb_data.next_non_note = t->first_non_note;
++ cb_data.nn_list = &(t->first_non_note);
++ cb_data.nn_prev = NULL;
+ + cb_data.note_mode = mode;
+
+ /* Write tree objects representing current notes tree */