aboutsummaryrefslogtreecommitdiff
path: root/devel/git/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-07-11 13:03:59 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-07-11 13:03:59 +0000
commit06f67f420bba25526950a553cdac9d0506f17170 (patch)
tree001fddc1778c51ccb9a82eb25b0c49de416f4182 /devel/git/Makefile
parent1ed682112d620e73d86309d9410ad7d86fce1927 (diff)
downloadports-06f67f420bba25526950a553cdac9d0506f17170.tar.gz
ports-06f67f420bba25526950a553cdac9d0506f17170.zip
- Fix build with PCRE using --with-pcre1 configure option since git moved
default --with-pcre to use version 2 - Add a new OPTION PCRE2 to let it build with devel/pcre2 - Bump PORTREVISION PR: 229366 Submitted by: mat MFH: 2018Q3 Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=474443
Diffstat (limited to 'devel/git/Makefile')
-rw-r--r--devel/git/Makefile11
1 files changed, 9 insertions, 2 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 54f718337eb2..0e249e56c358 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
DISTVERSION= 2.18.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -50,8 +51,10 @@ TEST_TARGET= test
CONFIGURE_ARGS= --enable-pthreads=-pthread ac_cv_header_libcharset_h=no
+OPTIONS_RADIO= PCRE_VERSION
+OPTIONS_RADIO_PCRE_VERSION= PCRE PCRE2
OPTIONS_DEFINE= GUI SVN GITWEB CONTRIB P4 CVS HTMLDOCS PERL ICONV CURL \
- SEND_EMAIL NLS PCRE SUBTREE
+ SEND_EMAIL NLS SUBTREE
OPTIONS_DEFAULT= CONTRIB P4 CVS PERL GITWEB ICONV CURL SEND_EMAIL PCRE \
SUBTREE
OPTIONS_SUB= yes
@@ -59,6 +62,7 @@ OPTIONS_SUB= yes
GITWEB_DESC= Install gitweb
CONTRIB_DESC= Install contributed scripts
P4_DESC= Enable Perforce support
+PCRE2_DESC= Use Perl Compatible Regular Expressions (v2)
CVS_DESC= Enable CVS support
HTMLDOCS_DESC= Install additional documentation
SEND_EMAIL_DESC=Enable the git-send-email(1) script
@@ -77,7 +81,10 @@ GITWEB_IMPLIES= PERL
GITWEB_RUN_DEPENDS= p5-CGI>=0:www/p5-CGI
PCRE_LIB_DEPENDS= libpcre.so:devel/pcre
-PCRE_CONFIGURE_WITH= libpcre
+PCRE_CONFIGURE_WITH= libpcre1
+
+PCRE2_LIB_DEPENDS= libpcre2-8.so:devel/pcre2
+PCRE2_CONFIGURE_WITH= libpcre
SEND_EMAIL_IMPLIES= PERL
SEND_EMAIL_RUN_DEPENDS= p5-Authen-SASL>=0:security/p5-Authen-SASL