aboutsummaryrefslogtreecommitdiff
path: root/devel/git/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-04-03 12:51:28 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-04-03 12:51:28 +0000
commit214f379539e085e9dad7bc5ca2dd1c3eaeee15b2 (patch)
treebdd09643773d4385bc90aea3e21aa08f6b5f4d8d /devel/git/Makefile
parent36ef9ab669049f8e181762430099a7ed8c2661db (diff)
downloadports-214f379539e085e9dad7bc5ca2dd1c3eaeee15b2.tar.gz
ports-214f379539e085e9dad7bc5ca2dd1c3eaeee15b2.zip
Update devel/git to 2.17.0
Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=466347
Diffstat (limited to 'devel/git/Makefile')
-rw-r--r--devel/git/Makefile6
1 files changed, 3 insertions, 3 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 2b38cb3fec8f..1908665ab3d0 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -2,7 +2,7 @@
# $FreeBSD$
PORTNAME= git
-DISTVERSION= 2.16.3
+DISTVERSION= 2.17.0
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -25,7 +25,7 @@ GROUPS= git_daemon
SUB_FILES= pkg-message
GNU_CONFIGURE= yes
-USES= autoreconf gmake shebangfix ssl tar:xz
+USES= autoreconf gmake iconv shebangfix ssl tar:xz
CPPFLAGS+= -isystem${LOCALBASE}/include
LDFLAGS+= -L${LOCALBASE}/lib
MAKE_ARGS+= DEVELOPER_CFLAGS=
@@ -154,7 +154,7 @@ post-patch:
.for FILE in ${RMMAN7}
@${RM} ${WRKDIR}/man7/${FILE}
.endfor
- @${REINPLACE_CMD} -e 's|share/man/man3|man/man3|' ${WRKSRC}/perl/Makefile.PL
+ @${REINPLACE_CMD} -e "s,%%SITE_PERL%%,${SITE_PERL},g" ${WRKSRC}/Makefile
post-patch-CONTRIB-on:
@${REINPLACE_CMD} -e "s,/usr/bin/perl,${PERL}," \