aboutsummaryrefslogtreecommitdiff
path: root/devel/git/Makefile
diff options
context:
space:
mode:
authorRenato Botelho <garga@FreeBSD.org>2018-09-28 12:48:37 +0000
committerRenato Botelho <garga@FreeBSD.org>2018-09-28 12:48:37 +0000
commitfd388b4082d4ca89f3ba4a7333fd45e296c2b8e7 (patch)
tree25488dcac24bd5a74e40f473bd0f2fa34242e6db /devel/git/Makefile
parent26164efa00e0b331df63862e949b789de0881dd5 (diff)
downloadports-fd388b4082d4ca89f3ba4a7333fd45e296c2b8e7.tar.gz
ports-fd388b4082d4ca89f3ba4a7333fd45e296c2b8e7.zip
devel/git: Keep original bash completion filename
Do not rename git-completion.bash to git.sh to make it easier for users that follow git docs, which point to original filename. Add a note in pkg-message to let users know about it. PR: 231775 Submitted by: pierogmorski@gmail.com Sponsored by: Rubicon Communications, LLC (Netgate)
Notes
Notes: svn path=/head/; revision=480858
Diffstat (limited to 'devel/git/Makefile')
-rw-r--r--devel/git/Makefile5
1 files changed, 3 insertions, 2 deletions
diff --git a/devel/git/Makefile b/devel/git/Makefile
index 13b34346b3f0..3f901006a49c 100644
--- a/devel/git/Makefile
+++ b/devel/git/Makefile
@@ -3,6 +3,7 @@
PORTNAME= git
DISTVERSION= 2.19.0
+PORTREVISION= 1
CATEGORIES= devel
MASTER_SITES= KERNEL_ORG/software/scm/git
DISTFILES= ${DISTNAME}${EXTRACT_SUFX} \
@@ -229,13 +230,13 @@ post-install-CONTRIB-on:
# will be useful
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
@${LN} -s ../../share/git-core/contrib/completion/git-completion.bash \
- ${STAGEDIR}${PREFIX}/etc/bash_completion.d/git.sh
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/
post-install-CONTRIB-off:
# Install the contrib completions anyway
@${MKDIR} ${STAGEDIR}${PREFIX}/etc/bash_completion.d
${INSTALL_SCRIPT} ${WRKSRC}/contrib/completion/git-completion.bash \
- ${STAGEDIR}${PREFIX}/etc/bash_completion.d/git.sh
+ ${STAGEDIR}${PREFIX}/etc/bash_completion.d/
post-install-P4-on:
${INSTALL_SCRIPT} ${WRKSRC}/git-p4.py ${STAGEDIR}${PREFIX}/bin/