aboutsummaryrefslogtreecommitdiff
path: root/devel/gitg
diff options
context:
space:
mode:
authorRuslan Makhmatkhanov <rm@FreeBSD.org>2016-03-20 18:12:22 +0000
committerRuslan Makhmatkhanov <rm@FreeBSD.org>2016-03-20 18:12:22 +0000
commitb9f14c0b556abbf0e36cb71456c79ff77b5c659c (patch)
tree0821741578a6f77d2502fd20a12f633e929bc1aa /devel/gitg
parentfe2eda2f9a45901a37da61543d77209023b55351 (diff)
downloadports-b9f14c0b556abbf0e36cb71456c79ff77b5c659c.tar.gz
ports-b9f14c0b556abbf0e36cb71456c79ff77b5c659c.zip
devel/gitg: fix build
- add missing dependency upon security/libsecret - add upstream patch to fix build with libgit2 0.24.x
Notes
Notes: svn path=/head/; revision=411470
Diffstat (limited to 'devel/gitg')
-rw-r--r--devel/gitg/Makefile3
-rw-r--r--devel/gitg/files/patch-libgitg_gitg-remote.vala14
2 files changed, 16 insertions, 1 deletions
diff --git a/devel/gitg/Makefile b/devel/gitg/Makefile
index c84322abbe91..ba9bc3704d74 100644
--- a/devel/gitg/Makefile
+++ b/devel/gitg/Makefile
@@ -16,7 +16,8 @@ LIB_DEPENDS= libsoup-2.4.so:${PORTSDIR}/devel/libsoup \
libgee-0.8.so:${PORTSDIR}/devel/libgee \
libgit2-glib-1.0.so:${PORTSDIR}/devel/libgit2-glib \
libpeas-1.0.so:${PORTSDIR}/devel/libpeas \
- libgtkspell3-3.so:${PORTSDIR}/textproc/gtkspell3
+ libgtkspell3-3.so:${PORTSDIR}/textproc/gtkspell3 \
+ libsecret-1.so:${PORTSDIR}/security/libsecret
BUILD_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas \
valac:${PORTSDIR}/lang/vala
RUN_DEPENDS= gsettings-desktop-schemas>=0:${PORTSDIR}/devel/gsettings-desktop-schemas
diff --git a/devel/gitg/files/patch-libgitg_gitg-remote.vala b/devel/gitg/files/patch-libgitg_gitg-remote.vala
new file mode 100644
index 000000000000..18d37ceeac7e
--- /dev/null
+++ b/devel/gitg/files/patch-libgitg_gitg-remote.vala
@@ -0,0 +1,14 @@
+Upstream fix for building against libgit2 0.24.
+Should be removed after updating to gitg 3.20.0
+
+--- libgitg/gitg-remote.vala.orig 2015-12-15 14:12:13 UTC
++++ libgitg/gitg-remote.vala
+@@ -247,7 +247,7 @@ public class Remote : Ggit.Remote
+ try
+ {
+ yield Async.thread(() => {
+- base.connect(direction, new Callbacks(this, callbacks, null));
++ base.connect(direction, new Callbacks(this, callbacks, null), null);
+ });
+ }
+ catch (Error e)