aboutsummaryrefslogtreecommitdiff
path: root/devel/gitlab-runner
diff options
context:
space:
mode:
authorFelix Palmen <zirias@FreeBSD.org>2023-07-12 12:13:03 +0000
committerFelix Palmen <zirias@FreeBSD.org>2023-07-12 18:56:04 +0000
commit7d1faa7179813ffa542b550a1fdb3bdc80a7986c (patch)
treebca2e70f4a6137f858d0ca5792e376602af7bab7 /devel/gitlab-runner
parent16bde072b16daca1c886116e602c94b5fa99c20f (diff)
downloadports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.tar.gz
ports-7d1faa7179813ffa542b550a1fdb3bdc80a7986c.zip
bsd.sites.mk: Update all ports using USE_GITLAB
Replace GL_COMMIT by GL_TAGNAME in all ports. The new GL_TAGNAME is backwards-compatible (accepting any commit hash as before), but also understands an actual tag name. Moving to tag names where appropriate is left to individual ports' maintainers. Approved by: portmgr (tcberner, mentor) Differential Revision: https://reviews.freebsd.org/D37077
Diffstat (limited to 'devel/gitlab-runner')
-rw-r--r--devel/gitlab-runner/Makefile4
1 files changed, 2 insertions, 2 deletions
diff --git a/devel/gitlab-runner/Makefile b/devel/gitlab-runner/Makefile
index 89e22d44baae..e551d4f40f1a 100644
--- a/devel/gitlab-runner/Makefile
+++ b/devel/gitlab-runner/Makefile
@@ -26,7 +26,7 @@ _BUILD_DATE= $$(date -u +%Y-%m-%dT%H:%M:%S%z)
GO_BUILDFLAGS= -ldflags=" \
-X gitlab.com/gitlab-org/gitlab-runner/commands.ROOTCONFIGDIR=${ETCDIR} \
-X gitlab.com/gitlab-org/gitlab-runner/common.VERSION=${PORTVERSION} \
- -X gitlab.com/gitlab-org/gitlab-runner/common.REVISION=${GL_COMMIT:C/^(........).*/\1/} \
+ -X gitlab.com/gitlab-org/gitlab-runner/common.REVISION=${GL_TAGNAME:C/^(........).*/\1/} \
-X gitlab.com/gitlab-org/gitlab-runner/common.BUILT=${_BUILD_DATE} \
-X gitlab.com/gitlab-org/gitlab-runner/common.BRANCH=${GITBRANCH} \
-s -w"
@@ -34,7 +34,7 @@ USE_GITLAB= yes
GL_ACCOUNT= gitlab-org
# Find tags here:
# https://gitlab.com/gitlab-org/gitlab-runner/-/tags
-GL_COMMIT= 79704081c9fe038e6054066d7d7462c712d7345e
+GL_TAGNAME= 79704081c9fe038e6054066d7d7462c712d7345e
GITBRANCH= 16-0-stable
# for go dependencies