aboutsummaryrefslogtreecommitdiff
path: root/devel/glog
diff options
context:
space:
mode:
authorCheng-Lung Sung <clsung@FreeBSD.org>2009-02-05 07:15:39 +0000
committerCheng-Lung Sung <clsung@FreeBSD.org>2009-02-05 07:15:39 +0000
commit234f71359c5eb83b79ead7fcb8ba33d45cc65438 (patch)
tree842ab2afb85666c0f636f096f3a7758f9ae19ef3 /devel/glog
parentb7f194464498e3c56a81384ce0bc74d9a4da23aa (diff)
downloadports-234f71359c5eb83b79ead7fcb8ba33d45cc65438.tar.gz
ports-234f71359c5eb83b79ead7fcb8ba33d45cc65438.zip
- Update to 0.2
Notes
Notes: svn path=/head/; revision=227643
Diffstat (limited to 'devel/glog')
-rw-r--r--devel/glog/Makefile13
-rw-r--r--devel/glog/distinfo6
-rw-r--r--devel/glog/files/extra-patch-src-raw_logging.cc11
-rw-r--r--devel/glog/files/extra-patch-src-utilities.cc20
-rw-r--r--devel/glog/files/extra-patch-src-utilities.h11
-rw-r--r--devel/glog/pkg-plist1
6 files changed, 46 insertions, 16 deletions
diff --git a/devel/glog/Makefile b/devel/glog/Makefile
index 95cef3174b82..de4bcc365207 100644
--- a/devel/glog/Makefile
+++ b/devel/glog/Makefile
@@ -6,21 +6,30 @@
#
PORTNAME= glog
-DISTVERSION= 0.1.1
+DISTVERSION= 0.2
CATEGORIES= devel
MASTER_SITES= http://google-glog.googlecode.com/files/
MAINTAINER= clsung@FreeBSD.org
COMMENT= A library of C++ classes for flexible logging
+LIB_DEPENDS+= execinfo.1:${PORTSDIR}/devel/libexecinfo
+
GNU_CONFIGURE= yes
USE_LDCONFIG= yes
+USE_GCC= 4.2+
+
+CONFIGURE_ENV+= LDFLAGS="${LDFLAGS} -L${LOCALBASE}/lib -lexecinfo"
.include <bsd.port.pre.mk>
.if ${ARCH} == "amd64" || ${ARCH} =="ia64" || ${ARCH} =="sparc64"
EXTRA_PATCHES= ${FILESDIR}/extra-patch-src-logging.cc \
- ${FILESDIR}/extra-patch-src-raw_logging.cc
+ ${FILESDIR}/extra-patch-src-utilities.cc
+.endif
+
+.if ${ARCH} == "amd64"
+EXTRA_PATCHES+= ${FILESDIR}/extra-patch-src-utilities.h
.endif
post-patch:
diff --git a/devel/glog/distinfo b/devel/glog/distinfo
index 83e8353751bc..7fa1a0376519 100644
--- a/devel/glog/distinfo
+++ b/devel/glog/distinfo
@@ -1,3 +1,3 @@
-MD5 (glog-0.1.1.tar.gz) = 19c001eaf7a261cfeb34aa6b8da118aa
-SHA256 (glog-0.1.1.tar.gz) = 589933e86b3815577c5abb546db8624638e3bf1742dec20a73b15d769b4d1088
-SIZE (glog-0.1.1.tar.gz) = 436766
+MD5 (glog-0.2.tar.gz) = c0fe88ea51ba4e2328580cffc4856ca5
+SHA256 (glog-0.2.tar.gz) = d3a71c5a057a95ed1432bf52c00fb8b9b6c4ff7980f1f27f9a7e6a4537bb7df3
+SIZE (glog-0.2.tar.gz) = 478999
diff --git a/devel/glog/files/extra-patch-src-raw_logging.cc b/devel/glog/files/extra-patch-src-raw_logging.cc
deleted file mode 100644
index ff0b467b4e82..000000000000
--- a/devel/glog/files/extra-patch-src-raw_logging.cc
+++ /dev/null
@@ -1,11 +0,0 @@
---- src/raw_logging.cc.orig 2008-10-03 13:32:50.000000000 +0800
-+++ src/raw_logging.cc 2008-10-14 13:34:22.000000000 +0800
-@@ -87,7 +87,7 @@
- DoRawLog(&buf, &size, "%c%02d%02d %02d%02d%02d %08x %s:%d] RAW: ",
- LogSeverityNames[severity][0],
- 1 + t.tm_mon, t.tm_mday, t.tm_hour, t.tm_min, t.tm_sec,
-- int(pthread_self()),
-+ long(pthread_self()),
- basename(const_cast<char *>(file)), line);
- }
- va_list ap;
diff --git a/devel/glog/files/extra-patch-src-utilities.cc b/devel/glog/files/extra-patch-src-utilities.cc
new file mode 100644
index 000000000000..3d9ad6c8977d
--- /dev/null
+++ b/devel/glog/files/extra-patch-src-utilities.cc
@@ -0,0 +1,20 @@
+--- src/utilities.cc.orig 2009-01-23 09:37:14.000000000 +0800
++++ src/utilities.cc 2009-02-04 11:25:50.000000000 +0800
+@@ -187,8 +187,6 @@
+ #ifndef __NR_gettid
+ #ifdef OS_MACOSX
+ #define __NR_gettid SYS_gettid
+-#elif ! defined __i386__
+-#error "Must define __NR_gettid for non-x86 platforms"
+ #else
+ #define __NR_gettid 224
+ #endif
+@@ -214,7 +212,7 @@
+ return GetCurrentThreadId();
+ #else
+ // If none of the techniques above worked, we use pthread_self().
+- return (pid_t)pthread_self();
++ return reinterpret_cast<unsigned long>(pthread_self());
+ #endif
+ }
+
diff --git a/devel/glog/files/extra-patch-src-utilities.h b/devel/glog/files/extra-patch-src-utilities.h
new file mode 100644
index 000000000000..0de83895d71e
--- /dev/null
+++ b/devel/glog/files/extra-patch-src-utilities.h
@@ -0,0 +1,11 @@
+--- src/utilities.h.orig 2009-01-22 06:17:01.000000000 +0800
++++ src/utilities.h 2009-02-05 08:07:44.000000000 +0800
+@@ -72,7 +72,7 @@
+ #if defined(HAVE_LIB_UNWIND)
+ # define STACKTRACE_H "stacktrace_libunwind-inl.h"
+ #elif !defined(NO_FRAME_POINTER)
+-# if defined(__i386__) && __GNUC__ >= 2
++# if (defined(__i386__) || defined(__amd64__)) && __GNUC__ >= 2
+ # define STACKTRACE_H "stacktrace_x86-inl.h"
+ # elif defined(__x86_64__) && __GNUC__ >= 2
+ # define STACKTRACE_H "stacktrace_x86_64-inl.h"
diff --git a/devel/glog/pkg-plist b/devel/glog/pkg-plist
index 9dbf4d0011a3..4fd27f8bf342 100644
--- a/devel/glog/pkg-plist
+++ b/devel/glog/pkg-plist
@@ -13,6 +13,7 @@ lib/libglog.a
%%PORTDOCS%%%%DOCSDIR%%/INSTALL
%%PORTDOCS%%%%DOCSDIR%%/NEWS
%%PORTDOCS%%%%DOCSDIR%%/README
+%%PORTDOCS%%%%DOCSDIR%%/README.windows
%%PORTDOCS%%%%DOCSDIR%%/designstyle.css
%%PORTDOCS%%%%DOCSDIR%%/glog.html
%%PORTDOCS%%@dirrm %%DOCSDIR%%