aboutsummaryrefslogtreecommitdiff
path: root/devel/gnome-vfs/Makefile
diff options
context:
space:
mode:
authorAde Lovett <ade@FreeBSD.org>2000-06-29 19:28:06 +0000
committerAde Lovett <ade@FreeBSD.org>2000-06-29 19:28:06 +0000
commit53d3581af0d93aec3ce6dc5512e6b41df3ee7dc1 (patch)
tree02020e9052d516edecc60e77d121b19f8b2b0dfc /devel/gnome-vfs/Makefile
parent9ea482340be54a13e8a585a3d907c69917c81ea7 (diff)
downloadports-53d3581af0d93aec3ce6dc5512e6b41df3ee7dc1.tar.gz
ports-53d3581af0d93aec3ce6dc5512e6b41df3ee7dc1.zip
gnomevfs is the embryonic GNOME Virtual File System,
Notes
Notes: svn path=/head/; revision=29993
Diffstat (limited to 'devel/gnome-vfs/Makefile')
-rw-r--r--devel/gnome-vfs/Makefile34
1 files changed, 34 insertions, 0 deletions
diff --git a/devel/gnome-vfs/Makefile b/devel/gnome-vfs/Makefile
new file mode 100644
index 000000000000..84a44acaa666
--- /dev/null
+++ b/devel/gnome-vfs/Makefile
@@ -0,0 +1,34 @@
+# New ports collection makefile for: gnomevfs
+# Date created: 28th June 2000
+# Whom: Ade Lovett <ade@FreeBSD.org>
+#
+# $FreeBSD$
+#
+
+PORTNAME= gnomevfs
+PORTVERSION= 0.1
+CATEGORIES= devel gnome
+MASTER_SITES= ${MASTER_SITE_GNOME}
+MASTER_SITE_SUBDIR= unstable/sources/gnome-vfs
+DISTNAME= gnome-vfs-${PORTVERSION}
+
+MAINTAINER= ade@FreeBSD.org
+
+LIB_DEPENDS= gnome.4:${PORTSDIR}/x11/gnomelibs
+
+GLIB_CONFIG?= ${LOCALBASE}/bin/glib12-config
+GTK_CONFIG?= ${X11BASE}/bin/gtk12-config
+
+USE_GMAKE= yes
+USE_X_PREFIX= yes
+USE_LIBTOOL= yes
+INSTALL_SHLIBS= yes
+CONFIGURE_ARGS= --localstatedir=${PREFIX}/share/gnome \
+ --datadir=${PREFIX}/share/gnome \
+ --disable-gconf
+CONFIGURE_ENV= CPPFLAGS="-I${LOCALBASE}/include" \
+ GLIB_CONFIG="${GLIB_CONFIG}" \
+ GTK_CONFIG="${GTK_CONFIG}" \
+ LIBS="-L${LOCALBASE}/lib"
+
+.include <bsd.port.mk>